Solved WorldGuard MySQL Help

Discussion in 'Bukkit Help' started by bad339, Mar 22, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    bad339

    I'm fairly new to MySQL and databases in general, but I know my way around well enough. Just by doing a google search, I already saw there are about 20 of these threads already but my issue is different. I receive 2 error strings from Worldguard + MySQL every time I start my server:


    http://pastebin.com/MWkzc445
    and
    http://pastebin.com/TRfk0LEJ

    I then queried region_storage_update_20110325.sql on my database, and this is the message I received back.

    WorldGuard doesn't generate any tables at all; does it want me to make all of the blank tables and then query it with region_storage_update_20110325.sql?


    My config:

    I understand if this is the wrong place to put it, since this is in general Bukkit issues and not plugin related issues, but I was just seeing if anyone on here knew the fix for this, since google didn't reveal anything. Lastly, sorry for my English, it is not my primary language.
     
  2. Offline

    PolarCraft

    Your in the right place. And second I wouldn't use MySQL unless needed. But worldedit does not need it.
     
  3. Offline

    bad339

    I know, I just want to use MySQL to store regions and such.
     
  4. Offline

    PolarCraft

    Okay easy fix.
    You need to update your database.
     
  5. Offline

    bad339

    It's not just "simply updating" it. It's running queries to generate tables. Anyways, I made more progress. I ran the region_storage query, THEN ran the region_storage_update, but now it comes back with:

     
  6. Offline

    PolarCraft

    Hmm. That should have worked. Unless it has changed.
     
  7. Offline

    bad339

    Stuck on that error. I have set up everything including the blacklist database just fine until I reached this.
     
  8. Offline

    PolarCraft

    Try undoing all of it and try again.
     
  9. Offline

    bad339

    Did that. Same error. I looked it up and this is also a common "stump" point for people.
     
  10. Offline

    PolarCraft

    Try doing a new mysql database.
     
  11. Offline

    bad339

    I've tried it on 2 different databases now: "worldguard" and "minecraft"
    Same error.
     
  12. Offline

    PolarCraft

    hmm.
    c0mp TnT

    [EDIT] That should get them to help.
     
  13. Offline

    Maihym

    Use WampServer.
     
  14. Offline

    Lolmewn Retired Staff

    I suggest not using MySQL with WorldGuard. It is known to... not work very well. Flatfile works awesome though.
     
  15. Offline

    Maihym

    What do you mean Flatfile?
     
  16. Offline

    Lolmewn Retired Staff

    Just simple files, non-databases.
     
  17. Offline

    andrewpo

    Once upon a time, I tried to use WorldGuard with MySQL - it was a horrible experience. :)
     
  18. Offline

    bad339

    I guess I will just switch to flatfile.

    I am, I'm using it for logblock and inventorySQL


    Thanks for the advice, I saw your post about using flatfile on some other threads having the same issue, but I was just seeing if I could get it to work.

    Anyways, I just switched to flatfile, and it already feels like a relief to have no startup errors.

    Thanks for everyone's help.
     
  19. Offline

    Maihym

    How do you swith to flatfile?
     
  20. Offline

    bad339

    Just set "use = false" under MySQL
     
  21. Offline

    Maihym

    Where?
     
  22. Offline

    PolarCraft

    HEHE! :D
     
  23. Offline

    bad339

    [​IMG]

    In the worldguard config.yml
     
  24. Offline

    PolarCraft

    bad is you issue solved?


    [EDIT]bad is you issue solved?
     
  25. Offline

    Maihym

    Ok thanks I use flatfile already for WorldGuard I just didn't know it.
     
  26. Offline

    bad339

    It is!
    TnT c0mp Mark as solved please.
     
  27. Offline

    c0mp

    No need to tag staff for marking your thread as solved. I've already done it for this one, but for future reference, just below the title at the top of the screen, on the right-hand side, you'll see Thread Tools. Hover the mouse over that, click Edit Thread, change it from No Prefix to Solved, and click Save.
     
  28. Offline

    PolarCraft

    Thank you. Have a nice day! :D
     
Thread Status:
Not open for further replies.

Share This Page