Solved Worldguard messages???

Discussion in 'Bukkit Help' started by _Ass4ssin_, Feb 10, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Hello people,

    I have some trouble with worldguard. I would like to remove the message that appears when you add/remove an owner. I tried using the source from github and change it with eclipse, but this is my first time doing this so I got some trouble. I was able to get all of the files into an eclipse workspace folder, but everything had errors and I think I did something wrong.

    Can somebody explain how to do this, or can somebody do this for me?
    The message I want to remove is the: Region ' + id + ' updated.
    It is inside this java part three times.
    Hopefully someone can give an easy step by step tutorial how to do this or just do it for me.

    Thanks in advance,
  2. Offline


    anyone? I really would like to learn/have this.
    thanks in advance.
  3. Offline


    Remove line 88 & 89?
  4. Offline


    there are 4 times the message exists, one for each command. if you want to remove them, just remove the entire
    + "Region '" + id + "' updated.");
    on all 4 appearances.
  5. Offline


    Well, I knew I should remove those, but I got all kinds of errors in the worldguard file and that is the problem.
    So, can one of you guys please explain how to change those?
    The errors I get are:
    ApplicableRegionSet cannot be resolved to a type
    Blacklist cannot be resolved to a type
    BlacklistLoggerHandler cannot be resolved to a type
    Block cannot be resolved to a type

    All of them a few times and I do not know how to fix it?
    I tried to ignore them at first but that didn't work the plugin was broken when I tried this.
    So I made some mistake with getting the source code?
    Could anyway tell me how to do this?
  6. Offline


    sounds like you failed to include a dependency or something.
  7. Offline


    Oh maybe it need world edit ? I can remember they depend on each other or one on the other...
    let me try and come back with the result!

    Did not fix it, but I think I may found the problem... Let me try something

    I fixed at least a lot of errors by changing something. I took the src from github with eclipse and it had package like* I remove the main and java folder out of my workspace what fixed a lot. Yet I have some errors, I guess from a dependency I am missing... I will try to find those.
  8. Offline


    Well thanks for the help, I think I can fix it now ^^
Thread Status:
Not open for further replies.

Share This Page