Problem/Bug Worldedit error

Discussion in 'Bukkit Help' started by PlyMC, Jan 26, 2020.

  1. Offline

    PlyMC

    I'm trying to set up a server on my PC, and I wanted WorldEdit and WorldGuard to protect my stuff. I tried getting a wand, but the command wasn't recognized. I checked the logs, and this is the error that showed up:
    Code:
    [10:46:18] [Server thread/ERROR]: Could not load 'plugins\worldedit-bukkit-7.0.1.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: org/apache/logging/log4j/spi/AbstractLoggerAdapter
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_201]
    Caused by: java.lang.NoClassDefFoundError: org/apache/logging/log4j/spi/AbstractLoggerAdapter
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_201]
        at java.lang.ClassLoader.defineClass(ClassLoader.java:763) ~[?:1.8.0_201]
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_201]
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:468) ~[?:1.8.0_201]
        at java.net.URLClassLoader.access$100(URLClassLoader.java:74) ~[?:1.8.0_201]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:369) ~[?:1.8.0_201]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:363) ~[?:1.8.0_201]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_201]
        at java.net.URLClassLoader.findClass(URLClassLoader.java:362) ~[?:1.8.0_201]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_201]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_201]
        at com.sk89q.worldedit.slf4j.impl.StaticLoggerBinder.<clinit>(StaticLoggerBinder.java:36) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.bind(LoggerFactory.java:150) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.performInitialization(LoggerFactory.java:124) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:412) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.getLogger(LoggerFactory.java:357) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.getLogger(LoggerFactory.java:383) ~[?:?]
        at com.sk89q.worldedit.bukkit.WorldEditPlugin.<clinit>(WorldEditPlugin.java:96) ~[?:?]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_201]
        at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_201]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        ... 6 more
    Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.spi.AbstractLoggerAdapter
        at java.net.URLClassLoader.findClass(URLClassLoader.java:382) ~[?:1.8.0_201]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_201]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_201]
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_201]
        at java.lang.ClassLoader.defineClass(ClassLoader.java:763) ~[?:1.8.0_201]
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.8.0_201]
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:468) ~[?:1.8.0_201]
        at java.net.URLClassLoader.access$100(URLClassLoader.java:74) ~[?:1.8.0_201]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:369) ~[?:1.8.0_201]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:363) ~[?:1.8.0_201]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_201]
        at java.net.URLClassLoader.findClass(URLClassLoader.java:362) ~[?:1.8.0_201]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_201]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_201]
        at com.sk89q.worldedit.slf4j.impl.StaticLoggerBinder.<clinit>(StaticLoggerBinder.java:36) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.bind(LoggerFactory.java:150) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.performInitialization(LoggerFactory.java:124) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.getILoggerFactory(LoggerFactory.java:412) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.getLogger(LoggerFactory.java:357) ~[?:?]
        at com.sk89q.worldedit.slf4j.LoggerFactory.getLogger(LoggerFactory.java:383) ~[?:?]
        at com.sk89q.worldedit.bukkit.WorldEditPlugin.<clinit>(WorldEditPlugin.java:96) ~[?:?]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_201]
        at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_201]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        ... 6 more
    [10:46:18] [Server thread/ERROR]: Could not load 'plugins\worldguard-bukkit-7.0.2.jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: WorldEdit
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:219) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8-R0.1-SNAPSHOT-latest.jar:git-Spigot-db6de12-18fbb24]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_201]
    I'm not necessarily fluent in this, so help would be greatly appreciated.
     
  2. Online

    timtower Moderator Moderator

    @PlyMC Get a worldedit and worldguard version made for 1.8, not for 1.15
     
    PlyMC likes this.
  3. Offline

    PlyMC

    Thank you! This fixed my problem rather than downloading the latest version.
     

Share This Page