Why is my config.yml broken? :( [Kits]

Discussion in 'Bukkit Help' started by Adder_, Apr 17, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    Adder_

    kits:
    tools:
    delay: 172800
    items:
    - 272 1 name:&7Starter-Sword
    - 273 1 name:&7Starter-Shovel
    - 274 1 name:&7Starter-Pickaxe
    - 258 1 name:&7Starter-Axe
    - 364 16 name:Starter-Steak
    VIP:
    delay: 172800
    items:
    - 257 1 efficiency:2 unbreaking:3 fortune:2 name:&aVIP-Hacka
    - 267 1 sharpness:2 unbreaking:3 looting:2 name:&aVIP-Svard
    - 258 1 efficiency:2 unbreaking:3 name:&aVIP-Yxa
    - 256 1 efficiency:2 unbreaking:3 name:&aVIP-Spade
    - 364 32 name:VIP-GrillBiff
    - 306 1 protection:2 unbreaking:3 name:&aVIP-Hjalm
    - 307 1 protection:2 unbreaking:3 name:&aVIP-Harnesk
    - 308 1 protection:2 unbreaking:3 name:&aVIP-Byxor
    - 309 1 protection:2 unbreaking:3 name:&aVIP-Skor
    - 265 64
    VIP+:
    delay:
    items:
    - 278 1 efficiency:4 unbreaking:3 fortune:4 name:&aVIP&6+&a-Hacka
    - 266 1 sharpness:4 unbreaking:3 looting:4 name:&aVIP&6+&a-Svard
    - 258 1 efficiency:4 unbreaking:3 name:&aVIP&6+&a-Yxa
    - 256 1 efficiency:4 unbreaking:3 name:&aVIP+-Spade
    - 364 42 name:&aVIP&6+&a-GrillBiff
    - 306 1 protection:4 unbreaking:3 name:&aVIP+-Hjalm
    - 307 1 protection:4 unbreaking:3 name:&aVIP+-Harnesk
    - 308 1 protection:4 unbreaking:3 name:&aVIP+-Byxor
    - 308 1 protection:4 unbreaking:3 name:&aVIP+-Skor
    - 42 15
    - 264 5
    This is how it looks like. It happend then I was adding Kit: VIP+ :(
     
  2. Offline

    MaliciousMan

    Paste this to a pastebin to preserve the formatting, such as spacing so I may check it for those errors. Also VIP+ has a delay, but no number is specified.
     
  3. Offline

    JOPHESTUS

    I don't think having a blank value will mess up any formatting
     
  4. Offline

    MaliciousMan

    You don't think so, I do. No one knows for sure. There's no harm in trying.
     
  5. Offline

    JOPHESTUS

    After looking at my configs which work flawlessly, I can say with certainty, blank option doesn't make any difference.
     
  6. Offline

    MaliciousMan

    If you don't want a delay, you must put a 0 for the delay, not leave it blank. If you want it usable only once, use a negative number, which makes the delay infinite.

    If Adder_ ever replies, here's a good reference:
    Code:
    kits:
      <kit name>:
        delay: <delay between usage>
        items:
          - <item number> <amount> <meta>
          - <item number> <amount> <meta>
     
  7. Offline

    cMan_

  8. Offline

    Adder_

    ok so I've edited the document a bit, but it still does not work, Pastebin: http://pastebin.com/2BQhhCrn
     
  9. Offline

    Necrodoom

    What is the exact issue you are getting?
     
  10. Offline

    JaguarJo Retired Staff

    MaliciousMan likes this.
  11. Offline

    samomezz

    In whatever you are configuring it in, You might not be able to see it, but once you have it all lined up, in your items section,
    - 276 1
    Like one of those, you can see the spaces behind it, yet there's some spaces not being used, so Java, being the picky language it is, doesn't accept that, so, you have to backspace
    - 276 1
    Until it looks like this:
    - 276 1
    Then, you need to space it back to original area, and that is one invisible spacing error that I get a lot.
    Also, the
    Kitname:
    and all the others, need to be spaced out perfectly.
    Hope this helped!
     
  12. Offline

    Adder_

Thread Status:
Not open for further replies.

Share This Page