When will Bukkit be updated for Minecraft 1.5?

Discussion in 'Bukkit News' started by EvilSeph, Apr 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    Update:
    We have completed the update to Minecraft 1.5_02 (and have had it done for a while now) and are working out a few issues before we promote a recommended build. A TEST ONLY build is available but we highly recommend that you wait until we promote a Recommended Build before putting it on your production server.

    You can find the latest test build on ci.bukkit.org. Please note, though, that if you don't already know how to get it, you probably shouldn't be using it. Only Recommended Builds have gone through extensive testing. Anything else could result in unforeseen problems like Bukkit eating your cake or your world. You have been warned.

    ---------------------------

    Common Problems/Questions:
    What's the first build that works with Minecraft 1.5_02
    The first CraftBukkit build that works with Minecraft 1.5_02 was made available 2 days ago and is build #689. However, it is HIGHLY RECOMMENDED that if you are running the test builds, you always stay up to date as we usually fix bugs, exploits and improve stability.

    I downloaded build 714 but got some other build!
    You're probably reading the version string incorrectly.

    Here's an example version string:
    git-Bukkit-0.0.0-686-g71ef92a-b714jnks (MC: 1.5_02)

    This version string is for build 714, as you can tell by the "b714jnks" at the end.

    Whenever I use a plugin that changes blocks, I can't see the changes until I reconnect!
    We had an issue with blocks not updating properly but this has since been fixed from build #707. This bug affected plugins that changed blocks in game, like WorldEdit.

    Help! My console keeps getting spammed with this error whenever someone gets kicked or disconnects and it lags the server!
    This is a bug we've fixed from build #701 onwards.

    I can't build or destroy anything! Help!?
    The common cause of this issue is a client mod called Single Player Commands, please try uninstalling all your client mods and seeing if this fixes the issue. If this is the case, then it isn't a Bukkit issue and you should contact the author of the mods you use.

    Every time I connect to the server and load a sign, the client crashes. What's wrong?
    Minecraft 1.5 has added limits for sign text. Plugin developers commonly used longer sign text to store extra data or add colours to signs. This is no longer possible, so we now cut off any line in a sign longer than 15 characters (as of build #712).

    I get kicked when flying and am told that flying hasn't been enabled on this server. How do I enable flying?
    Minecraft 1.5 added anti-flying checks. You can enable flying by setting allow-flight=true in server.properties.

    Whenever I try to send a long message in chat, it gets cut off at roughly two lines.
    A limit on chat has been added with Minecraft 1.5. This is one of the issues we're hoping to address before we promote a Recommended Build.

    Help! When I use the CLI arguments to set ports (or any setting), the server always starts up on 25565 or ignores the setting!
    There was a bug that prevented the server from reading settings passed through CLI arguments. This has since been fixed from build #706 onwards.

    The easiest fix for most problems is to update to the latest Bukkit test build.

    --------------------------------

    As is the case with every Minecraft update, we saw our usual influx of extra traffic from people wondering if we have a build of CraftBukkit working with the Minecraft update seconds after release (seriously). Usually, you'd see a pretty standard post from me stating we're working on an update and providing the usual advice that you aren't forced to update. However, this time there was a distinct lack of communication from the team regarding the status of the update, other than the usual "we're working on it". Couple this with the slow development occurring lately and we can forgive people for posting the expected "is Bukkit dead?" or "what's going on?" posts. I hope this post will explain everything.

    Will there be a CraftBukkit for Minecraft 1.5?
    Given the reports of showstopping bugs present in 1.5, there's a high chance a new bugfix update for Minecraft will be out tomorrow or even several times this week. As a result, it is unlikely we will be releasing a 1.5 compatible build and, instead, will be waiting for something stable to work with.

    Due to the nature of the project and the methods we use to provide Bukkit for Minecraft, any update - no matter how small - requires us to figure out the mapping of obfuscated classes and update our code. This takes a lot of time and work, so hopefully you understand our decision.

    Having said all this, we recommend that you stay on 1.4 for a while until the patch storm subsides if your server depends on Bukkit.

    Further, I wanted to apologise for the lack of communication regarding this update. I was really hesitant announcing this since it would only serve to disappoint and annoy people, however, I noticed quite a few supportive comments on here and IRC that pushed me to post this announcement because the people that have supported us through everything deserve it.

    Why are things so quiet? Why is the update taking so long?
    Before I answer this, I think it is appropriate to cover what usually happens when we're aware of an update coming soon. Whenever we recieve word of a Minecraft update (which, contrary to popular belief, is generally the same time as everyone else), we place all development in the Bukkit project under a code freeze to prepare for the update and make things easier. That being said, last week thursday we were expecting a Minecraft update and appropriately placed the project under a code freeze. Unfortunately, the update was delayed and pushed to the next week, resulting in a much longer code freeze than normally occurs. Naturally, this lead to activity within the project seeming critically lower than it really was and prompted some people to post the inevitable "what's going on?" thread.

    On top of the code freeze, we're working on some larger changes to Bukkit or CraftBukkit that require quite a bit of time to complete and will only be commited to the public code when they are ready. Quite often you'll find that, while you don't see any updates, we definitely are still working hard programming awesome things and appreciate your patience and support.

    So why is this update taking so long? After we had updated for Minecraft 1.4, we came across some annoying chunk related issues and bugs that were incredibly difficult to pinpoint due to confusion with the new obfuscated names mappings (d -> c and c -> d). Naturally, these kinds of issues were unacceptable for the project and we immediately got to work on improving our update process to avoid issues of this nature in the future. While I think we can all agree with this decision, the unfortunate result is the delay we're currently facing since we're not yet done improving the process. The good news is, we're nearly done improving our update handling process and the wait will definitely be worth it come future updates.

    Thank you for your patience and understanding!
     
    Azukay, Nuinbot, pcgames3112 and 54 others like this.
  2. Offline

    Deathlysteve-

    haha I JUST BOUGHT Portal 2 tonight... but I need to wait for my brother to come home to get a backkup off him from steam... because I dont have a massive download plan... -.- so Im just going to wait on here for now lol
     
  3. Offline

    giuliano

  4. Offline

    Thom8203dk

    1.5_01 is already Out ?
     
  5. Offline

    alpenghandi

    yes
     
  6. Offline

    Deathlysteve-

    lol 1.5_02 is out...? then why wont my minecraft UPDATE to 1.5_02? can anyone else update atm?
     
  7. Offline

    alpenghandi

    its out for vanilla servers (http://www.minecraft.net/download.jsp).
     
  8. Offline

    Deathlysteve-

  9. Offline

    par0noid

    lol guys, chill, you're expecting a update within 5 minutes? lol
     
  10. Offline

    alpenghandi

    thats right.
     
  11. Offline

    Deathlysteve-

    ok I guess thats good... now just to wait for bukkit... :p wait if i have bukkit i dont really need to download the minecraftserver.exe (1.5_02) dont I?
     
  12. Offline

    Dreadreaver

    correct
     
  13. Offline

    alpenghandi

    only if you want a server you can play on atm.
     
  14. Offline

    Deathlysteve-

    naa Ill just wait the 48 Hours for Bukkit :) start playing Portal 2 for a bit when I can :D now its jus the wait for bukkit but meh what can you do :)
     
  15. Offline

    tiltomat

    Deathlysteve- likes this.
  16. Offline

    studog

    So not trying to piss anyone off or anything but... FYI just because Minecraft 1.5_## is out does not mean its stable let alone more of a starting point for bucket then 1.5 is. Just kick back and relax. The Bukkit team knows far in advance before the general public does that an updated is being pushed. They knew about 1.5 and even 1.5_1 before just about everyone else. Have faith that they will come through for us as they have many times before. Also just because they know of the update also does not mean they have inside access to the code. They get to see it the same time the rest of us do. They just get to prepare for it a little better as stated in comment that this thred is off of.

    As for the ones who updated your client there is a link back on page 3 for fall back to 1.4.

    That being said I would like to thank LPMC for that as I made the mistake my self of updating my client and I am a server admin that runs his own server that should know better. LOL just not awake when I did it.

    Again I would like to thank the Bukkit team for everything they have done and also all of the MOD writers out there. With out them Bukkit would be useless.
     
  17. Clients are still at 1.5_01 but servers are at 1.5_02.

    That's why the tweet says "Minecraft server beta 1.5_02 is out." and not "Minecraft 1.5_02 is out."
     
  18. Offline

    Deathlysteve-

    well said.
     
  19. Heh, whatever works for you, I guess. :) Our peeps are loving the snow, and last I heard building a cozy nordic tavern type thing. And they won't lose any of it when the Bukkit server comes back.
     
  20. Offline

    BStramke

    Go out and do something else than waiting for bukkit. For Example placing Ladders where they are supposed to be as the "only every 2nd block" behavior got fixed ;).

    Also: "Whenever we recieve word of a Minecraft update (which, contrary to popular belief, is generally the same time as everyone else)" <<< Bukkit team does not know if there are new Updates planned or such things. Read the Article on the Frontpage...
     
  21. Offline

    jamescosten

  22. Offline

    cvenomz

    Thanks for the update announcement
     
  23. Offline

    Paul_VB

    hey how do i down grade to 1.4_01? i know its been talked about in this topic before, but i didnt understand how it was resolved. can someone plz explain it to me?

    EDIT: nmv i figured it out for myself. if anyone wants to know how, all i did was go to my minecraft bin folder, right clicked it and got a "previous version" from april 18th. this works for windows 7, and probably for vista as well, but i have ABSOLUTLY NO IDEA wether this would work for macs or linux.
     
  24. Offline

    rockxz2135

    whoo yay 1.5_02 fixed crashing the first stable version go bukkit go bukkit GO!!... when ur ready...
     
  25. Offline

    Simanova

    You need the "/bin" folder from 1.4_01 - Someone has to upload it
     
  26. Offline

    DarkRender

    lol already released 0.o dam notch is fast
     
  27. Offline

    Deathlysteve-

    If you want to downgrade your minecraft the link for the tool to do it is here...
     
  28. Offline

    par0noid

    hope that 1.5_02 will be accepted as a "stable" minecraft :)
     
    Paul_VB likes this.
  29. Offline

    typhoonwes

    I have a Temp copy of the bin folder here

    ** You must own a copy of MineCraft to Download **
     
  30. Offline

    iman66

    Hi, I use your server software and I'm a big fan of it (like we all are). I totally understand the reasons to why it's not coming out right away, but I have a quick question if someone doesn't mind answering. I'm taking the advice to stay with 1.4 as previously mentioned in the first post. But my issue is whenever I use either the launcher or the browser versions of Minecraft, it says, "Do you want to update now?". I read to click "Not Now", so I did (on both the launcher and the browser versions). Then when the company logo popped up and then went to the Minecraft start page, I see in the top left hand corner "Minecraft Update 1.5". I didn't want to update to 1.5... How would I fix this? I deleted and reinstalled the launcher twice now and it's doing the same thing... Help please?

    Thanks much,
    iman66
     
  31. Offline

    typhoonwes

    Get someones Bin folder and replace yours

    You can get a copy of one here
     
Thread Status:
Not open for further replies.

Share This Page