Solved weird crash report with 1.12.2 bukkit server

Discussion in 'Bukkit Help' started by Hapun, Sep 30, 2017.

Thread Status:
Not open for further replies.
  1. Offline


    so i was playing with 5 of my friends on the craftbukkit SMP server i host myself. i shut it down to add a few plugins and after they were added i started the server up again. i got this giant weird crash report:

    ---- Minecraft Crash Report -------- Minecraft Crash Report ----// Daisy, daisy... Time: 30/09/17 2:41 PMDescription: Exception in server tick loop End of input at line 1 column 1 path $ at net.minecraft.server.v1_12_R1.ChatDeserializer.a(SourceFile:506) at net.minecraft.server.v1_12_R1.ChatDeserializer.a(SourceFile:522) at net.minecraft.server.v1_12_R1.JsonList.load( at net.minecraft.server.v1_12_R1.DedicatedPlayerList.A(SourceFile:99) at net.minecraft.server.v1_12_R1.DedicatedPlayerList.(SourceFile:25) at net.minecraft.server.v1_12_R1.DedicatedServer.init( at at Source)Caused by: End of input at line 1 column 1 path $ at at at at$ at$ at net.minecraft.server.v1_12_R1.ChatDeserializer.a(SourceFile:504) ... 7 more[/p] [p]A detailed walkthrough of the error, its code path and all known details is as follows:--------------------------------------------------------------------------------------- -- System Details --Details: Minecraft Version: 1.12.2 Operating System: Windows 10 (amd64) version 10.0 Java Version: 1.8.0_144, Oracle Corporation Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation Memory: 1905432984 bytes (1817 MB) / 2058354688 bytes (1963 MB) up to 2058354688 bytes (1963 MB) JVM Flags: 2 total; -Xms2048M -Xmx2048M IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0 CraftBukkit Information: Running: CraftBukkit version git-Bukkit-a3b3a42 (MC: 1.12.2) (Implementing API version 1.12.2-R0.1-SNAPSHOT) true Plugins: {} Warnings: DEFAULT Reload Count: 0 Threads: { RUNNABLE DestroyJavaVM: [], RUNNABLE Attach Listener: [], WAITING Thread-4: [ Method), Source), Source), Source), Source), org.fusesource.jansi.AnsiOutputStream.write(, Source), Source), Source), Source),, Source)], WAITING Snooper Timer: [java.lang.Object.wait(Native Method), java.lang.Object.wait(Unknown Source), java.util.TimerThread.mainLoop(Unknown Source), Source)], RUNNABLE Signal Dispatcher: [], RUNNABLE Server console handler: [org.fusesource.jansi.internal.Kernel32.ReadConsoleInputW(Native Method), org.fusesource.jansi.internal.Kernel32.readConsoleInputHelper(, org.fusesource.jansi.internal.Kernel32.readConsoleKeyInput(, org.fusesource.jansi.internal.WindowsSupport.readConsoleInput(, org.bukkit.craftbukkit.libs.jline.WindowsTerminal.readConsoleInput(, org.bukkit.craftbukkit.libs.jline.WindowsTerminal.access$000(, org.bukkit.craftbukkit.libs.jline.WindowsTerminal$,,,,,, org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readCharacter(, org.bukkit.craftbukkit.libs.jline.console.ConsoleReader.readLine(, net.minecraft.server.v1_12_R1.DedicatedServer$], RUNNABLE Server thread: [java.lang.Thread.dumpThreads(Native Method), java.lang.Thread.getAllStackTraces(Unknown Source),, net.minecraft.server.v1_12_R1.CrashReportSystemDetails.a(SourceFile:78), net.minecraft.server.v1_12_R1.CrashReport.h(, net.minecraft.server.v1_12_R1.CrashReport.(,, Source)], WAITING Reference Handler: [java.lang.Object.wait(Native Method), java.lang.Object.wait(Unknown Source), java.lang.ref.Reference.tryHandlePending(Unknown Source), java.lang.ref.Reference$ Source)], RUNNABLE Netty Server IO #0: [$SubSelector.poll0(Native Method),$SubSelector.poll(Unknown Source),$SubSelector.access$400(Unknown Source), Source), Source), Source),,,, io.netty.util.concurrent.SingleThreadEventExecutor$, Source)], WAITING Finalizer: [java.lang.Object.wait(Native Method), java.lang.ref.ReferenceQueue.remove(Unknown Source), java.lang.ref.ReferenceQueue.remove(Unknown Source), java.lang.ref.Finalizer$ Source)], TIMED_WAITING Server Infinisleeper: [java.lang.Thread.sleep(Native Method), net.minecraft.server.v1_12_R1.DedicatedServer$], WAITING NonBlockingInputStreamThread: [java.lang.Object.wait(Native Method),, Source)],} Recent tasks from -31--1{} Profiler Position: N/A (disabled) Is Modded: Definitely; Server brand changed to 'CraftBukkit' Type: Dedicated Server (map_server.txt)

    and the only changes i made were the plugins i added. i proceeded to remove ALL of them, and still got the same error.

    works fine, adds plugins, goes horribly wrong, removes plugins, still goes horribly wrong. kinda annoying. help appreciated :D
  2. Offline


    The stacktrace makes it seem like your 'banned-players.json' contains messed up syntax. Try deleting it.
  3. Offline


    easiest fix in my life. thank you so much dude, surprising that one little mistake in the bans screwed up the server.
Thread Status:
Not open for further replies.

Share This Page