Inactive [WEB/SEC/ADMN] MCbb v.1.12 phpbb/mybb Forum White and Greylist Connection Server<->Forum[1.2.5]

Discussion in 'Inactive/Unsupported Plugins' started by blargh, Jan 4, 2012.

  1. Offline


    Yes but user details are in a different table where do I input the table in the config? Also what to do with verifyuser, sorry I've never seen that before and I think anon login is disabled for me
  2. Offline


    23:11:10 [INFO] mcbb lookup [PLAYERNAME] -> Displays whether player has Forum Account or not
    >mcbb lookup xxxxxxxx
    23:11:23 [WARNING] Unexpected exception while parsing console command
    org.bukkit.command.CommandException: Unhandled exception executing command 'mcbb' in plugin MCbb v1.8.0.0
            at org.bukkit.command.PluginCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.MinecraftServer.b(
            at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.NullPointerException
            at de.javakara.manf.mcbb.MCbbCommands.onCommand(
            at org.bukkit.command.PluginCommand.execute(
            ... 7 more
    That was upon using the lookup command (as you can see). Doesn't bug me personally, because I doubt I'll be using that often. Nevertheless, I thought it would be useful to know. That's with the 1.9.1 dev.
  3. Offline


    Flobi i hate this command personally, because its complicates everything :D

    aciid First the anon User was a test for phpbb users, but other scripts dont have something like this, you can change it to an existing user. The anonymous user can be changed to an any other user(even to yourself) , it just tests if it can connect to database, and looks for the username then. You just need to enter the field id(you can see that in the URL e.g.) its in the config a value you can change( You dont need to enter a database table by yourself
  4. Offline

    Nick Hooper

    When trying to make a new group in phpbb i get this error:
    General Error
    SQL ERROR [ mysqli ]
    Field 'servergroup' doesn't have a default value [1364]
    How can i make the 'servergroup' field that was added have a default value?
  5. Offline


    Nick Hooper the fasted way is just remove servergroup and add it afterwards, i had a fix for this, but i have forgot which it was exactly
  6. Offline


    Sorry I'm still lost :(

    I have the forum mysql database, in this there is
    -table mybb_users containing usernames/passwords/uid/etc (fid = username, password, ip,regdate)
    -table mybb_userfields containing custom profile input like minecraft name/youtube video/country/etc (fid = fid1, fid2, fid3)

    How would that work?
  7. Offline


    aciid use id 1 in the config?
  8. Offline


    Hey blargh

    I love how active you are!

    But i hate how i can't get this to work LOL

    Here is my problem... as mentioned above by other people... this is what i get when a player joins.

    13:18:06 [INFO] agrro5 [/] logged in with entity id 134 at ([Industrial] -308.71875, 65.0, 684.25)
    13:18:06 [SEVERE] Could not pass event org.bukkit.event.player.PlayerJoinEvent to MCbb
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.ServerConfigurationManager.c(
        at net.minecraft.server.NetLoginHandler.b(
        at net.minecraft.server.NetLoginHandler.a(
        at net.minecraft.server.NetworkListenThread.a(
        at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
        at java.lang.reflect.Method.invoke(
        ... 9 more
    Caused by: java.lang.NullPointerException
        at de.javakara.manf.mcbb.GreyPlayerListener.onPlayerJoin(
        ... 14 more
    I have tried your stable 1.8 builds, I have tried 1.9, and even 1.9.1 and still get the same error.

    I also updated PEX to the latest, happens on both older version and newest.

    Here is my mcbb config file, but dont think it has something to do with that.

        teach: 'Teaching MCbb '
        start: '[MCbb] Validating Configs'
        confSucess: '[MCbb] Configs validated'
          host: '[MCbb] Creating MySQL Host'
          port: '[MCbb] Creating MySQL Port'
          user: '[MCbb] Creating MySQL User'
          password: '[MCbb] Creating MySQL Password'
          database: '[MCbb] Creating MySQL Database'
          prefix: '[MCbb] Creating MySQL Prefix'
          testedSucess: '[MCbb] MySql was tested by User Verifikation Anonymous!'
        loading: '[MCbb] Loading Configs'
        loadSucess: '[MCbb] Configs loaded'
        seton: '[MCbb] turned on'
        'on': '[MCbb] Plugin is currently activated'
        'off': '[MCbb] Plugin is currently deactivated'
        setoff: '[MCbb] turned off'
        registerFirst: '[MCbb] First register on the Forum!'
        auth: '[MCBB] Player <player> is authenticated!'
        kick: Server is Reloading; Please register on the Forum!
        whitelist: Not on Whitelist! Register on the Forum;
        newUpdate: '[MCbb] New Update!'
        greyActivated: '[MCbb] Greylist activated'
        whiteActivated: '[MCbb] Whitelist activated'
        unknownType: Type is unknown! Disabeling Plugin
        noPerm: '&2[MCbb] Permission error!'
        version: Version
        currversion: 'Current Version: '
        latestversion: 'Latest Version: '
        enabled: '[MCbb] loaded ->'
        disabled: '[MCbb] unloaded ->'
      forumtyp: phpbb
      verifyuser: anonymous
      host: *******
      port: 3306
      user: *******
      password: *******
      database: *******
      prefix: *******
      type: Greylist
      authType: Field
      syncGroups: 'false'
          damageEntities: 'true'
          lootItems: 'true'
          dropItems: 'true'
          chat: 'true'
          interact: 'true'
          command: 'true'
      id: 2
      moneyPerPost: '0'
  9. Offline


    What I meant is mybb_users contains the forum usernames
    But I want to match the player login with the Minecraft username in mybb_userfields and the password from mybb_users :(
  10. Offline


    aciid what do you want with passwords oO
    BigBenM Other plugins , do you have vault? and could you post a sql database of the User database and the field db
  11. Offline


    Oh I thought this plugin had /login password command, fuck lol so stoned
  12. Offline


    aciid this will be added if i fixed that weird bug cause by unknown reasons
  13. Offline


    Just to let you know, I'll try to finish the video for tomorrow. :) I am very busy... :/
  14. Offline


    blargh can you help me whit your plugin?? my skype name is danilonba22
  15. Offline


    As promised! The video for the setup of MCBB with phpbb (GroupSync). The instructions are in French. If someone could translate it into English, it would be very apreciate.

    Prérequis :
    PermissionsEx (ou un autre plug-in de permission compatible avec superperms.)
    1) Mettez dans le dossier Plugins : MCbb, Vault et PermissionsEX (ou un autre plug-in de permissions compatible avec superperms).
    2) Démarrez le serveur pour générer les fichiers de configuration.
    3) Ouvrez le fichier de configuration de MCbb avec Notepad++.
    4) Modifiez les informations de la base de données MYSQL.
    5) Changez le authType pour Username et SyncGroups à True.
    6) Les protections de la greylist sont par défaut toutes à True. Libre à vous de les modifiés.
    7) Enregistrez le fichier
    8) Maintenant, allez modifier les permissions de PermissionsEx avec Notepad++ et créer vos groupes.
    9) Ajoutez la permission : mcbb.user.join dans les groupes.
    10) Enregistrez le fichier
    11) Faites un Reload de vos plug-ins dans la console.
    12) Allez dans PhpMyAdmin et cliquez sur la base de données du forum.
    13) Cliquez ensuite sur SQL, en haut dans les onglets.
    14) Tapez ce code : ALTER TABLE phpbb_groups ADD servergroup TEXT NOT NULL
    15) Cliquez sur Go
    16) Tapez ensuite ce code : UPDATE phpbb_groups set servergroup='default'
    17) Cliquez sur Go
    18) Allez dans la table phpbb_groups
    19) Cliquez sur ADMINISTRATORS (Edit) et tapez dans le champ (server_group) : administrator
    20) Cliquez ensuite sur Go
    21) Faites la même chose pour GLOBAL_MODERATORS
    22) Vous avez terminé! Lancez Minecraft pour essayer!
    Si un joueur n'est pas enregistré sur le forum, un message l'avertira de s'enregistrer (il ne pourra rien faire).
    Les Modérateurs et Administrateurs seront automatiquement placés dans leur groupe avec leurs permissions.
    Bon jeu à tous!
  16. Offline


    I Like this plugin but it doesnt seem to work with permission's 3 is there a way you could implement it into this plugin it would greatly be apreciated thank
  17. Offline


    @blargh I have sent you the phpBB3 database schema I am using.
  18. Offline


    KlaasT Im busy at the moment i will be more active on when i have more time
    TwiztedPsyko No. Permisson3 is history, pex/bpermissions etc are the ones, that are active
  19. Offline



    If you could please please please upload the files you are using. I tried starting completely over with only the following:

    Bukkit 1.1 R3
    Vault 1.2.8
    PEX 1.18 & 1.2 Dev

    I am still getting the

    [SEVERE] Could not pass event org.bukkit.event.player.PlayerJoinEvent to MCbb org.bukkit.event.EventException

    I tried re downloading Bukkit, fresh new install, not modded, no other plugins and still get the same error.

    Maybe Francois can send me his entire package (minus the mcBB server info of course).

    Someone please help!

    EDIT: Ill even allow someone to log into my PC with Team Viewer to help me... I cannot figure this out and im usually very good with plugins and server stuff.
  20. Offline


    BigBenM, KlaasT yes im a fool....
    I think i got that weired bug.
    change mysql.forumtyp to mysql.forumtype
    should work then
    danilonba i cant help you specially, sorry if you ask a specific question, yes of course
  21. Offline


    You would be correct!!! :) yay... but now I get "Incative" when i use mcbb lookup... I think my field link is incorrect

    Sorry one last help request: :)

    I have 2 custom profile fields in phpBB.

    I would like to use Minecraft name field... which is ID:2

    I know this because when i log intot the database using phpmyadmin, and go to phpbb_profile_fields, the ID is 2. My config for mcbb is set to field: id: 2 even tried '2'... and still when i log on, it says i have to register in order to do anything....

    I'm also pretty sure that my server connection setup is also accurate..

    Anybody have any suggestions?


    If i switch the type to Username, then it works and on playerjoin, I see Player Authenticated. and i can then interact with minecraft world...

    Why is the custom profile field ID not working?? please see my post on page 9 of this thread for my config file.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  22. Offline


    BigBenM could you trie just reconecting? dunno why but on my testserver it works then.
  23. Offline


    Nah, still doesn't work. Tried several attempts. Like I said, works with Username, but not custom field. You're sure you have it checking phpbb_profilefield table? Or what table do you query?

    Yeah its strange... if I have Username as the type... and do mcbb lookup bigbenm it comes back saying active!

    If i switch back to field type, and do lookup bigbenm it comes back inactive, even after restarting the server.

    Do you have your source code up anywhere? maybe i can poke around and figure out why

    I think i got it...

    Took me 3 hours to dissect your code but i got it!

    I will try to compare code to see what i changed... lol

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  24. Offline


    blargh That would be a good idea to put the video in the first post. I'll make the instructions in English probably this weekend.
  25. Offline


  26. Offline


    So, now this plugin also works fine for me. :) Thank You! It was the thing with typ/type. But I just getting an error when I use the command "mcbb lookup".

    >mcbb lookup test
    20:44:37 [INFO] [MCbb] Permission error!
  27. Offline


    TheHandsomePete mcbb lookup is a bit bugged. You need the permissions btw
  28. Offline


    blargh Also when I use it via console?
  29. Offline


    TheHandsomePete idc. my testing server worked, but alot of people said there is a bug

    Having some issues because i have no MC Account at the moment(myaccount went back to his original owner) will have to look how i get a new account

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  30. Offline


    Ok... I didn't even see that one :) Thanks. However now I've got a similar problem like BigBenM has :(.

    I'll try to explain it. It doesn't matter if I've got my nick written in my board profile. When I've set a value to "true" that action isn't allowed for anyone. If it is set to "false" it is allowed for everyone. So currently it works as if it was a general permission setting.

Share This Page