[TP] Wormhole X-Treme - Multi-World capable Stargates - Moved to BukkitDev!

Discussion in 'Inactive/Unsupported Plugins' started by lycano, Jul 1, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Wormhole X-Treme v1.016
    Multi-World capable Stargates for bukkit powered servers
    Craftbukkit 1846

    This project has been moved to BukkitDev
    Please visit the new project page on BukkitDev http://dev.bukkit.org/server-mods/wormhole_x-treme/

    Project moved to BukkitDev

    Attached Files:

    Last edited by a moderator: May 18, 2016
  2. Offline


    @lycano I have a feature request...
    Add a custom wormhole texture and opening/closing sound with Spout.

    @lycano Another feature request... This one from one of my users. We had a bit of a discussion about it...
    My user would like to be able to create his own network and pick and choose who has access to it, and who can build gates for it. I actually like this idea because I don't like having to change my permissions file every time someone adds a new gate network.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  3. Offline


    Sure take your time. I think we're all just happy to have this plugin back. Is there any plan to fix the "Invalid Gate Target" thing in any future updates? It's kind of annoying to have to reset the gate every time I restart the server/ leave the area for a while.

    Are you still planning on making ring platforms, if I may ask? mxRingplatforms is all well and good, but it can be a little touchy at times, it would be nice to have something more stable.
  4. Offline


    Out of curiosity, I tried enabling Wormhole X-Treme Worlds support in settings.txt. When I do this, I cannot use Wormhole X-Treme wormholes, and on load, I get this error:

    2011-08-05 02:53:28 [INFO] [WormholeXTreme][v1.011] Boot sequence initiated...
    2011-08-05 02:53:28 [WARNING] [WormholeXTreme] Not a supported version of Permissions. Recommended is 3.0.x
    2011-08-05 02:53:28 [INFO] [WormholeXTreme] Attached to Permissions version 3.1.6
    2011-08-05 02:53:28 [INFO] [WormholeXTreme] Complex Permissions Enabled
    2011-08-05 02:53:28 [INFO] [WormholeXTreme] Help Plugin support disabled via settings.txt.
    2011-08-05 02:53:28 [INFO] [WormholeXTreme] Attached to Wormhole Worlds version 0.505
    2011-08-05 02:53:29 [WARNING] [WormholeXTreme] Caught Exception while trying to load support plugins.null
    2011-08-05 02:53:29 [SEVERE] java.lang.NullPointerException
    2011-08-05 02:53:29 [SEVERE]     at de.luricos.bukkit.WormholeXTreme.Wormhole.utils.DataUtils.blockFromBytes(DataUtils.java:45)
    2011-08-05 02:53:29 [SEVERE]     at de.luricos.bukkit.WormholeXTreme.Wormhole.logic.StargateHelper.parseVersionedDataV8(StargateHelper.java:1251)
    2011-08-05 02:53:29 [SEVERE]     at de.luricos.bukkit.WormholeXTreme.Wormhole.logic.StargateHelper.parseVersionedData(StargateHelper.java:758)
    2011-08-05 02:53:29 [SEVERE]     at de.luricos.bukkit.WormholeXTreme.Wormhole.model.StargateDBManager.loadStargates(StargateDBManager.java:204)
    2011-08-05 02:53:29 [SEVERE]     at de.luricos.bukkit.WormholeXTreme.Wormhole.plugin.WormholeWorldsSupport.enableWormholeWorlds(WormholeWorldsSupport.java:83)
    2011-08-05 02:53:29 [SEVERE]     at de.luricos.bukkit.WormholeXTreme.Wormhole.plugin.WormholeWorldsSupport.enableWormholeWorlds(WormholeWorldsSupport.java:69)
    2011-08-05 02:53:29 [SEVERE]     at de.luricos.bukkit.WormholeXTreme.Wormhole.WormholeXTreme.onEnable(WormholeXTreme.java:190)
    2011-08-05 02:53:29 [SEVERE]     at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
    2011-08-05 02:53:29 [SEVERE]     at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:878)
    2011-08-05 02:53:29 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
    2011-08-05 02:53:29 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:162)
    2011-08-05 02:53:29 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:146)
    2011-08-05 02:53:29 [SEVERE]     at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:284)
    2011-08-05 02:53:29 [SEVERE]     at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:271)
    2011-08-05 02:53:29 [SEVERE]     at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:148)
    2011-08-05 02:53:29 [SEVERE]     at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:335)
    2011-08-05 02:53:29 [SEVERE]     at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    2011-08-05 02:53:29 [INFO] [WormholeXTreme][v1.011] Boot sequence completed
    2011-08-05 02:53:29 [INFO] [WormholeXTremeWorlds][v0.505] Enabling plugin ...
    2011-08-05 02:53:29 [WARNING] [WormholeXTremeWorlds] Not a supported version of Permissions. Recommended is 3.0.x
    2011-08-05 02:53:29 [INFO] [WormholeXTremeWorlds] Attached to Permissions version 3.1.6
    2011-08-05 02:53:29 [INFO] Preparing start region for level 1 (Seed: -4721780654039860271)
    2011-08-05 02:53:30 [INFO] [WormholeXTremeWorlds] Auto-loaded 1 world.
    2011-08-05 02:53:30 [INFO] [WormholeXTremeWorlds][v0.505] Startup finished
    I'm aware that there used to be a message, at least in alron and Lologarithm's thread, that users shouldn't enable this feature as it wasn't ready yet, due to the absence of a compatible Wormhole X-Treme Worlds version. I looked at your two threads, and didn't see such a message. Is the implementation not complete yet? And, if it is or will be, what exactly does this option do, in terms of server performance and/or functionality?

    Lastly, I can't express how thankful I am after seeing these two plugins being picked up. That's all I can really say about that :D
  5. Offline


    I was actually looking more for the sound of the actual stargate, but that'll work too I suppose =)
  6. Offline


    @Elfsovereign shure i think i have time this weekend. Regarding the Ring stuff ... yeah ill keep that in mind but its currently not in my queue but the invalid target gate will be fixed.

    @HunterAP during refactoring ill change permissions so that you can have a group permission for all networks.

    @EcoMaster21 Wxw and wxt is fully tested with #953 and works with or without enabling "WXW support". The old thread is a way outdated. Nearly half of the code has changed. At least in 953 it was working perfectly. Didnt had time to check it with #1000 as the topic states.

    If you enable wormhole xtreme worlds support in wxt it will not use its native world loading feature instead it will register with wxw and use this for world handling.

    The error message seems to me like something is wrong with the gate itself when loaded from the database. Try to remove and recreate the gate.

    @cionxdistan well using custom sounds would mean that you have to modify your client or install server side midi files. Im currently not planning to implement any new features as the refactoring is not yet complete fully. After that I will fine tune some stuff for shure ^^

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  7. Offline


    Have you looked into Spout at all lycano? Spout allows you to add thing to the game that work for people with the SpoutCraft client. If they don't have the SpoutCraft client, then they can still play, they just won't have the special stuff.
  8. Offline


    Sounds fun =)
  9. Offline


    I use MultiVerse.
  10. Offline


    This error started to pop up when I use /wxw go WORLD. I have 5 worlds and it happens for all of em..Started around the time I installed worldguard and worldedit.

    Show Spoiler
    2011-08-06 07:22:59 [SEVERE] java.net.SocketException: Socket closed
    2011-08-06 07:22:59 [SEVERE] at java.net.SocketOutputStream.socketWrite(Unknown Source)
    2011-08-06 07:22:59 [SEVERE] at java.net.SocketOutputStream.write(Unknown Source)
    2011-08-06 07:22:59 [SEVERE] at java.io.BufferedOutputStream.flushBuffer(Unknown Source)
    2011-08-06 07:22:59 [SEVERE] at java.io.BufferedOutputStream.flush(Unknown Source)
    2011-08-06 07:22:59 [SEVERE] at java.io.DataOutputStream.flush(Unknown Source)
    2011-08-06 07:22:59 [SEVERE] at net.minecraft.server.NetworkWriterThread.run(SourceFile:116)
  11. Offline


    Firstly, fantastic mod.
    However, encountered problems shortly after using. Made a few stargates, they all worked great, then randomly they all stopped working. When I use the command /wxstatus it says that "Wxw-link" has failed, if that has anything to do with it (not sure what that is). Any help would be appreciated, since we now have a load of difficult to remove obsidian blocks in the shape of unusable stargates scattered all over our world! Thanks!
  12. Offline


    I put the jar file into my plugins folder then ran it (it created the folder) but once i ran the server my permissions (ranks) werent working? Any explanation?
  13. Offline


    Are you referring to the gate's shape files, or the gate itself in-game? I'm in for some fun if you're referring to in-game gates, cause I've got about 80 on the server :) It's pretty damn popular here.

    I'm not quite sure how to zero in on the offending gate, if this is indeed the case. I don't expect you to go out of your way to help, though. After all, this could simply have something to do with my use of the current recommended build, as opposed to 953. I'll toy around with things and see if I can't find out what's up. If I do, I'll be sure to come back here.
  14. Offline


    Sorry is it still okay with you to post custom gate design and ask for help, if not sorry for the stupid question.
    Thanks for the awsome pluggin and continued work.
  15. Offline


    @zootsuitman well you can post it here its the right place for it but dont expect a fast help cause its very time consuming to check for errors in this file. Normally (if a gate shape doesnt work) its because invalid block counts, double GateName (The shapes name is defined inside the file not taken from the filename!) or lost equal signs for Layer definition.

    @EcoMaster21 im referring to the gate itself. As DataUtils method at L45 checks for the Location of the block either your Gate contains wrong location data OR you enabled WorldsSupport without having a correct world xml description file. E.g. Support enabled but the world your target gate is in contains errors.

    Please provide more information.

    @fatmarley try to not autoload all worlds. SocketErrors are most likely coming from having too many worlds loaded or your having your server under heavy load.
  16. Offline


    @lycano i tracked it down to an issue with Spout...removing spout fixed the error. Funny enough it was actually a conflict between WorldGuard, Wormhole and Spout...

    Spout developers are aware and it should be fixed with the next update.
  17. Offline


  18. Offline



    There is a problem using the material lapiz with the method of transfer by sign. It does not recognize this method and uses the other method.

    Thank you.
  19. Offline


    It seems my "minimal" gate has changed on me some how. I don't know what happened.

    When I first installed the plugin, my gates looked like this:
    But, after a day or so, I decided to make more gates. The patter didn't work, though. I didn't change anything, either. So, I built the pillar with the button and had it auto-build the "minimal" gate, and it came out looking like this:
    What happened? If the "minimal" gate file did somehow get changed, could someone show me what it should say?
  20. Offline


    It was just earlier today that I built a Minimal Gate and it was fine.
  21. Offline


    Well, my previous gates work just fine. But I can no longer build that shape, and autobuilding a minimal gate makes it look all retarded-like.

    My minimal gate is:


    # These values are the relative positions of the button to the lower right corner of the design.
    # In the standard gate the corner is 1 down (-1 up) from the button, 1 to the right of the button, and 4 away.
    # Note that the DHD counts as a block, so in the standard gate there is the DHD block + 3 = total of 4 away.
  22. Offline


    @Fariel If you are having trouble with the default shape files just delete them from the plugins directory before reloading the server. They will be automatically recreated after start.
  23. Offline


    does this plugin support iconomy ??
    how to make royalty??
  24. Offline


    @forceserver iconomy is on my roadmap but not implemented yet
  25. Offline


    i add wormhole.simple.use in permission
    if user cilk button
    you lack the permissions to do this
  26. Offline



    Could you check over my gate, I cant get it to work properly.

    Sign gate (open)


    # Number of ticks to wait before activating each # of the woosh. 1 tick = ~50ms
    WOOSH_TICKS = 3;
    # Number of ticks to wait before activating each # of the lights. 1 tick = ~50ms
    LIGHT_TICKS = 2;

    # None of the follow materials are required, they will default if not set.
    # Portal material the material the [P] blocks will be when gate is active.
    # Suggested values are as follows: STATIONARY_WATER, STATIONARY_LAVA, PORTAL, and AIR

    # Iris material is the material the [P] block become when iris is active

    # Stargate material is the material the [O] blocks are made of

    # Active material is the material that :L blocks become when gate is active
    # Suggested Values are as follows: GLOWSTONE and GLOWING_REDSTONE_ORE

    # Redstone activated is the parameter to allow redstone to/from redstone locations.
  27. Offline


    Sometimes my gates don't work and sometimes they do.

    For example I hit a gate, dial everything is fine. When I get to the other gate 50% of the time I can't get it to activate. I hit the lever and hit the lever and nothing happens. If I reconnect to my server sometimes it will work, sometimes it doesn't and I need to restart the server before that gate will let me dial out from it.

    I've checked that the cooldown period isn't affecting anything so I'm confused as to why its acting funky. I'm using bucking build 953 as suggested.

    I don't believe any other plugins could be conflicting with it but I'm using AntiXRay, ChestLock, ClearInventory, CraftBook, CraftIRC, DynMap, General, iChat, LogBlock, MobLoot, NoCheat, NoWeather, NSCommand, Permissions (The last 2.x version), Stackable, Whitelist, WorldEdit and WorldGuard.

    I tried unloading all of these plugins leaving only the WormholeXTreme plugin installed and it still was flakey only working about 50-75% of the time.

    This is a great plugin so I hope my problem is something solvable :)
  28. Offline


    I have encountered this myself recently. It's more prevalent now that I've switched to build BK 1000. I'd say 90% of the time logging out and logging back in resolves the issue but some times a server reboot is required. I am also seeing an issue with general warping and the /home command, Error: Hole in floor. I would suspect that his has something to do with it since they both rely on the same basic principal. Probably more of a Bukkit issue than a WHX issue.
  29. Offline


    @DeathToKittens a hole in the floor tells you "hey you probably have a chunk error at this spot" this has nothing to do with the plugin iteself. Warping just uses the teleport command on command so there is no magic behind this ^^

    @VodkaDK im 100% shure that 1.011 works perfectly in 953 with PermissionsEx / Permissions 2.7.x, WorldGuard, WorldEdit, VirtualChest, Tele++, CommandBook.

    Im using onPlayerJoin / Kick / Quit for internal player registration and PlayerInteractEvent for button / gate activation. Maybe that helps you in finding your problematic plugin. If you use Essentials use CommandBook. Essentials is known for producing problems with other plugins.

    Procedure: PlayerJoin -> Register player as WormholePlayer -> Player activates gate -> can activate? -> set properties -> add stargate to object -> activate gate -> timeout gate -> remove gate from active gates and WP-Objects (if present)

    If this player quits or was kicked then the WormholePlayer will be de-registered.

    (( For advanced users: You can switch the log-level to FINE with /wxw debug FINE. Any action will be then visible if you monitor the server.log file with tail / editor on linux or with TailMe (windows).

    Dont forget to switch back to INFO (default) after debugging. If you can handle this or maybe you see a problem you can post the debug output at the failing point in SPOILER CODE tags here.
  30. Offline


  31. Offline


    Thank you for all your work with this plugin, so far you've added some great stuff! If I might suggest, it would be REALLY neat to have wormholes cost some sort of fuel. This way we could make some that have real DHD's like in the series, and others that need to be constructed that use "power" of some sort (an "engine" comprised of some iron block(s) and a chest with coal which burns away perhaps?)

    Overall it would be a really great addition to see people paying something for their gate use. This would be for dialing out only as well, of course! Anyway... just a suggestion! Keep up the great work!
Thread Status:
Not open for further replies.

Share This Page