Inactive [TP] ButtonWarp v1.1 - Teleport using buttons with price/reward/custom messages [953]

Discussion in 'Inactive/Unsupported Plugins' started by Codisimus, Mar 18, 2011.

  1. Offline


    This page will no longer be updated. Please follow this project at the Bukkit Dev Page

    ButtonWarp (Previously DungeonReward) - Teleport using buttons with price/reward/custom messages:
    Version: 1.1 (7/16/2011)
    Supports iConomy, BOSEconomy, Essentials, Permissions
    Download Page

    This plugin is used to reward a player with money for reaching a certain region of the world.
    Or you can use it as a simple teleport using buttons.
    Money is added/subtracted when the user presses the button, the user is then teleported to a set location.

    If you are interested in this plugin be sure to check out PhatLoots.

    • Buttons can also teleport users without giving any reward.
    • Deny taking items to a new World
    • Custom messages
    • Option to not teleport on button press (only charge/display message)
    • Set a cooldown time
    • Rewards can be negative to charge users to warp.
    • Set different reward values for different dungeons.
    • List and locate teleport locations.
    • Send money to player/bank account
    • Take money from player/bank account
    • Uses iConomy, BOSEconomy or Essentials to give users money.
    • Permissions to limit players from using, getting rewards, and using commands.
    • Included in CraftBukkitUpToDate for easy updating (make sure you come check the changelog if somthing is not working right)
    Commands can be written as /buttonwarp or /bw
    Show Spoiler

    • /bw make [Name] - Makes Warp at current location
    • /bw make [Name] nowarp - Makes a Warp that doesn't teleport
    • /bw move [Name] - Moves Warp to current location
    • /bw link [Name] - Links target button with Warp
    • /bw unlink [Name] - Unlinks target button with Warp
    • /bw delete [Name] - Deletes Warp and unlinks buttons
    • /bw amount [Name] [Amount] - Sets amount for Warp
    • /bw source [Name] server - Generates/Destroys money
    • /bw source [Name] [Player] - Gives/Takes money from Player
    • /bw source [Name] bank [Bank] - Gives/Takes money from Bank
    • /bw msg [Name] [Msg] - Sets message recieved after using Warp
    • /bw time [Name] [0'0'0'0] - Sets cooldown time for using Warp
    • /bw type [Name] [Type] - Sets cooldown type for using Warp
    • /bw list - Lists all Warps
    • /bw locate [Name] - Gives location of Warp
    • /bw rl - Reloads ButtonWarp

    Permission Nodes:
    Show Spoiler

    • buttonwarp.use - Needed to be able to use the warp
    • buttonwarp.getreward - Needed to be able to receive money
    • buttonwarp.make
    • buttonwarp.amount
    • buttonwarp.source
    • buttonwarp.msg
    • buttonwarp.time
    • buttonwarp.type
    • buttonwarp.admin.move
    • buttonwarp.admin.list
    • buttonwarp.admin.locate
    • buttonwarp.admin.freewarp

    NOTE: New Tutorial video, please watch before asking a question.

    Old Versions + ChangeLog can be found at Download Page
    Show Spoiler

    Version 1.1 (7/16/2011)
    • Fixed nowarp
    Version 1.0 (6/26/2011)
    • Improved OP options
    • Updated Economy support
    • Fixed custom messages
    • Added rl command
    Version 0.9 (6/15/2011)
    • Added option of denying warp if trying to take items to a different world
    • Event is now cancelled if the warp event is cancelled
    Version 0.8 (6/12/2011)
    • Cleaned up code/fixed errors
    Version 0.7.5 (6/4/2011)
    • Cleaned up errors and added error messages
    Version 0.7.4 (6/3/2011)
    • Various fixes and code cleanup
    Version 0.7.3 (6/3/2011)
    • Added Essentials econ support
    Version 0.7.2 (5/20/2011)
    • Fixed ArrayIndexOutOfBounds '12' error
    Version 0.7.1 (5/16/2011)
    • Fixed creation of 'nowarp' warps
    Version 0.7 (5/15/2011)
    • Fixed location saving (no more looking straight up/down)
    • Actually fixed /bw make
    • Changed permission nodes
    • Added commands such as /bw source
    • Fixed all money issues
    Version 0.6.1 (5/4/2011)
    • Updated to iConomy 5
    • Few various fixes
    Version 0.6 (4/29/2011)
    • Fixed reload issues
    • Added custom messages
    • Fixed bank support
    • Added option to not teleport on button press (only charge)
    • Added cooldown
    • Renamed to ButtonWarp
    • Rewrote/Cleaned up code
    Version 0.5 (4/15/2011)
    • Improved Multiworld support
    • Many various fixes
    Version 0.4.1 (3/31/2011)
    • Few minor fixes
    • Works with build #612
    Version 0.3.3 (3/24/2011)
    • Fixed payment issues
    • Fixed Permission issues
    • changed dungeonreward.reward permission node to dungeonreward.amount
    Version 0.3.2 (3/22/2011)
    • Added confirmation messages (took out that you could set your own message)
    • Added a check to make sure the balance has enough money
    Version 0.3.1 (3/20/2011)
    • Fixed negative value adding money to account
    Version 0.3 (3/19/2011)
    • Fixed unknown command spamming chat
    • Fixed no Economy message spamming
    • Improved /reward list output
    • Added /reward msg (dungeonreward.msg) to set a custom message for when to press the button
    • Add option of negative value for paying to use warp
    Version 0.2 (3/19/2011)
    • Improved /reward make command (no more targeting, saves direction you are facing)
    • Added multiworld support
    Version 0.1 (3/18/2011)
    • Initial Release
  2. What he said, money is not added/deducted
    For some of my warps I'm getting the following after clicking the button:

    2011-05-09 00:24:40 [SEVERE] java.lang.NullPointerException
    2011-05-09 00:24:40 [SEVERE] at org.bukkit.craftbukkit.entity.CraftPlayer.teleport(
    2011-05-09 00:24:40 [SEVERE] at ButtonWarp.Warp$

    What information can I provide to help with this?
  3. I've read through the thread again and I think the error I'm getting can be caused by a corrupt save file. What would be a proper way to restore it except for wiping it out completely?
  4. Offline


    amount is not deducted/added to account. wtf does /bw bank do?
  5. Offline


    Hey guys FYI, if you still want to use most of the features, try this instead.. of "/bw make abc"

    /bw make abc nowarp
    /bw move abc

    it then works as normal..
    however, I cannot attach a cost or a message to the button at this point...
  6. Offline


    yup could really use the cost function working :(
  7. Offline

    louis zook

    Getting save issue.

    2011-05-10 20:26:39 [INFO] [ButtonWarp] Load failed, saving turned off to prevent loss of data
    2011-05-10 20:26:39 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: 12
    2011-05-10 20:26:39 [SEVERE]     at ButtonWarp.SaveSystem.loadFromFile(
    2011-05-10 20:26:39 [SEVERE]     at ButtonWarp.ButtonWarp.onEnable(
    2011-05-10 20:26:39 [SEVERE]     at
    2011-05-10 20:26:39 [SEVERE]     at
    2011-05-10 20:26:39 [SEVERE]     at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    2011-05-10 20:26:39 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    2011-05-10 20:26:39 [SEVERE]     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-05-10 20:26:39 [SEVERE]     at net.minecraft.server.MinecraftServer.e(
    2011-05-10 20:26:39 [SEVERE]     at net.minecraft.server.MinecraftServer.a(
    2011-05-10 20:26:39 [SEVERE]     at net.minecraft.server.MinecraftServer.init(
    2011-05-10 20:26:39 [SEVERE]     at
    2011-05-10 20:26:39 [SEVERE]     at
    2011-05-10 20:26:39 [INFO] ButtonWarp 0.6.1 is enabled!

  8. I think your warp save file is corrupt, so you'll have to re-create.
  9. Offline

    louis zook

    I have deleted the save file several times and still get this after like the 3 warp is created
  10. Are you setting the /bw amount to negative?
  11. Offline


    when i use command /bw make he wrotes all commands but not make a button
    /bw make is the same how /bw pff
  12. do the following:

    /bw make [name] nowarp
    go to where you want the warp to be
    /bw move [name]

    this will work
  13. Offline


    k ty
  14. Offline

    louis zook

    i get that as soon as i load the server. and i havent even started adding amounts
  15. Offline


    i do get the same as the other.
    -/bw make [name] and the menu just shows up everything else is working but not the warp command need help please ;)
  16. Offline


    hi, i was wondering how to keep my save files from dungeon reward to button warp.....

    I've tried changing the name of the folder the save file is in and the save file but it still didn't work

    please help this plugin plays a big part on my server
  17. Offline


    When I try to make a warp (/bw make station) it gives me the help page.
    the other commands works fine.
    P.S. I am a Admin and have all permissions.
    Screenshot-Minecraft.png Screenshot-Minecraft-1.png

    please help me :D
  18. You could read up at least a page before you post a question :/
  19. Offline

    Jake Buly

    I need some help, how do I do the following?

    Set a postion that the button sends you to, and make it cost money.
    Make another button that sends you back and gives you money.

    This is for a lava obstacle course. I want it to cost $150 to go there, then if you pass it you push another button. That button will return you and give you $400.

    Please help me!
  20. Button costs don't seem to work, Jake.
  21. Offline


    sorry i only wathed first 2 pages
  22. Offline

    Jake Buly

    Would you possibly be able be able to combine this with Essentials? I want to use prices on the button's but I don't use iConomy. Instead I use the Essentials currency system.
    MegaMan_Juno likes this.
  23. Offline


    Ik it's long overdue but I finally updated this. I appreciate everyones patience and I created a tutorial that should answered many questions that people have. Thanks @tr0y for helping by answering questions while I was gone
    Here's the Changes:
    Version 0.7 (5/15/2011)
    • Fixed location saving (no more looking straight up/down)
    • Actually fixed /bw make
    • Changed permission nodes
    • Added commands such as /bw source
    • Fixed all money issues
    And here's the Tutorial:

    If you still have a question after this feel free to re-ask it.
    tr0y likes this.
  24. Offline


    Everytime I do /bw make name .. nothing happens. Just brings up the help menu. Build #782
  25. Offline


    When I try to use the button warp after making it, I get disconnected with a message saying: You moved to quickly ;( (Hacking?) build 766
  26. This is a minecraft issue. I have not found any solution to this, but don't blame Button Warp, it happens with many other plugins too.
  27. Offline


    Iam having problems with naming my warps. I managed to get 2 named, but now, any warp stating winth aletter or symbol will not name. no error in servr window, i just acts like never issued the command.
  28. Have you upgraded to the latest version? I haven't yet and in the previous one /bw make didn't work, only /bw make name nowarp + /bw move name
  29. Offline


    as @tr0y said, there is nothing that can be done about this yet (that I know of) It happens to me once in a while but most of the time works fine. It can however warp you to the middle of nowhere if it happens while warping between worlds.
  30. Getting the below when using /bw make warpgk-c nowarp
    2011-05-16 23:48:45 [SEVERE] java.lang.NullPointerException
    2011-05-16 23:48:45 [SEVERE]    at
    2011-05-16 23:48:45 [SEVERE]    at ButtonWarp.SaveSystem.addWarp(
    2011-05-16 23:48:45 [SEVERE]    at ButtonWarp.ButtonWarpPlayerListener.onPlayerCommandPreprocess(
    2011-05-16 23:48:45 [SEVERE]    at$5.execute(
    2011-05-16 23:48:45 [SEVERE]    at org.bukkit.plugin.RegisteredListener.callEvent(
    2011-05-16 23:48:45 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.callEvent(
    2011-05-16 23:48:45 [SEVERE]    at net.minecraft.server.NetServerHandler.handleCommand(
    2011-05-16 23:48:45 [SEVERE]    at
    2011-05-16 23:48:45 [SEVERE]    at net.minecraft.server.NetServerHandler.a(
    2011-05-16 23:48:45 [SEVERE]    at net.minecraft.server.Packet3Chat.a(
    2011-05-16 23:48:45 [SEVERE]    at net.minecraft.server.NetworkManager.a(
    2011-05-16 23:48:45 [SEVERE]    at net.minecraft.server.NetServerHandler.a(
    2011-05-16 23:48:45 [SEVERE]    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    2011-05-16 23:48:45 [SEVERE]    at net.minecraft.server.MinecraftServer.h(
    2011-05-16 23:48:45 [SEVERE]    at
    2011-05-16 23:48:45 [SEVERE]    at
  31. Offline


    Thanks for finding this error, I just fixed it in Version 0.7.1

Share This Page