[TP] BrainWarpz v1.2.4 - Warpz0r fork with MySQL Support [798]

Discussion in 'Inactive/Unsupported Plugins' started by Brain, Apr 29, 2011.

  1. Offline


    Abandoned due to lack of interest and changing requirements

    BrainWarpz - Warpz0r fork with storage plugin
    Version: 1.2.4

    Warpz0r fork with storage plugin, supporting Warpz0r list files and MySQL tables.

    Download the plugin

    Version 1.2.4
    • Updated for iConomy 5.x
    Version 1.2.3
    • Added noPrefix config option
    • Brain now also writes storage node into the config file
    Version 1.2.2
    • Added /clearhome [Player]
    • Made /warpto and /clearhome allow partial names
    • Brain added plug-in storage for different data storage modules.
      Currently implemented: Warpz0r list files, MySQL
  2. Offline


    You shouldn't have even posted this here if it isn't up to date :/ why not the WIP forum?
  3. Offline


    Because I didn't know such a forum exists. It took me several minutes to find it, now that I know it exists. But don't bother, it will be up to date within the next 12 hours after i got some sleep. It's midnight here.

    By the way, fancy meeting a fellow German here. :)

    See, was no big deal, you can use the same jar for CB 740 as I suspected, just tested it. Still built a new one against CB 740 and the most recent versions of the dependencies just in case.
  4. Offline


  5. I use WarpzOr, so I've tried this, since the author is not wishing to update anymore ? ........ anyway, I've not noticed any difference - what is the difference please ? and although the plugin file name is different, it still uses the WarpzOr folder within the plugins directory, which might become a problem to either yourself, or others at a later date.

    Also, for other users, your download is not good. It is a .gz file (presumably Linux), which many people (primarily Windows users) may not have come across, although Winrar will deal with it for Windows users with no problem. More importantly, the file inside the .gz download ends in a .3, instead of .jar, which mean anyone not knowing about renaming a file extention to the correct format will not be able to use this plugin, and you'll get loads of spam in this thread saying it doesn't work.

    In short, users have to change the filename - NOT the file they download, but the file inside the download - from brainwarpz-cb740-wz1.2.3 to brainwarpz.jar for it to work.

    Anyone currently using WarpzOr, this plugin will continue using any stored warp locations you have without a problem. Tested on Bukkit #767
  6. Offline


    There is barely no difference. As stated in the first post it is simply a Warpz0r fork that implements storage configurable facilities other than flat files. Currently supported are Warpz0r's flat file format and MySQL tables. I also haven't compiled against iConomy 5 yet so I don't know if it works with that version.
    The name of the folder is ok since I also use the original plugin.yml. I'm convinced anything I do will become a problem later because it will become a problem to others, but I don't mind. I can just disappear if I need to. However it is unavoidable people will have problems. Since there are more than enough people incapable of emptying a full bucket of water even if the instructions to do so were written on the underside of the bucket's bottom, they will have problems. But that won't be my problem.
    I'm a bit sad Drakia won't support Warpz0r anymore because this means now people will start bugging me. Wonderful.

    Well, it's not my fault Windows hides file extensions by default. If you disable the fluff and rip the training wheels off of the GUI you will see that the gz file indeed contains a plugin folder with a jar file.

    Yes, that's true. The Bukkit API hasn't changed in the warping department recently. I could build against the current bukkit RB. Do you think it would make people happy?
  7. I already have file extentions unhidden in Windows - always have, and when I pulled your file out of the .gz file, it didn't have a .jar file extension it had a .3 extension ? ...... maybe its the way Winrar deals with it - not sure, anyway, thats the way it is, with my system anyway (Windows 7 64bit)

    As for the rebuild, if it is not broke, don't fix it. ! .......... and its working at the moment, certainly with bukkit #767, so I'd wait for the problems to roll in before doing something to the code.

    ...... many thanks for keeping it alive though ....... !

    By the way, where does it store the mysql file please ? is it the warps.db in the WarpzOr folder ?
    ........ and how is it choosing which way to store the locations ? i.e. flatfile or mysql (I'n not using permissions - never have, so no idea if that bits working)
  8. Offline


    Very strange. My gaming PC runs Win7/64 bit too. And WinRAR 3.91.
    I hate it when Windows and Windows application try to think. They usually do an even crappier job than humans.

    I'm not quite sure what you are looking for. If you are looking for the file where you enter the MySQL access credentials and table names that would be config.yml in the Warpz0r plugin directory. All other files from Warpz0r are also used. By default my Warpz0r fork behaves exactly like Warpz0r. Stores data in flat files, uses Warpz0r plugin directory. Simply a drop-in replacement. Delete Warpz0r.jar, insert BrainWarpz*.jar, restart server.
  9. Many thanks for the reply .......... just thought I'd let you know (and anyone else reading this) that your plugin does actually work ok - no problems up to now.
  10. Offline


    *Bump* for anyone who might be following this:

    Updated on par with Warpz0r 1.2.4 which means iConomy 5 support. I've also tested warps and homes against RB798.
  11. Offline


    Thank you so much brain for forking it! You saved me a warp-plugin change! :)
    I downloaded 1.2.4 from the original post, but it wouldnt work with latest Essentials and bukkit build 803.
    But then I saw this and that it used the same config and all, and yes it worked :D
    Please keep it up and i'll donate!
  12. Offline


    Still works with RB 860. Noticed a bug with MySQL support though. After running for about a day it cannot connect to the DB anymore. Currently investigating this...

Share This Page