The solution if you have server-problems!

Discussion in 'Bukkit Help' started by vrostol, Mar 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Please stop making new threads about those server-problems...

    One of your problems is old plugins, remove all your plugins and try again, if that doesn't work, download the latest build from here:

    When you have downloaded the latest build, you can take your plugins back to their folder. you will get lots of errors when you start the server, but it still works.

    The errors you get is because of the plugins, they are too old and cannot be used in the new minecraft. To fix this problem, you have to find a new version of your plugin or a similar plugin. Find one updated after 01.03.12 (1. march) then you're as good as safe.

    Hope you understood and that it helped ;)

  2. Offline


    I think most of the poeople knows that, but same as me. I have the latest of build and plugins, and it still does not work. I cant even type /help and stuff. So it has to be something else, if i misunderstood what you wrote or anything, please reply :) I'm sure other people need answers too.
  3. Offline


    Yepp, I hoped they knew it, but after at least 10 threads about the same thing where something of this is the solution, I found out that the best thing to do was making one thread with the solutions instead of 20 with the same questions ;)

    Anyways... my server works perfectly with the latest dev. build =) If you're using the latest rec. build, it will go wrong =P
  4. Offline


    What about your plugins? Did you reinstall them all or did they update themselves, becouse i can go into my server and stuff, but as i said, none of it works and i cant use commands, like.. The only one i can use is /plugins and when i use the others this message comes up "An internal error occurred while attempting to perform this command". And my groups and stuff neither works.
  5. Offline


    when i try to run my server, it says a whole lot of stuff, then says press any key to continue
  6. Offline


    I reinstalled all my plugins to be sure it would be right =P My world-portals wont work, not the commands for them either, and it gives the server pretty much errors ;) Exept from that, everything works fine... i can use all the other plugins like for example my LWC-plugin with "/cprivate" (lock doors) works fine =)

    Remember that you can't expect that plugins from before 01.03 will work ;)

    Exactly what does it tell you? =P

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  7. Offline


    ii don't know if this means anything, but when i go to the multiplayer section on my minecraft, it says my server is up even if i don't have it running. but when i try to go on, it just sends me back to the homepage
  8. Offline


    That's wierd... =P Actually... I have no idea what that is =P have you tried everything i've suggested at the top of this page? =)
  9. Offline


    ya, i tried everything before i posted stuff. and i dont have any plugins
  10. Offline


    Ok first i got all the latest server and plugins.

    This server is running CraftBukkit version git-Bukkit-1.1-R6-b1988jnks (MC: 1.1) (Implementing API version 1.1-R6)

    WorldEdit v5.2 - WorldGuard v5.5.1

    With out plugins server runs fine, but once i put plugins WorldEdit v5.2 and WorldGuard v5.5.1 no other plugins.
    I get the following error when moving it just keeps repeating down the sever command screen every step i take in the world. can you please help.

    15:48:19 [SEVERE] Could not pass event PlayerMoveEvent to WorldGuard
    at org.bukkit.plugin.RegisteredListener.callEvent(
    at org.bukkit.plugin.SimplePluginManager.callEvent(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet10Flying.handle(SourceFile:126)
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(
    at net.minecraft.server.MinecraftServer.w(
    Caused by: java.lang.NoSuchMethodError: org.bukkit.entity.Player.getVehicle()Lorg/bukkit/entity/Vehicle;
    at com.sk89q.worldguard.bukkit.WorldGuardPlayerListener$PlayerMoveHandler.onPlayerMove(
    at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    ... 10 more

    I have tryed redownloading server the problem lies with the latest revision of the server or WorldGuard.
  11. Offline


    that looks a bit what my server looks like when i set it up, but i dont have any plugins
  12. Offline


    Works. -_-
  13. Offline


    It looks like it is something wrong with that plugin then ;) Contact the one who made the plugin to get more information about that problem ;)

    Okay, so... you're running build #2032 ?
    And you have changed the settings in the .bat starter-file so the right name for the .jar file is the one named there?
    If this doesn't work, rightclick the cmd, mark the whole text, press enter and past it here so i can see what it says =P

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  14. Offline


    at<init>(Unknown Source)
    at<init>(Unknown Source)
    at net.minecraft.server.AchievementMap.<init>(SourceFile:15)
    at net.minecraft.server.AchievementMap.<clinit>(SourceFile:9)
    at net.minecraft.server.Statistic.d(SourceFile:38)
    at net.minecraft.server.CounterStatistic.d(SourceFile:15)
    at net.minecraft.server.StatisticList.<clinit>(SourceFile:24)
    at net.minecraft.server.MinecraftServer.main(
    at org.bukkit.craftbukkit.Main.main(
    at net.minecraft.server.LocaleI18n.<clinit>(SourceFile:5)
    at net.minecraft.server.Item.l(SourceFile:447)
    at net.minecraft.server.StatisticList.a(SourceFile:134)
    at net.minecraft.server.StatisticList.c(SourceFile:81)
    at net.minecraft.server.Item.<clinit>(SourceFile:252)
    at net.minecraft.server.Block.<clinit>(
    at net.minecraft.server.StatisticList.a(SourceFile:117)
    at net.minecraft.server.StatisticList.<clinit>(SourceFile:52)
    at net.minecraft.server.MinecraftServer.main(
    at org.bukkit.craftbukkit.Main.main(
    Caused by: java.lang.NullPointerException
    at<init>(Unknown Source)
    at<init>(Unknown Source)
    at net.minecraft.server.LocaleLanguage.b(SourceFile:35)
    at net.minecraft.server.LocaleLanguage.<init>(SourceFile:21)
    at net.minecraft.server.LocaleLanguage.<clinit>(SourceFile:10)
    ... 10 more
    Press any key to continue . . .
  15. Offline


    Are you shure you run this ( build?
    Because... that is exactly the same i got when i ran the R6-build =P
  16. Offline


    i downloaded that build and the same thing happend
  17. Offline



    i put this when it starts the conversion process so that it wouldnt exceed 3000 characters.
    19:30:49 [INFO] [MobDisguise] Loading MobDisguise v1.7
    19:30:49 [INFO] [ChatManager] Loading ChatManager v1.19
    19:30:49 [INFO] [LogBlock] Loading LogBlock v1.50
    19:30:49 [INFO] [LogBlock] Version check: Your version is up to date
    19:30:49 [INFO] [LogBlock] Connecting to root@jdbc:mysql://localhost:8889/logblock...
    19:30:50 [INFO] [LWC] Loading LWC v4.1.1 (b645-git-b24cc99e)
    19:30:50 [INFO] [MagicSpells] Loading MagicSpells v2.0
    19:30:50 [INFO] [ChestShop] Loading ChestShop v3.29
    19:30:50 [INFO] [LWC] Enabling LWC v4.1.1 (b645-git-b24cc99e)
    19:30:50 [INFO] LWC: Loading shared objects
    19:30:50 [INFO] LWC: Native library: plugins/LWC/lib/native/Mac/x86_64/libsqlitejdbc.jnilib
    19:30:50 [INFO] LWC: Protection cache: 0/10000
    19:30:50 [INFO] LWC: Loaded 207 locale strings (0 overrides)
    19:30:50 [INFO] LWC: Permissions API: PEXPermissions
    19:30:50 [INFO] LWC: Currency API: iConomy6Currency
    19:30:50 [INFO] LWC: Connecting to SQLite
    19:30:50 [INFO] LWC: Performing any necessary database updates
    19:30:50 [INFO] LWC: Using database: Native
    19:30:50 [INFO] LWC: Precached 9181 protections.
    19:30:50 [INFO] LWC: At version: 4.1.1 (b645)
    19:30:50 [INFO] Preparing level "Illyria"
    19:30:50 [INFO] Converting map!
    19:30:50 [INFO] Scanning folders...
    19:30:50 [INFO] Total conversion count is 509
    19:30:50 [INFO] LWC: Latest version: 4.1.1
    19:30:51 [INFO] Converting... 18%
    19:30:52 [INFO] Converting... 35%
    19:30:53 [INFO] Converting... 53%
    19:30:54 [INFO] Converting... 71%
    19:30:55 [INFO] Converting... 78%
    19:30:56 [INFO] Converting... 83%
    19:30:57 [INFO] Converting... 90%
    19:30:58 [SEVERE] java.lang.ArrayIndexOutOfBoundsException: -3926167
    19:30:58 [SEVERE]at java.util.ArrayList.set(
    19:30:58 [SEVERE]at net.minecraft.server.RegionFile.<init>(SourceFile:137)
    19:30:58 [SEVERE]at net.minecraft.server.WorldLoaderServer.a(SourceFile:183)
    19:30:58 [SEVERE]at net.minecraft.server.WorldLoaderServer.a(SourceFile:169)
    19:30:58 [SEVERE]at net.minecraft.server.WorldLoaderServer.convert(SourceFile:128)
    19:30:58 [SEVERE]at net.minecraft.server.MinecraftServer.a(
    19:30:58 [SEVERE]at net.minecraft.server.MinecraftServer.init(
    19:30:58 [SEVERE]at
    19:30:58 [SEVERE]at
    19:30:58 [SEVERE] Unexpected exception
    java.lang.ArrayIndexOutOfBoundsException: -3926167
    at java.util.ArrayList.set(
    at net.minecraft.server.RegionFile.<init>(SourceFile:137)
    at net.minecraft.server.WorldLoaderServer.a(SourceFile:183)
    at net.minecraft.server.WorldLoaderServer.a(SourceFile:169)
    at net.minecraft.server.WorldLoaderServer.convert(SourceFile:128)
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
    20:26:23 [INFO] Connection reset
    20:28:33 [INFO] Connection reset
    21:08:29 [INFO] Read timed out
    SERVER CRASH By the way... i did this with and without the plugins and the map conversion still didn't go any ideas?
  18. Offline


    Then i'm sorry, I can't help you with your problem =/ But if i find something that can help, I will tell you ;)

    I dont know anything about that map or the error message you get, so i cannot help you with that =/ But if i find out, i will tell you ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  19. Offline


    thank you :/
  20. Offline


    The same thing happend to someone i know, and it just fixed itself soon
  21. Someone please help!! Ever since 1.2.3 my server has been screwed up. I run my server and I took all the plugins out of the folder, and its up with no errors, but it keeps saying polling and then cannot reach server. I need help!
  22. Offline


    Have you port forwarded?
  23. Yea it worked before 1.2.3
  24. Offline


    If it wont let you type the standard commands you need to remove the minecraft essentials plugin from your server folder. It hasn't been updated yet so the server cant use it, and since it edits all of the standard commands, you wont be able to use those unless you remove it.
  25. Offline


    Start your server and then go to and type in 25565 (This is default unless you changed it) if it saids 'error' then you have not port forwarded correctly and should check that again. Also in the server properties file make sure that where it saids server-ip= leave it blank!
  26. Oh that might be my problem hold on

    Thank you sooooo much!!! It was the server properties :)

    And so how long do you think it will take for most of the plugins to be updated?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
  27. Offline


    Well almost all of the popular plugins have been updated, depends on how many you have :)
  28. Ok good but one more question... Do you know if all my ranks on bpermissions will be saved?
  29. Offline


    I recommend backing up your server and then installing the new updated plugins and then if it hasn't saved saved something important like your ranks on bpermissions you can just copy over the necessary files, that's what I did anyway :)
  30. Ok I will do that :)

    Thanks for the help! (Ive been looking for a solution for hours)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 24, 2016
Thread Status:
Not open for further replies.

Share This Page