strange world problem..

Discussion in 'Bukkit Help' started by Puseidr, May 26, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, i have a strange world problem on my server...
    I want to move my server spawn (an island on the Creative world) to a new world (copy of the island)
    Atm my server needs ~20 seconds to start with 8 worlds and 71 Plugins but when i try to copy the world its going to be 250 seconds or more.

    Strange things about that:

    The spawn is on the creative world (1.1 GB), so i copied the world and renamed it to: spawn -> now i have 2 copies (2x 1.1 GB) of the same world but with different names --> restart time ~20 seconds (everything is fine)
    server log:

    When i trim the world using the plugin WorldBorder or MCEdit the world is only 12 MB but the restart needs 250+ seconds and after some seconds the server is getting "Read timed out" and restarts
    server log:

    I can't copy the spawn with worldedit .. its to big (700*700) the server cant copy or paste the island

    When i remove the new spawn world and generate another world (without the spawn from the creative world) restart time is ~20 seconds and everything works fine again.. no "Read timed out"-msg..

    The server have enough RAM (16GB) and CPU usage is minimal while this.. but the server can't handle the trimmed world..?!

    any idea why this is happening and how to fix it?
    i really want that spawn island on a new world..

    is it possible that the trimmed world have errors inside? how can i check this? how can i cut/paste the spawn without mcedit/worldedit?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 1, 2016
  2. Offline


    Are you sure you need to run in Offline mode?

    Take at look at the timestamps for the various plugins to load, and see if you are missing some settings in the configuration files for the plugins for the new world.

    This part suggests that you might not have succeeded in renaming the copy of the "Hub" world:

    1. 2013-05-27 00:04:21 [INFO] CONSOLE: Starting import of world 'Hub'...
    2. 2013-05-27 00:04:21 [INFO] [Multiverse-Core] Loading World & Settings - 'Hub' - Env: NORMAL - Type: null
    3. 2013-05-27 00:04:21 [INFO] [WorldGuard] (Hub) TNT ignition is PERMITTED.
    4. 2013-05-27 00:04:21 [INFO] [WorldGuard] (Hub) Lighters are PERMITTED.
    5. 2013-05-27 00:04:21 [INFO] [WorldGuard] (Hub) Lava fire is blocked.
    6. 2013-05-27 00:04:21 [INFO] [WorldGuard] (Hub) All fire spread is disabled.
    7. 2013-05-27 00:04:21 [INFO] [WorldGuard] Loaded configuration for world 'Hub'
    8. 2013-05-27 00:04:21 [INFO] [WorldGuard] 0 regions loaded for 'Hub'
    9. 2013-05-27 00:04:21 [INFO] Preparing start region for level 8 (Seed: -4489814583449540608)
    10. 2013-05-27 00:04:22 [INFO] [dynmap] Loaded 2 maps of world 'Hub'.
    11. 2013-05-27 00:04:22 [WARNING] [Multiverse-Core] Spawn location from world.dat file was unsafe. Adjusting...
    12. 2013-05-27 00:04:22 [WARNING] [Multiverse-Core] Original Location: X: -162 Y: 63 Z: 33 P: 0 Y: 0
    13. 2013-05-27 00:04:22 [INFO] [Multiverse-Core] New Spawn for 'Hub' is located at: Hub:-160.50,63.00,33.50:0.00:0.00
    14. 2013-05-27 00:04:30 [INFO] CONSOLE: Complete!
    15. 2013-05-27 00:04:30 [INFO] CONSOLE: Forcing save..
    16. 2013-05-27 00:04:30 [INFO] CONSOLE: Save complete.
    17. 2013-05-27 00:04:30 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    18. 2013-05-27 00:04:30 [INFO] [Server] **SERVER IS SHUTTING DOWN**
  3. Offline


    • 2013-05-27 00:04:22 [INFO] [dynmap] Loaded 2 maps of world 'Hub'.
    thats normal, every world have two maps (flat and surface)..
    the starnge thing is, when i rename the world Hub (with the spawn island) for backup, and create a new world called Hub - everything works fine.. but when i load the Hub-world with the island the server cant handle it...

    i've uploaded the spawn island so you can test it by youself
  4. Offline


    You copied the world folders in your OS? Which OS and what command did you use? I'm thinking the file OS permissions (not Bukkit permissions) are not correct.
  5. Offline


    debian 6 64bit
    and i copied it with "cp oldmap/ Hub/"
    and correcting the permissions, sure without that i could import/load the map into multiverse
  6. Offline


    /cp -p -r
    might have worked better, because you might have changed ownership. Maybe you want to try again...
  7. Offline


    the permissions are right.. i can load/import the map but something might be wrong with it..
    even on my PC (windows 7) i can't import/load the world correct.. without it a start takes 5 seconds, with the wold it needs 40+ seconds
  8. Offline


    So I tried your ZIP file in Singleplayer mode, and it works fine. The world loads in about 1 second, and I can move around. Even to that one oddball .mca region.

    Neat volcano, BTW.
  9. Offline


    try to add this world to a bukkit (maybe a local testserver) server and you will see what i mean
  10. Offline


    Sorry, but I don't have anything set up to try that.
  11. Offline


    you can easily download the BukkitGUI and put the latest craftbukkit..jml inside the a folder where the CUI is
    + multiverse
    and start it

    i fixed it.. but i dont know why the normal process doesnt worked..

    i made ~50 stripes (16 block wide) of the world and cut and pasted it with world edit.. dotn know why.. but now the world is loading fast

    s**t i thought it works.. but after a remove and import of the map the error is still existing.. i think its a problem by multiverse

    no2 i definitely fixed the problem!!.. it wasn't a multiverse problem..
    the spawn island have a lot of entities, and bukkit has problems loading all the things on a (re)start
    i moved the world spawn away from the island, so the chunks around the spawn doesn't have so much entities like the island.
    and the world will load very fast :) new i use a multiverse portal to teleport to the island when you enter the real spawn

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 1, 2016
Thread Status:
Not open for further replies.

Share This Page