Solved Spigot Server with Hamachi - Failed to bind port

Discussion in 'Plugin Help/Development/Requests' started by puma9S, Jun 15, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Hi, I'm trying to get my spigot server working but get an error message all the time.

    I'm using Hamachi so I can play with a friend on my server, unfortunately I'm not able to set up port forwarding and yes I've tried.

    I'm using Java 8 and Eset SmartSecurity on my Windows 10 pc, connected to my fritzbox Wifi Router.

    However, I've managed to set it up many times before but this time I just couldn't find a solution.

    So here's the message

    Error Message (open)
    Java HotSpot(TM) 64-Bit Server VM warning: Using incremental CMS is deprecated a
    nd will likely be removed in a future release
    Loading libraries, please wait...
    [16:24:11 INFO]: Starting minecraft server version 1.8.6
    [16:24:11 INFO]: Loading properties
    [16:24:11 INFO]: Default game type: SURVIVAL
    [16:24:12 INFO]: This server is running CraftBukkit version git-Spigot-044d928-e
    8c6403 (MC: 1.8.6) (Implementing API version 1.8.6-R0.1-SNAPSHOT)
    [16:24:12 INFO]: Debug logging is disabled
    [16:24:12 INFO]: Server Ping Player Sample Count: 12
    [16:24:12 INFO]: Using 4 threads for Netty based IO
    [16:24:12 INFO]: Generating keypair
    [16:24:12 INFO]: Starting Minecraft server on
    [16:24:12 INFO]: Using default channel type
    [16:24:12 WARN]: **** FAILED TO BIND TO PORT!
    [16:24:12 WARN]: The exception was: Cannot assign reques
    ted address: bind
    [16:24:12 WARN]: Perhaps a server is already running on that port?
    >Drücken Sie eine beliebige Taste . . .

    So the main part is:

    The exception was: Cannot assign reques
    ted address: bind
    This seems to be an unusual error I guess.

    What I've tried already is

    Checking if any other program use the port

    killing all Java processes

    Disabling Eset Firewall

    Uninstall Eset SmartSecurity

    Uninstall/ reinstall Hamachi

    Using another Server Jar File


    PS: the IP in the spoiler is not my real hamachi IP
  2. Offline

    I Al Istannen

    @puma9S Try leaving the "server-ip=" in the server.properetis blank. And if that doesn't work, maybe this helps you.
    puma9S likes this.
  3. Offline


    thank you!

    But I've solved it, it has to do with windows 10 and hamachi unfortunately
    Since I'm using a preview build of windows 10, Hamachi couldn't install a virtual network and drivers so there wasn't anything to connect to.

    So if someone who find this thread also has an error message like me, check your Network Adapters :D

    The thread can be closed now
  4. Offline

    timtower Administrator Administrator Moderator

    Locked on request
Thread Status:
Not open for further replies.

Share This Page