[SpaceBukkit] Step 4 Web Configuration issue (Server was not reached)

Discussion in 'Bukkit Help' started by NitroNarcosis, May 3, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Moved to http://forums.xereo.net/threads/spa...nfiguration-issue-server-was-not-reached.349/

    Hello there,
    This is my first Linux MC Server I have seen some running Space Bukkit and I figured I could tackle this no problem.

    I hit a few hurdles...issues of my own design which I eventually overcame.

    My issue now is that I cannot get past the web configuration wizard for initial setup.

    Not much help on the wiki regarding this stage of the install...so I assume that it is either stupid easy or I am running into an issue that shouldn't be occurring.

    Debian 6.0.4

    CraftBukkit version git-Bukkit-1.2.5-R1.0

    isynuser@IsYn-Apollo:/minecraft/Alpha# sh rtoolkit.sh
    Minecraft Remote Toolkit R10 Alpha 13
    Loading toolkit properties...Done.
    Loading toolkit modules...Done.
    Loading SpaceModule...Done.
    --------------------[SpaceModule v0.1]--------------------
    | Checking for updates... [||||||||||||||||||||||] 100 % |
    | Starting SpaceBukkit... [||||||||||||||||||||||] 100 % |
    Wrapper is running on: Linux 2.6.32-5-686 i386
    Starting wrapper...
    Starting UDP listen server on port 25561
    15:53:39 [INFO] Listening to Port 25,561 with a connectivity queue size of 5.
    182 recipes27 achievements15:53:41 [INFO] Starting minecraft server version 1.2.5
    15:53:41 [INFO] Loading properties
    15:53:41 [INFO] Starting Minecraft server on *:25565
    15:53:41 [WARNING] The server will make no attempt to authenticate usernames. Beware.
    15:53:41 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
    15:53:41 [WARNING] To change this, set "online-mode" to "true" in the server.properties file.
    15:53:41 [INFO] This server is running CraftBukkit version git-Bukkit-1.2.5-R1.0-b2149jnks (MC: 1.2.5) (Implementing API version 1.2.5-R1.0)
    15:53:41 [INFO] [SpaceBukkit] Loading SpaceBukkit v0.1
    15:53:41 [INFO] [RemoteToolkitPlugin] Loading RemoteToolkitPlugin v0.61
    15:53:41 [INFO] Preparing level "IsYn"
    15:53:41 [INFO] Default game type: 0
    15:53:42 [INFO] Preparing start region for level 0 (Seed: -926406371532389738)
    15:53:43 [INFO] Preparing spawn area: 32%
    15:53:44 [INFO] Preparing spawn area: 89%
    15:53:44 [INFO] Preparing start region for level 1 (Seed: -926406371532389738)
    15:53:45 [INFO] Preparing spawn area: 28%
    15:53:46 [INFO] Preparing spawn area: 77%
    15:53:46 [INFO] Preparing start region for level 2 (Seed: -926406371532389738)
    15:53:47 [INFO] Preparing spawn area: 36%
    15:53:47 [INFO] [SpaceBukkit] Enabling SpaceBukkit v0.1
    15:53:48 [INFO] ----------------------------------------------------------
    15:53:48 [INFO] | SpaceBukkit version 0.1 is now enabled! |
    15:53:48 [INFO] ----------------------------------------------------------
    15:53:48 [INFO] [RemoteToolkitPlugin] Enabling RemoteToolkitPlugin v0.61
    15:53:48 [INFO] Memory max: 1543503872 bytes
    15:53:48 [INFO] Memory total: 1543503872 bytes
    15:53:48 [INFO] Remote Toolkit Plugin V0.61 enabled!
    15:53:48 [INFO] Server permissions file permissions.yml is empty, ignoring it
    15:53:48 [INFO] Done (6.340s)! For help, type "help" or "?"
    15:53:53 [INFO] [SpaceBukkit] Database contains 4086 plugins.

    From the above output it is safe to assume:

    Spacebukkit is running
    RTK is running
    MC server is running

    However I keep getting this message when attempting to complete Step 4 of 5


    Everything is running on the same server.
    For the Address I have tried both the 10.x.x.x address which is the Internal IP, I have tired localhost, I have also tried the external address. I do have the ports open externally (although if this is all local that should not matter correct? unless I wanted to get to the web ui externally)

    Any help appreciated
  2. Offline


    You shuld have posted this here LINK
  3. Offline


    Ty I will re up the thread there...was confused by the vague description within the comment section of the plugin.

    It is great how this is the first time I am seeing this entirely separate site...even though I have been troubleshooting through this install just about my entire work day. I appreciate your speedy response.

    I am not so thrilled at how there are no links on search engines pointing to this new site.

    Correction...I have been working with this wiki page all day...It is http://spacebukkit.xereo.net/wiki/index.php?title=Main_Page

    Therefore I have been on that site all day...it just so happens that all of the "if you need help post here or on the forums" is on the main site.

    Maybe time will tell. Again

  4. Offline


    not a problem.
  5. Offline


    How about this...use McMyAdmin! :D
  6. Offline


    Spacebukkit SO much better I switched from my paid MCmyadmin
  7. Offline


    Does mcma still not support multiple worlds?
  8. Offline


    andrewpo Coming after a few more bug fix release, etc.
  9. Offline


    Just shocks me really - many servers have multiple world setups and any competent programmer should be able to devise a program capable of handling more than one main world.
  10. Offline


    How it's going to work isn't an issue, neither is implementing it. How the configuration is correctly migrated when you've got over 20000 servers to worry about is quite another. I can't just tell people to throw away their existing configuration and start again, especially the big hosting companies that entirely rely on McMyAdmin to operate as a business.

    So big structural changes like multiworld are a much slower process because there are so many caveats that have to be tip toed around to keep things running smoothly. Moving from MCMA 1 -> 2 was a fairly big challenge because of the sheer scale of the changes made, and while it arrived later than planned - the migration has been pretty smooth for the most of it. However unlike MCMA2 which was mostly adding new features, multiworld requires much heavier modification of existing features and changing the behavior of existing components that are relied upon by other components can get hairy pretty fast.

    Of course it's pretty easy to kick back and say that any competent programmer could do it when you're not the one with over 20000 servers to worry about and 40+ different hosting companies depending on you to get it right first time.
Thread Status:
Not open for further replies.

Share This Page