Plugin Help [SOLVED]PermissionsEx and Essentials Chat

Discussion in 'Plugin Help/Development/Requests' started by smiggle0404, Dec 13, 2014.

Thread Status:
Not open for further replies.
  1. Invisible

    smiggle0404

    Hey...This is the same problem MANY people have had and i've spent the last 2 and a half hours (+ another 3 last night) surfing google and trying to resolve this issue.....this is my last resort.
    Originally I thought the issue was between Factions and Essentials chat where the whole 'chatSetFormat' was at fault so tried changing that...Then threads were saying to change the format/group format in the essentials config...This didn't work either.
    Going through every last plugin the only OTHER one that could relate to this issue was PermissionsEx, where i had prefixes setup e.g &a[Owner]. So I tried something out, prefix: '{factions_relcolor}{factions_roleprefix}{factions_name} &a[Owner]&f' .This Worked! It came up with **Faction[Owner]Player: Hi!
    However for all commands and in console it didn't 'parse' the faction tags I put in PEX. For example if someone went to type /tpa, instead of it coming up saying "Player wants to tp to you blah blah" It would come up ''{factions_relcolor}{factions_roleprefix}{factions_name}Player wants to tp to you blah blah"...

    EDIT: Fixed the Issue! Isolated every plugin until I found what was doing it, ProjectKorra (Bending) was the issue. For some reason it had a chat format enabled and was overriding every other plugin!
     
    Last edited by a moderator: Dec 13, 2014
Thread Status:
Not open for further replies.

Share This Page