Filled Skyblock with surface world - Enforcement Plugin

Discussion in 'Plugin Requests' started by krlsmnk, Oct 14, 2018.

Thread Status:
Not open for further replies.
  1. Offline

    krlsmnk

    Plugin category: Block Placement

    Minecraft version: 1.13

    Suggested name: FloatingCity

    What I want: A plugin that prevents players from placing blocks below a certain y level (specified in the config).

    The players should still be able to BREAK blocks, but not PLACE any.

    This forces players to build everything, including their starter homes and bulk chests, in the sky.

    Don't sweat the logistics. I start my players on floating islands with a way to recall back up to their home. There's also a special pad on their island that lets them slow fall down to the surface for adventure and resource acquisition.


    Optional:
    1: Prevent mobs from spawning above a certain y level. Not having to spawn-proof builds allows for a lot more creativity.

    2: Warn the player when they cross the threshhold with a configurable message. Maybe something like "You can't place blocks on the surface" as the default.

    3: Prevent buckets from being emptied below the threshhold (not sure if that's covered by the game's player-placed checks)

    Ideas for commands: PLEASE NO COMMANDS.

    Ideas for permissions: I don't need them, but you can include some if you want.
     
  2. Offline

    Tango_

    @krlsmnk
    I can do this for you, shouldn't take me long.

    Edit:
    Here it is link: DOWNLOAD
    If there is anything you want changed, let me know.
     
    Last edited: Oct 15, 2018
  3. Offline

    Eccentric_Gamer

    This looks super easy tbh. I might do this for the fun of it.
     
  4. Offline

    krlsmnk

    It seems I completely ignore the plugin's restrictions if I'm an operator.
    When I deop myself, the plugin does what is described, but I also can't interact with objects above the threshhold. Can't sleep in a bed, can't open chests, can't break blocks (no message printout).
    Some blocks on the surface, below the threshhold, won't break if I'm deop'd. Not a certain KIND of block, just certain blocks. I can "break" them, but they pop back into existence with no error message.
    Even after some debugging attempts, I can't say I'm sure what's causing the behavior.
     
  5. Offline

    Tango_

    Oh, sorry, I added the OP part because I thought it would be annoying if a staff member needed to modify under the threshhold but couldn't. I will remove that. As for the other part, I never listen for block break, so that means its not my plugin thats cancelling it and putting the blocks back. And again for the interact part, I never listen for interactions with chests / beds. I'm not getting any of these issues on my end so its hard for me to pin point the issue. Try having just my plugin enabled and see if you are getting the same results.
     
  6. Offline

    krlsmnk

    Yep. Definitely this one; nothing else running, same issue.
    Forgot to mention: when I place a block below the threshhold and it pops out of existence, it also disappears from my inventory.
    1.13.0 if that matters. Haven't updated to 1.13.1 and don't plan to soon.
    I'm on Spigot, not Bukkit. That has actually been an issue for another plugin before, so I'll mention it.
     
  7. Offline

    Tango_

    The version I used t0 make the plugin was for Spigot 1.13.0. I can send you the code (there is less than 100 lines), there is literally nothing there to suggest what you are getting comes from this plugin. Do you happen to get any errors? And you should probably update to 1.13.1, because 1.13.0 was super buggy, and all plugins you have currently for 1.13 will still work. Also, you are more than welcome to come on my test server so you can see its working fine on my end.
     
    Last edited: Oct 18, 2018
  8. Offline

    krlsmnk

    I'll record a little clip of what's going on. Kinda hard to explain.
    I'll update after that, and try it again.
    What's your server info?

    EDIT: For anyone experiencing the issue described, change your server property "Spawn Protection" to 0 (zero)
     
    Last edited: Oct 18, 2018
  9. Offline

    Tango_

    Glad you solved it, here is the version without the OP feature, link DOWNLOAD
     
Thread Status:
Not open for further replies.

Share This Page