"sh": java.io.IOException: error=12, Cannot allocate memory

Discussion in 'Bukkit Help' started by unenergizer, Apr 23, 2011.

Thread Status:
Not open for further replies.
  1. I am hosted on a VPS with:
    Memory: 3gb
    Burst: 3gb
    OS: Cent OS 5 32 bit
    Java Version:
    I am receiving an error when I start bukkit. I have properly installed java. And I am in the correct directories.

     java -Xms512m -Xmx2600m -jar craftbukkit.jar nogui
    After doing that command I get the following:

    Do notice the line in the above quote ""sh": java.io.IOException: error=12, Cannot allocate memory."

    The server will generate a world, but you can not connect to it using the MC client. Does anyone know what the problem is?

    Thank you for your help.
  2. Offline


    try this launcher:
    java -Xms2.5G -Xmx2.5G -jar craftbukkit.jar nogui
  4. Offline


    got 32 bit java?
  5. I assume it is 32 bit. When I type "java -version" it doesn't say 64 bit or anything.
  6. Offline


    Using OpenJDK? VPS's with burst memory (OpenVZ) don't have swap, and OpenJDK hates minecraft without swap.
    You should try Sun Java 6 using the repositories if your not using it.
    Had the same issue with OpenJDK in my VPS (when I had it) and when I switched to Sun Java 6, everything was fixed.

    You'd have to google for sun java repositories, I have no idea what it is anymore as its been months since I fixed it.
  7. Offline


    32 bit can only use up to 1.5 gb ram!
  8. Does this look right to you?

    If i try:
    It says:

    EDIT: I just tyred
    And I am still getting the error in my first post.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 14, 2016
  9. Wanted to post my findings.. it is because VPS don't get ANY swap space.. I get the same error unless i run "java -Xms256 -Xmx256 -jar craftbukkit.jar nogui"

    I submitted a support ticket for this issue because my server runs and I can have players. Though my issue is that when I use the reload command... Everyone gets disconnected and takes 8 seconds to reload. vs using the same config on my windows desktop I have no issues at all. Also on my centos box it takes 0.78seconds to load everything vs my home desktop is only 0.2 for initial script loading.
  10. Offline


Thread Status:
Not open for further replies.

Share This Page