[SEVERE] java.lang.ArrayIndexOutOfBoundsException: -3159265 server crash!

Discussion in 'Bukkit Help' started by Val-Dim, Aug 10, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Attached Files:

  2. Offline


    I get this too. Some of my players are very upset about it.
  3. Offline


    I used to get an error similar to this when a player used optifine and had the super-far-view or whatever it was called enabled.
  4. Offline


    Hmm not sure what's causing this, I would recommend removing your plugins and trying again to see if the error goes away.
    If it does go away then slowly add the plugins back one at a time and should hopefully find out which plugin is causing this issue.

    EDIT: If it's not plugin related then I guess I can only offer the basics:
    Update Java
    Update CraftBukkit(try dev builds)
    Basically, update anything and everything you can think of.
  5. Offline


  6. Offline


    I will, I'm doing right now. I started receiving a whole new variety of crashes as this one occured-right now, the server is unresponsible to logins and queries and I just don't know what's causing this, as in the console everything looks fine. I'll try downgrading the Bukkit build, as the night before this happened I updated it to reduce lag. Hope this helps.

    EDIT: Didn't help. Problem remains.

    The issue seems to cause crashes and login non-responsibility if it lasts too long. I'll try to update to the dev build and see if this remains. If it does, it's probably plugin-related.

    Edit: To be more accurate, I think it causes other exceptions.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 27, 2016
  7. Offline


    I updated to the latest build and tested the exact block that crashed, and it still crashes our server.
  8. Offline


    I tried, too. I did a little testing around, it seems to happen when a player enters a certain area where the some map delivery systems fail (see error log). I copied the .dat of a player that caused such failiure-his inventory was all OK, but at his coordinates the server put out the exception-in this case, areas of a jungle biome. I cannot yet figure out which regions would cause this and is there a pattern for them. I suppose there is.
  9. Offline


    Seems to be random, as my players encounter them mostly while strip mining.
  10. Offline


    I wouldn't say so-it happens in certain regions for me. The real problem is when a player logs out in such an area and tries to log in again later. Then during the "Downloading terrain" stage the server gets a mass of error messages.

    EDIT: I tried to log on with and without plugins on both the RB and the latest dev build-same error. It's obviously not plugin-related. On single player the map loads fine and there's nothing special about the region. It is either an error in the build, or a broken map that can only load on singleplayer... :eek:
  11. Offline


    I tried today if the map was broken-I deleted the region where this error occured, and regenerated it.
    Didn't help...
  12. Offline


    Turns out the map is really corrupted. I could not find any tools that could fix it :(
  13. Offline


    Look into chunkster. Not sure if it's updated as I haven't used it recently, but in the past it always fixed my corrupt world files like a charm!

    Also, if you can load the map in MCEdit and then save it again, that too can sometimes fix a lot of problems.
  14. Offline


    I tried Chunkster, but it just says "scanning world" then crashes.... And I think it's been updated for the last time November last year.
    IDK how's the situation with MCEdit, I'll try.
    One thing I know now-the whole problem is with the corrupted world, but I can find neither the reason nor the tool to fix it.
    EDIT: MCEdit crashed while rendering region 0,-1. That's probably the problem.
    Deleted it-the problem is still present.
Thread Status:
Not open for further replies.

Share This Page