Plugin Help serversign problem, tried almost everything.

Discussion in 'Plugin Help/Development/Requests' started by arno321, Mar 4, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    Hey everyone, im new to the forums but i browsed alot as a guest.

    my question is the following i made a signs with the commands.
    everything works as an operator (OP) but when i try it as a default group user or builder group etc. it doesn't work.

    i also use groupmanager and essentials.

    i tried these options:

    putting these permissions in the group default or builder,
    • serversigns.use.*: Allows the use of all ServerSigns on the server
    • serversigns.use: Allows the use of all ServerSigns which don't have a special permission set
    and also tried serversigns.use.promote

    then when that didn't work i tried this:

    Putting * before a command (instead of the /) will get the player to execute the command as if they have the permission '*'

    i dont know what else i could try to make it work.

    all the help is appreciated.
  2. Offline


    @Amo321 Also appreciated is all the info. You've said that you've tried to do the options. You haven't said what you've actually done. Please paste the commands you used here, and your gm or pex yml in
  3. Offline


    this is my /plugins/GroupManager/worlds/world/groups.yml
    i think u mean this yml with the permissions i've added.

    ive put these commands on the signs with the plugin serversign:

    /svs add <server>/manuadd <player> Builder
    /svs add <server>tp <player> 16 70 252

    hope this is what u were looking for.
  4. Offline


    @arno321 Did you actually set the 'promote' permission to the sign?
  5. Offline


    if im correct the serversign permission to it was /svs add permission everyone
    ...or am i incorect
  6. Offline


    @arno321 serversigns.use.everyone is not an actual permission.
    Also you actually need the slash for the tp command.
  7. Offline


    when me as an operator touches the sign it warps me to the specific place and puts me in the group builder.
    the only problem is that non-op players can't click the sign
  8. Offline


    @arno321 If that is your actual config then I don't know what to tell you.
  9. Offline


    i don't know if its my other plugins that can interfere with it.
    i have also noticed that non-op cant touch ANY sign, not only one with serversign commands also to join minigames they cant join. because they cant click the sign
  10. Offline


    @arno321 Maybe. Please post your plugin list.
  11. Offline


    here you go

    im using spigot 1.8.1 server
  12. Offline


    @arno321 I would guess that it's Lockette that's causing the problem
Thread Status:
Not open for further replies.

Share This Page