Server timing people out and then Crashing

Discussion in 'Bukkit Help' started by Raptero, Oct 28, 2019.

  1. Offline

    Raptero

    Hi guys,

    I've been running a server for the last 4 months however two days ago when the server was restarted a player logged on, it then allowed them to move but entities froze, then timed them out after about 20 seconds. Just before the server was restarted i updated my Java SE Runtime Environment to the 8u231 Windows x64 and was messing around in a separate file trying to remove the "this build is outdated" message that occured on server start up. To do this i downloaded latest java, git bash and the buildtools from spigot. I then proceeded to follow instructions and ended up with just a spigot server java file not the spigot and craftbukkit. I soon realised that the bukkit didn't download after a 1.12 update i believe it was. I then tried to add the spigot java file to the server that used to be bukkit as google told me all bukkit plugins worked with spigot. I then started this up fine with no "this build is outdated" message however when i joined to test it, it did the timing out thing described above. As i had no more time to sort it out i switched back to the original file i hadn't messed with (not the copy file) and started it up. However when someone joined that it still did the timing out described and hasnt stopped despite numerous efforts.

    Here is the crash report for the server:
    https://pastebin.com/Y9acrUr2

    Any help would be greatly appreciated!
    I would just like to mention that when a slightly older version of the server was relaunched it worked fine however after transferring world files to that it then reverted to the issue presented.
     
  2. Offline

    robertlit

    Your spigot/craftbukkit build is probably outdated.
     
  3. Offline

    Raptero

    But i don't get how it worked before when the bukkit said it was outdated. It caused no issue previously. There also seems no way to get an updated build of craftbukkit. Any suggestions?
     
  4. Offline

    timtower Moderator Moderator

    @Raptero Get and run Buildtools by spigotmc
     
  5. Offline

    KarimAKL

  6. Offline

    Raptero

    I did that at the very start however i did it again and got the same result with it just compiling a spigot-1.14.4 file and not a craftbukkit-1.14.4 file. I would like to state, if it wasn't clear from my original post, that the server worker completely fine before i tried to upgrade the build to get rid of the message that popped up upon start up in hope of making the server run more efficiently. I really appreciate the help so far guys thanks :)

    Edit: The same issue arose when i tried to log on after starting up the server. The console looked like this: https://gyazo.com/0959c868b9fda20b1454346c17c878ba however no crash report was made although this might have been because i closed the console tab after a few mins of it not responding

    I've noticed that this time out only occurs when the community village is rendered in which includes a decent amount of redstone however most if not all is turned off. I have also monitored my PC's performance that i run the server off and they are completely fine with the RAM rarely goin over 70% and CPU 40% when rendering the village
     
    Last edited: Nov 3, 2019

Share This Page