Inactive [SEC] PermissionsPlus v3.2.5p - Alternative commands to modify Permissions in-game now w/MWS [1337]

Discussion in 'Inactive/Unsupported Plugins' started by DigitalTyrant, Mar 20, 2011.

  1. Offline


    PermissionsPlus - Adds ability to modify Permissions in-game

    Updated: 10/6/2011
    Version: 3.2.5p [jar]
    CraftBukkit: [b1337jnks]
    PermissionsPlus adds commands to allow administrators the ability to modify their Permissions config from within Minecraft client. The most complete Permissions editing plugin for Bukkit. Supports Multi-World. Updated for MultiPlay!​
    REQUIRES: Permissions 3.x - Permissions Thread

    Includes: P2Aliases updated 10/6/2011


    Get updates on TWITTER!

    Installation and Usage information and Permissions nodes
    are available at


    It appears that I am not the only server admin that stuck to Permissions v2.7.4 so, I have released PermissionsPlusLegacy v2.4. It is a RB1000+ compatible version of PermissionsPlus v2.3. You can download this in the change log below.
    • You can specify multiple worlds separated using a comma. Do not use any spaces after the comma.
    • You can specify all worlds using an asterisk.
    • You can specify multiple groups using commas for the /user -addgroup command.
      /user -addgroup u:Username s:Group1,Group2,Group3
    • All Usernames and Groups can be shortened. You will be notified if more than one possible match is found.
      digital = DigitalTyrant, adm = Administrator
    • With 2.x+ you must add the info variable 'rank' to your groups in order to enable promote, demote and some group functions. You can set this variable from within the game using the command:
      /group -setinfo g:GroupName i:rank s:1-100+
                         /rankset GroupName 1-100+ world 
      The higher the number the higher the rank. Make sure you use i:rank and not i:Rank it is case-sensitive.
    • You can now set Promote and Demote limits. The Promote limit is the highest rank they can promote to. Demote limit is the highest limit that they can demote from. You can set these using the commands:
      /group -setinfo g:GroupName i:dlimit s:50
                         /group -setinfo g:GroupName i:plimit s:75 
    If you use want to Permissions + PermissionsPlus while using Essentials plugins, make sure you do not have FakePermissions or EssentialsGroupBridge enabled.

    Not sure how long this will be useful with Bukkit's upcoming Permissions system, but it allows the Moderators of my server to give new members access without having to modify the .yml file directly. I will continue development until the new Bukkit Permissions system has widely replaced Permissions plugin.
    Thanks to Nijikokun, original author of Permissions.

    Thanks and Enjoy!
  2. Offline


    why it doesent work for linux ?

    Help pleas !
  3. Offline


    The answer is yes i was testing it on my self i lowerd my self to super admin and was able to put my self back up how ever it is the promote command should not add a group. and make it so the user has 2 groups

    then again you cant really go checking for that because some servers may need 2 groups :/
    maybe a config option like maxgroups max groups any 1 user can be in :/ idk was weird that it still did it i can send you a copy of my file.


    take a copy of this. its the files from the world i did it in.

    What I DID:
    start as owner demote your self with.

    /demote username *

    then try and promote your self up to owner from superadmin
    /promote username * I used the (*) because i have 2 worlds with the same groups and users.
    it wont look like it worked from ingame but it buggers up the file and gives them owner.

    Attached Files:

  4. Offline


    When I load this, only the /user command works. All the other commands nulled and when I checked console I saw this message:
    11:39:52 [INFO] [P2] version 3.0 has been enabled.
    11:39:52 [INFO] [P2] Group TheOwner does not have a rank defined in World world
    11:39:52 [INFO] [P2] Group Admin does not have a rank defined in World world
    11:39:52 [INFO] [P2] Group Moderator does not have a rank defined in World world

    11:39:52 [INFO] [P2] Group Builder does not have a rank defined in World world
    11:39:52 [INFO] [P2] Some groups do not have a rank defined, some commands are d
    11:39:52 [INFO] [P2] Group TheOwner does not have a rank defined in World world_
    11:39:52 [INFO] [P2] Group Admin does not have a rank defined in World world_net
    11:39:52 [INFO] [P2] Group Moderator does not have a rank defined in World world
    11:39:52 [INFO] [P2] Group Builder does not have a rank defined in World world_n
    11:39:52 [INFO] [P2] Some groups do not have a rank defined, some commands are d
    11:39:52 [INFO] [P2Aliases] 1.2 Enabled.
    I have all those groups in both world and world_nether, even in globalgroups. Help!
  5. Offline


    @zawmbee42 try reading the install again mainly the part about the rank: in the permissions file.Fyi in the info section like under build true. then a number lower number lower the rank and don't start at 1 because the plugin has a bug and it will not demote to group 1 so start at 2 or 3 for the lowest group.
  6. Offline


    I have a suggestion, could you add a command that changes a prefix?
  7. Offline


    Renaming Permissions didn't make it load first.
  8. Offline


    i got a new workaround for that problem

    rename the permissionsplus.jar into zpermissionplus.jar
  9. Offline


    getting this error wtf...

    2011-06-20 13:41:48 [SEVERE] Could not load 'plugins/PermissionsPlus.jar' in folder 'plugins':
    java.lang.NoClassDefFoundError: com/nijiko/permissions/Entry$EntryVisitor
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.reload(
    at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    at net.minecraft.server.NetServerHandler.handleCommand(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.Packet3Chat.a(
    at net.minecraft.server.NetworkManager.b(
    at net.minecraft.server.NetServerHandler.a(
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(
    Caused by: java.lang.ClassNotFoundException: com.nijiko.permissions.Entry$EntryVisitor
    at$ Source)
    at Method)
    at Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 20 more
  10. Offline


    what version of permissions and P+ are you running, permissions 3.x and p+ 3.0?
  11. Offline


    Didn't work either.
  12. Offline


    same as all others.

    P+ loads befor P is loaded.

    rename the jar files or wait for update.
  13. Offline


    I'm having problems with setting up the ability to promote and demote people. I've done the setting of ranks, the dlimits, and the plimits, but it keeps telling me "Some groups do not have a rank defined, some commands are disabled." Is there anything I should post to help?
  14. Offline


    rename to what plz ?

    i tried it too, didn't wroked p+3.0 p3.1.5b

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  15. Offline


    my mods cannot promote, i added the plimit and dlimit but wont work.
    i need your patcher, update or something.

    prefix'&1[&dMOD&1]&f '
            - Default
  16. Offline


    hey is it possible to removegroups from and playeR ?
    like i revoked smb and i want to whitelist him again
    is ist possible to user /user -removegroup u:... s:Revoked w:w*
  17. Offline


    Hey, I appreciate seeing this plugin updated. Why the makers of Permissions don't just follow this scheme and use (to me) a non-user friendly system for in-game commands is beyond me. Anyways, since this is update I've been trying out P3.x and P+3.0 on my local server with our main server's permissions. Everything seems to be working except for 1 key ingredient: /groupset

    /user -addgroup u:Test s:Builder Works just fine, however /groupset Test Builder gives me this error in-game: [P2] You must specify the user and group(s) you would like to add the user to. I get nothing in the console when I get that error however. All my ranks are setup from P+2.x, so I doubt that to be the problem.

    Let me know please, this is the only thing keeping us on P2.x & P+2.x. I do wish the Permissions team would bring you on board though. :p
  18. Offline


    My mods cant promote or demote they have p2.demote and p2.promote why is this they only have a plimit of 4 they are 5 and they can not move rank 2 to rank 3 or do any thing to them self :/ <<< confused

    the command is returning an internal error for them.
  19. Offline


    Just wondering...why would you want this if P 3.X already has commands, even though they suck? Like does it override the track system (which also sucks)?
  20. Offline


    promote demote is much easier for my team.
    inversation likes this.
  21. Offline


    seconded. Alas it is not working for me still, and I've tried heaps. Setting the lowest rank to a number above 1 (I moved to 10+), setting plimit and dlimit values, copying the groups config across both of my worlds (including global), specifying * instead of the world name, nothing seems to work, it just keeps throwing exceptions :(
  22. Offline


    You could try this inside your plugin.yml (Essentials uses it for iConomy):

    depend: [Permissions]
  23. Offline


    If someone has it working fully, would they be willing to post their permissions files so I can have a look and see if there's something obvious I'm just missing in my setup?
  24. Offline


    what sort of exceptions is it throwing? here's a copy of mine which works fine

    Attached Files:

  25. Offline


    there is no p2.promote p2.demote
  26. Offline


    i only really tested as an admin, so there was no need for me to add them to the permissions file. i'm running it on a local server atm, as i haven't had time to add it to the main server.
    Updated, and still works without any issues.
            default: false
                prefix: '&cMOD'
                suffix: ''
                build: true
                rank: 50
            - BasicUser
            - residence.create
            - iConomy.access
            - iConomy.admin.account.create
            - iConomy.admin.reset
            - iConomy.admin.hide
            - permissions.user
            - permissions.promote.main
            - p2.promote
            - p2.demote
  27. Offline


    yeah i told "my team have problems" i can promote and demote
  28. Offline


    Whenever I use the promote command it promotes the player and allows the player to use the commands in the next group, but it keeps the same prefix as the group it was in before. The only work around I can think of is a command to remove a player from a group. Such as /user -removegroup u:username s:GroupName w:World

    Could you please add the command to the plugin? :)
  29. Offline


    Hey, what is the EXACT command to promote someone?
    Like, if I shall promote the player AAmdahl to the group AA, what do I use?
  30. Offline


    The EXACT command is /promote AAmdahl
    Then you keep typing that in till the player is promoted to that group, you have to set the ranks of the groups 1st by typing /rankset AA <Rank#(The Higher The Number The Higher The Rank)> <World> or /group -setinfo i:rank g:AA s:Rank# w:WorldName
  31. Offline


    Im not really thinking of that RANK... Because I got 3 ranks: AA, HG and TM. They are the axact same, just the citys location. How do i like... Set the GROUP of them..?

Share This Page