:s can't get bukkit to run

Discussion in 'Bukkit Help' started by Carnage104, Jan 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    hey guys
    I'm new to linux, and i just got a VPS yesterday and ran a bog-standard minecraft server for a while. Today, i want to get bukkit up on the server, but i'm having problems running it.
    Everything i try to get it running suggested here on the forums comes up with this:

    root@ausrpcraft:/minecraft/bukkit# ./server_starter.sh
    Exception in thread "main" java.lang.NoClassDefFoundError: org/bukkit/craftbukkit/Main
    Caused by: java.lang.ClassNotFoundException: org.bukkit.craftbukkit.Main
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    Could not find the main class: org.bukkit.craftbukkit.Main. Program will exit.

    Ive tried some other codes to run it as well.
    I'm stuck, any ideas?
  2. Offline


    Post your server_starter.sh file.
  3. Offline


    heres what i've tried
    screen -S minecraft java -Xms1024M -Xmx1024M -jar craftbukkit1.jar nogui
    java -Xms1024M -Xmx1024M -jar craftbukkit1.jar nogui

    then i treid that with standard download file didnt work (yes i renamed the jar to craftbukkit1)
Thread Status:
Not open for further replies.

Share This Page