Read Timed Out

Discussion in 'Bukkit Help' started by MGNick, May 4, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Moo Master

    Worldguard, Essentials, Worldedit, bigbrother, permissions, and server save are the only plugins that i've transfered over onto my second server. And it still crashes. :(
     
  2. Offline

    Godwar101

    This is a general problem ...
    Please bukkit developers take a look to this problem.
     
    THG3 likes this.
  3. Offline

    Locx

    has nothing to do with plugins. It is most likely our Ram or Cpu that is the problem. Check canihostaminecarftserver.com to see how much Players you can have on your server.
     
  4. Offline

    Joannou1

    My server can host 106 people according to that site... It goes town randomly due to that.
     
    Moo Master likes this.
  5. Offline

    Moo Master

    I think the bukkit devs on an earlier post said something about them not being able to re-create it, think there might be a way that we could recreate it? Because i get no java errors, it just stops. And then sometimes says read timed out.
     
  6. Offline

    maxij

    I actually moved my server to a host today.
    I'm also getting it there, i'm still waiting for their response about this problem, but i can definately say that "overload" is not the problem.
     
  7. Offline

    Locx

    Is it read timed out error? i fixed it by switching from permissions 3.1.6 to 3.0.0. I.m not sure baout any higher versions though. and also. Lucky you. mine can host 12....-_-
     
  8. Offline

    Joannou1

    lol :p I got this mod called rTriggers, set it to do /stoplag and stoplag -c with world guard every 2 hours automatically... It works pretty good! No more errors
     
  9. Offline

    Zaila

    Since this topic is here, i will post there.

    I'm basiclly having problems with the ArgonathRPG Minecraft server. Every player that is trying to connect to the server is either getting timed out, the name can't be verified or End of stream message. When trying to downgrade to 1000 again, the problem is still there. I will add the error message i get in the logs:

    Code:
    2011-08-26 01:08:41 [INFO] Disconnecting SpartanWabbit [/<IP Removed>]: Failed to verify username! [internal error java.net.UnknownHostException: www.minecraft.net]
    2011-08-26 01:08:41 [SEVERE] java.net.UnknownHostException: www.minecraft.net
    2011-08-26 01:08:41 [SEVERE]     at java.net.PlainSocketImpl.connect(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at java.net.SocksSocketImpl.connect(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at java.net.Socket.connect(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at java.net.Socket.connect(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.NetworkClient.doConnect(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.http.HttpClient.openServer(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.http.HttpClient.openServer(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.http.HttpClient.<init>(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.http.HttpClient.New(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.http.HttpClient.New(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at java.net.URL.openStream(Unknown Source)
    2011-08-26 01:08:41 [SEVERE]     at net.minecraft.server.ThreadLoginVerifier.run(ThreadLoginVerifier.java:34)
    Plugins:
    AdminChat
    AutoMessage
    DeathMessagePlugin
    dynmap
    Essentials
    Factions
    GriefAlertR
    HeroChat
    ItemLogger
    Lockette
    LogBlock
    LogBlockQuestioner
    Minequery
    MotherNature
    MultiVerse
    OwnBlocks
    Permissions
    PlugMan
    SpawnX
    Spout
    VanishNoPickup
    WorldEdit
     
  10. Offline

    Locx

    glad it works :D. but seriously.. 102 people at a time?! I would really like to know what type of pc or router you're using :) lol i would want at least more than 12 at a time on my server :p
     
  11. Offline

    Joannou1

    Well I have Verizon FiOS (Fiber Optics) internet! a 35/35 plan, so it can handle alot. And I custom build my pc.
    16GB memory, Intel i7 Quad Core.
     
  12. Offline

    stkeroro

    anyone can host more then 30 players without lag, minecraft don't want.
     
  13. Offline

    duck0311

    This error has plagued me for a couple weeks. Sometimes it can go hours without happening other times it is down in 15 minutes. No java error just Read Timed Out over and over and over again I am starting to have nightmares about it.
     
  14. Offline

    M1sT3rM4n

    Permissions 3.1.6 is known for causing that bug.
     
  15. Offline

    THG3

    This really needs to be fixed.
     
  16. Offline

    duck0311

    Your telling me. Tired of getting calls at all hours Server is down server is down....
     
  17. Offline

    THG3

    I don't get why the bukkit devs can't even explain it..

    Code:
    CONSOLE: Connection reset
    CONSOLE: Read timed out
    CONSOLE: Read timed out
    CONSOLE: Read timed out
    I get this at least twice a day even with no plugins.

    It's seriously a bukkit memory issue. My server has more then enough ram to do the things I want to do.

    I don't mean to triple post but I get this every time before the read timed out error.



    This is beyond frustrating.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 15, 2016
  18. Offline

    Mrlovecraft

    I never got this issue before. Just moved from my home pc to a badass server - and now i see it every day.
    Some things i changed. went from quadcore 2.5ghz 4 gig ram - to 16 core 2 ghz 12 gig ram.
    im currently not on SunJava - i was before and i hope that this is the problem.
    so to me it seems the drop in cpu clock might do this or perhaps openjava??
     
  19. Offline

    Lunar Delta

    This is NOT a Bukkit issue. I have never had any problem like this whatsoever. This is a Permissions 3.1.6 issue. This is well-documented.
     
  20. Offline

    kappatango

    Strange comment - I have the same probelm yet I do not use Permissions plugin. I have today tried everything I can to get bukkit running on my Win 7 64 bit without this error, no can do.

    I ran a standard server, NO Plugins and NO bukkit - all completely stable.

    The only plugins I have run on Bukkit are Essentials.

    I have tried fresh install ( both manual and using the craftbukkit installer ) as well as trying both Java 6 and 7.

    Unless I run a vanilla Minecraft server, all users get the Read Time Out then [SEVERE] Java socket errors.

    This needs to be addressed if we are to be able to host with commands.

    In addition, have you seen how many VIEWS this thread has had - probably an indication of the size of the issue.....
     
  21. Offline

    xLoGiiKzZo

    Updating to the New Essentials fixed my Read Timed Out problem
     
  22. Offline

    kappatango

    This is a new server I have setup in that last 2 days - I have the latest essentials 2.5.7
     
  23. Offline

    pandapipino

    - Try updating to the new essentials (loads the player files more faster)

    - Try removing the plugin Minecraftviewer (connection errors popping up when this is enabled which I suspected the cause of heavy read timed out errors on my server console)

    - Try installing Remotetoolkit plugin (it has crash detection that will restart you server automatically)

    - Update permissions to permissions EX

    - Also downground to craftbukkit 1000 if you can.

    My server is running kinda stable right now, I will be posting some problems when I encounter this problem again.
     
  24. Offline

    THG3

    Sorry but that is not correct. There are several vanilla plugin free servers that also have this issue. This IS a bukkit issue.
     
  25. Offline

    Lunar Delta

    I don't believe so. I've noticed a trend here. Virtually all of the people who have this problem either use Essentials, or Permissions 3.1.6, or both. If neither of those are true, I am sure there is some other contributing factor, because most informed people it seems do not suffer from this issue.
     
  26. Offline

    micromoose

    Got rid of essentials, and use 3.1.5 permissions and still got it a few times today. Only one user had extreme lag that slowly affected the whole server and caused read timed out errors. No plugin broke that I could tell I cant find a real reason for it.
     
  27. Offline

    zeeveener

    This won't work if its running on MCMA as well will it. Cause this error is causing MCMA to crash...
     
  28. Offline

    maxij

    I talked to the support on my host the other day and they said to me to try and disable MCmmo, after i did that this issue dissapeared (so far). If you have MCmmo i'd recommend to try it out for at least 24h.

    It works like a charm so far. :)
     
  29. Offline

    bukloveur

    read time out = stop connexion = he afk or he connexion bug and have stop
     
  30. Offline

    THG3

    Bump.

    Sorry won't let bukkit dev's ignore this.
     
Thread Status:
Not open for further replies.

Share This Page