Read Timed Out

Discussion in 'Bukkit Help' started by MGNick, May 4, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    MGNick

    Server keeps crashing all of the sudden and causing major lag. Terminal window is saying "Read timed out". Not sure what this means, can someone explain to me what this means and how to fix this.

    Plugins: world guard, world edit, bigbrother, essentials, craftbook, dailybonus, epic gates, iconomy, lwc, mcmmo, nocheat, permissions, real teleporter
     
  2. Offline

    Matalok

    Similar issue, server will start lagging then everyone will get disconnected (with Read Timeout) and unable to reconnect. No stack traces in the console. This has only started recently (say CB720+) but i'm not sure if its due to the uptick in users i've got connected. I've bumped the memory and assigned amount to Java, going to see if it happens again.

    WorldGuard, WorldEdit, LWC, Permissions, BigBrother, AssignPermissions, Landmarks, ModTRS, Sortal, MCDocs, iChat.
     
  3. Offline

    Zaflis

    I have a buckit server 740 set up, which is basically used by just me and a friend at this point. Server works fine for me with out without plugins but he gets "Read timed out". We used to play longer with older buckit versions but he has always had random disconnections. With 740 he can't stay online at all.

    Steps tried:
    - Move all .jar files from plugins\ to a temporary folder and run a clean bukkit -> "Read timed out" always.
    - Use basic minecraft server from minecraft.net -> works, but he still gets rarely disconnections.

    My own connection to buckit always works and i use the same external IP, not localhost.

    Code:
    14:13:11 [INFO] K*** [/85.***.***.***:50077] logged in with entity id 12263
    2
    14:13:41 [INFO] Read timed out
    14:13:41 [INFO] K*** lost connection: disconnect.endOfStream
    Also about server hardware:
    Windows 7, 4Gb RAM, 3GHz dualcore
    Buckit launched with 1024 memory parameters.
     
  4. Offline

    Glyn

    Try this proxy on the server machine/client/server and client: <Edit by Moderator: Redacted mediafire url>
     
    Last edited by a moderator: Dec 14, 2016
  5. Offline

    Zaflis

    How do i use that? Maybe it has some commandline parameters i need to know?

    Solved problem from my part with start of using Hamachi again.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 15, 2016
  6. Offline

    wassilij

    I have the same Problem .. same Plugins: Permissions, mcMMO, essentials :/

    It's horrible .. server timed out (crash ..) and need to restart.

    Plugin-List:
     
  7. Offline

    MGNick

    Still no fix found yet. Anyone else know a fix? Its getting really annoying.
     
  8. Offline

    Flenix

    I'm getting this too. I've narrowed it down to:

    WorldGuard, WorldEdit, Permissions, BigBrother, LWC

    Annoyingly 5 of the biggest plugins. The two guys who posted lists at the top had these in common and we also have all 5.
    Can't be the first two because sq89k's code is "perfect" (Total sarcasm, just annoys me how much he b***h's about everyone elses coding... equal chance its one of those to to the rest really :p)

    From what I've seen cruising forums, its BB. Problem is, disabling BB wipes your database... So who fancy's testing that?
    If it is BB then we gotta choose, let griefers run wild or get these errors..?
     
  9. Offline

    wassilij

    I deactivated BB tree days ago and added Ownblocks, problem don't solved ;(

    Plugin-List:
    I deleted now some plugins and hope the server dont crash again .. i deleted also the libs.

     
  10. Offline

    MGNick

    Dam, now I am getting the Read Timed Out error like non stop now. Just happened all of the sudden over night.
     
  11. Offline

    wassilij

    Okay .. i think now my Server dont crash .. see above what i deleted but now its okay :D

    Edit:// WTF? I write this Post and my Server crashed: Read timed out ;_;
     
  12. Offline

    MGNick

    Overall do you think it was caused by Bigbrother? Cause I really do not want to get rid of this plugin. The error just happened all of the sudden, not sure if it has to do with the latest update for the plugin.
     
  13. Offline

    wassilij

    No it has nothing to do with BigBrother .. i deactivated BigBrother (and many other Plugins too) and my server still crash ..

    but i noticed that the server crashed often when i come often or when im on .. so im deoped me and give me the same permissions like all .. maybe its now better ..
     
  14. Offline

    axebyte

    I have WG WE and thats it from your list of narrowed down. Still get it alot. Just thought i let you know :D. Are they sure it is not a bukkit issue causing this? On 740jnk but everything above it does it, and below it least the 1.5
     
  15. Offline

    MGNick

    If it is a Bukkit error I hope they fix it soon. It's almost at a point where its non stop
     
  16. Offline

    Flenix

    Well its either Bukkit or one of Sq89k's plugins, now we just need a few more people to post back saying whether they have those plugins or not...
     
  17. Offline

    sofah

    We just downgraded to 739, and it seems to have disappeared-
     
  18. Offline

    MGNick

    I just upgraded to build 760 something, it only occured once today.
     
  19. Offline

    MGNick

    So far only a couple Read Timed Out errors have occurred since I upgraded from build 740, but have noticed even before I upgraded, when a player leaves the console also states "Connection Reset" which cause lag, anyone know a fix 2 that?
     
  20. Offline

    kramark

    I am having this problem as well. It happens randomly and locks up my whole server. I have a remote VPS and when it locks up, I cant connect with SSH.
     
  21. Offline

    Killburner

    I've been getting the same error since CB733, about once every 2 days on average.

    Major plugins include CommandBook, LogBlock, MutliVerse, WorldEdit, WorldGuard.
     
  22. Offline

    Bokou

    disabled all my plugins and was still getting time out errors on 740. The server never crashed but I like to restart my server every few days. Running vanilla server alongside the bukkit server on the same machine and was able to connect to it just fine.

    Using McMyAdmin I disabled bukkit and it worked just fine

    holding off on using Bukkit again until there's a solution that works
     
  23. Offline

    aeternii

    Guys, this issue is frustrating... To the bukkit team: PLEASE SOLVE IT.
    I'm sometimes getting 4-5 of these an hour.
     
  24. Offline

    DylanP

    23:35:25 [INFO] Read timed out
    23:35:27 [INFO] Read timed out
    23:35:29 [INFO] Read timed out
    23:35:34 [INFO] Read timed out
    23:35:37 [INFO] Read timed out
    23:35:39 [INFO] Read timed out
    23:35:51 [INFO] Read timed out
    23:35:53 [INFO] Read timed out
    23:35:55 [INFO] Read timed out
    23:35:57 [INFO] Read timed out
    23:35:57 [INFO] Read timed out
    23:35:59 [INFO] Connection reset
    23:35:59 [INFO] Read timed out
    23:36:01 [INFO] Read timed out
    23:36:05 [INFO] Read timed out
    23:36:05 [INFO] Read timed out
    23:36:06 [INFO] Read timed out
    23:36:06 [INFO] Read timed out
    23:36:08 [INFO] Read timed out
    23:36:10 [INFO] Read timed out
    23:36:13 [INFO] Read timed out
    23:36:15 [INFO] Read timed out
    23:36:21 [INFO] Read timed out


    Same here...
     
  25. Offline

    Killburner

    This was happening every few days. Now out of the blue this afternoon it started every hour. Updating to RB766 earlier doesn't seem to have made any impact, positive or negative. I do use McMyAdmin FWIW.

    I guess it's time to start stripping plugins and isolating, but my spidey-sense tells me it has nothing to do with plugins.
     
  26. Offline

    Bokou

    mine was happening with zero plugins, Killburner
     
  27. Offline

    Phinary

    I believe this happens when a player logged in at a glitched chunk. Try to figure out who logs in or what happens before it says that then reset that character. Thats what fixed it for me
     
  28. Offline

    Killburner

    Shaun, you may be on to something. For the 1st time ever (4+ months) I encountered a missing chunk on my server, at 0,0 this case. I repaired it with ChunkRegenerate however the read error started before the repair.
     
  29. Offline

    Derangedyeti

    I don't think it is a corrupt world, or a player's spawn. I have had the same problem. I did a test with a fresh world before and it still happened. My server.log has this happening when NO ONE is on the server. So...
    Maybe a mob encountering something weird?
     
  30. Offline

    QuackzMcDuck

    Notice how almost everyone with this problem in this thread has WG and WE....
     
Thread Status:
Not open for further replies.

Share This Page