Read Timed Out problem.

Discussion in 'Bukkit Help' started by Tadas159, Jul 6, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hello everyone​
    So I start my server, and after some time it stops working, It works, but you can't login into it because it says "logging in". Please help me to optimize server.​
    My OS - CentOS 64bit​
    java version "1.6.0_17"​
    OpenJDK Runtime Environment (IcedTea6 1.7.10) (rhel-1.20.b17.el5-x86_64)​
    OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)​
    No Wrappers​
    Craftbukkit 1000​
    Command to run bukkit: java -Xms1048M -Xmx2560M -jar Craftbukkit.jar nogui​
    Plugins: AntiBuild, AutoMessage, AutoSave, Backup, BigBrother, BorderGuard, ClayGen, CommandBook, dynmap, Help, HeroicDeath, iChat, iConomy, iConomyChestShop, jobs, LWC, MagicCarpet, milkAdmin, Minequery, MyHome, MyWarp, Permissions, PermissionsPlus, SignLift, SimpleReserve, Tombstone, WorldEdit, WorldGuard.​
    Error: 2011-06-12 14:20:15 [INFO] Read timed out​
    Please help i have this over a month.​
  2. Offline


    Lots of people had that problem with MCMMO but you are not running that. The other thing that people done was switch from the latest permissions 3.1.6 to the 3.1.5. Also you can try switching from permissions system to a PermissionsEX which is a lot faster and easier to use. There are reports of that error going away after the permissions switch. For me it only worked when switched permissions and removed mcmmo.
  3. Offline


    It can't be any of these I got this error when i had permissions 2.4.7 also.
  4. Offline


    Any help?
  5. Offline


    Running Java 1.7 has definitely slowed down this problem, but it's still a big problem. It's generally accepted now that this -is- a bukkit issue since many have run it without plugins and still get this error.

    How to run with java 1.7:

    I'm going to continue my quest to fix this on this thread:

    Since it seems to be more comprehensive and older.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  6. Offline


    to fix the error update the craftbukkit it should help
  7. Offline


    I think some plugins are interacting with each other and that causes this.
    My craftbukkit is up to date now.
  8. Offline


    Not sure if anyone is still reading this thread, but I -FINALLY- fixed the "Read Timed Out" issues. It was the Permissions 3.x plugin. I rebuilt it with 'fair mode' and it's been running all night at around 1GB with no memory leaks. Here's a link to the thread post with more details and a download link (if you all want to try):

    Note: I'm using CB#1000 and haven't had -any- permission problems or "Read Timed Out" issues.
Thread Status:
Not open for further replies.

Share This Page