Problems with Citizens 2

Discussion in 'Bukkit Discussion' started by Lumynum, May 14, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    Hey netizens.

    I've recently encountered a considerable bug when trying to create NPCs in the newest version of Citizens. I enter the command correctly (thousands of times) and nothing ever happens. I've tried searching the web for any known solutions but I've had no luck on the topic.

    I basically want to create a simple guard that attacks anyone from a certain faction in the area, but I can't seem to summon the NPC regardless of my efforts! I will type in the command countless times but I still get no results.

    Here is any and all relevant information that I believe anyone that could fix this case would deem useful:
    • Minecraft Version (as of date): 1.7.9
    • CraftBukkit Version: 1.7.2 (MC: 1.7.9)
    • CraftBukkit Details: git-Bukkit-R0.3-66-g43d8943-b3078jnks (Implementing API version 1.7.9-R0.1-SNAPSHOT)
    • Citizens Version: 2.0.11 (Alpha)
    • Sentry Version: 1.8.0
    • Essentials Version: 2.12.2
    • Vault Version: v1.2.31-b411
    • Command attempted: /npc create Guard
    Please, if you have any idea how to 'fix' this, then do tell. Are there any prerequisites I might've zoned out on? Any plugins that must be installed beforehand? Have I done something wrong when installing said plugin?

    I have recently tried posting this same topic in the Plugins Development area. I was most promptly redirected here.

    Any and all help is vastly appreciated. Thank you for your time and support.
  2. Offline


    Give a newer Dev. version of Citizens a try

    Keep in mind these are development builds and should not be used on a production server with out testing. Hope this works for you!
  3. Offline


    1.7.9 is a Dev Release. I would imagine the devs are working on the plugins.
Thread Status:
Not open for further replies.

Share This Page