Possible Memory Leak

Discussion in 'Bukkit Help' started by lolzwaffle, Feb 23, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    1. CentOS 6
    2. x64
    3. Oracle Java 7, x64
    4. I am using Multicraft
    5. Build #3023
    6. server-log: http://pastebin.com/cJGDmkdK
    server.properties: http://pastebin.com/ppdjdbJH
    bukkit.yml files: http://pastebin.com/PEy87UBr

    7. The only command being ran is:
    java -Xmx2048M -Xms128M -Djline.terminal=jline.UnsupportedTerminal -jar /home/multicraft/multicraft/servers/server1185/craftbukkit.jar nogui
    8. Buycraft, Essentials, Factions, McMMO, mcore, Multiverse-Core, Multiverse-Inventories, OpenInv, Paintball, PermissionsEX, pvparena, SimpleBackup, SimplyVanish, SWatchdog, WorldEdit, WorldGuard
    9. The memory on my server increases at a rapid rate. I have to restart the server 2 - 3 times a day to decrease it back to 40%.
    10. I have uninstalled and reinstalled all plugins. I have made sure they are all updated. Also, I have even disabled all plugins and the same issue continues to happen. I have talked with my host and they tried troubleshooting it on their end and they didn't find anything wrong. We even tried all of the CraftBukkit builds from #3020 - #3023. When we tried running vanilla, the possible memory leak stopped happening.
    11. I have tried everything that you suggested.
  2. Offline


    Does anybody have any idea if this could be a memory leak? If so, any other ideas on how to fix it?
  3. Offline


    Are you tracking the timings on your plugins? If so can you post the like the 3rd or 4th newest one?
  4. Offline


  5. Offline


    Are those the right timings that were needed?
Thread Status:
Not open for further replies.

Share This Page