Problem/Bug PermissionsEx

Discussion in 'Bukkit Help' started by TheKiwi, Aug 20, 2019.

Thread Status:
Not open for further replies.
  1. Offline

    TheKiwi

    21.08 00:24:41 [Server] INFO ========== UNABLE TO LOAD PERMISSIONS BACKEND =========
    21.08 00:24:41 [Server] INFO Your configuration must be fixed before PEX will enable
    21.08 00:24:41 [Server] INFO Details: Error loading permissions file!
    21.08 00:24:41 [Server] INFO =======================================================
    ||
    I made a copy of the permissions folder on docks you can see it here or on the attached file ||
    (No spaces on the text below if you want to see the spacing look on the attached file) \/
    Code:
    groups:
     default:
     default: true
     prefix: '&8[&7Member&8]&f ‘
     permissions:
     - landclaim.default
     - modifyworld.*
    Helper
     default: false
     prefix: '&a[&2Helper&a]&f&l
     inheritance:
     - default
     permissions:
     - landclaim.default
     - modifyworld.*
     - -bukkitcommand.kick
     - -bukkitcommand.teleport
     Moderator
     default: false
     prefix: '&5&k[&5Moderator&5&k]&d&l
     inheritance:
     - Helper
     permissions:
     - landclaim.default
     - modifyworld.*
     - -bukkitcommand.kick
     - -bukkitcommand.teleport
     - -bukkitcommand.ban
     - -bukkitcommand.gamemode
     Admin
     default: false
     prefix: '&0&k[&4Admin&0&k]&4&l
     inheritance:
     - Moderator
     permissions:
     - landclaim.default
     - modifyworld.*
     - -bukkitcommand.kick
     - -bukkitcommand.teleport
     - -bukkitcommand.ban
     - -bukkitcommand.gamemode
     - -bukkitcommand.admintools
     - -bukkitcommand.give
     - -bukkitcommand.givemoney
     HeadAdmin
     default: false
     prefix: '&e&k[&cAdmin&e&k]&6&l
     inheritance:
     - Admin
     permissions:
     - landclaim.default
     - modifyworld.*
     - -bukkit.command.kick
     - -bukkitcommand.teleport.
     - -bukkitcommand.ban
     - -bukkitcommand.gamemode
     - -bukkitcommand.admintools
     - -bukkitcommand.give
     - -bukkitcommand.givemoney
     - -bukkitcommand.kill
     Owner
     default: false
     prefix: '&6&k[&3Owner&6&k]&b&l
     inheritance:
     - HeadAdmin
     permissions:
     - landclaim.default
     - modifyworld.*
     -  '*'
    schema-version: 1
    users:
     a1848d8d-68de-4f8b-90df-db10f5c021b3:
     group:
     - Owner
     options:
     name: TheKiwiYT
     bef8a7a2-f421-4bd0-b268-b12b74a10d17:
     options:
     name: JerryCash
     6b19ee38-66bb-4f78-b198-7d3b68a080b2:
     options:
     name: MonkeyNito
     9f024497-0637-4470-b866-9501f9c00613:
     group:
     - HeadAdmin
     options:
     name: boomis
     

    Attached Files:

    Last edited by a moderator: Aug 20, 2019
  2. Online

    timtower Moderator Moderator

    @TheKiwi Your group names are missing colons.
    Your group names have the wrong indentation.
     
  3. Offline

    TheKiwi

    I put colons after group names and tried 3 spaces and 2 spaces before group names but it came up with the same message here is the file I have now
     

    Attached Files:

  4. Online

    timtower Moderator Moderator

    @TheKiwi You are using multiple types of quotes or none at all. You need to fix that.
     
  5. Offline

    TheKiwi

    Is this better?
     

    Attached Files:

  6. Online

    timtower Moderator Moderator

    @TheKiwi Does it work on the server?
     
  7. Offline

    TheKiwi

    kind of but the commands i added dont work so admins cant use kill or kick or ban or anything only owner works. I didnt know how to make it work so i did something like bukkitcommand.kill

    this is my new file and it works but commands still don't work

    I tested it by setting my friend to rank admin and deopping him and he tried the adminessentials: and the normal versions of the commands and none worked

    The owner commands work and I can set peoples ranks but prefixes don't work even though I installed vault
     

    Attached Files:

    Last edited by a moderator: Aug 22, 2019
Thread Status:
Not open for further replies.

Share This Page