Permissions EX Ranks Not Working!

Discussion in 'General Help' started by MCJoshua345, Oct 1, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    MCJoshua345

    The title says it all. The prefixes aren't showing up and the permissions have no effect.Here's my Permissions EX permissions file. For your convenience, I have put it on Pastebin:
    http://pastebin.com/vZsuWpDt
    Please help! I need this on my server!
     
  2. Offline

    LHammonds

    If you used an Online YAML Parser, you would have noticed there was a problem on line 224. You have an extra space before "options:" which messes up the entire format of the file.
     
    farkros and DrPyroCupcake like this.
  3. Offline

    JaguarJo Retired Staff

    You also have two users sections, two schema-version lines, a Creator group defined in the users section instead of in groups, and multiple permission nodes that are written incorrectly (periods make a difference; it should be essentials.* not essentials*).
     
  4. Offline

    MCJoshua345

    Thanks SO Much! But how do you add a user to a group inside the permissions.yml?
     
  5. Offline

    JaguarJo Retired Staff

    It's probably easier to add users to groups using the in-game commands (/pex user playername group set groupname), but if you want to do it directly in the file, it would look like this:
    Code:
    users:
      590fa256-cd8f-48fb-a214-ebcad45097cc:
        options:
          name: westrey261
        group:
        - Members
    The group line should be indented 4 spaces with the name of the group lined up under it, kind of like how permission nodes are done. Make sure that you match capitalization, because PEX is picky about letter casing and will consider member and Member as two separate groups.

    Also, if you want players to be added to a group automatically when they first join the server, then you should add the line default: true to the options section of that starter group. Like this:
    Code:
    groups:
      Members:
        permissions:
        - modifyworld.*
        - cook.*
        options:
          rank: '300'
          rank-ladder: main
          prefix: '&0(&eMembers&e)&7'
          default: true
     
  6. Offline

    MCJoshua345

  7. Offline

    JaguarJo Retired Staff

    MCJoshua345 Could you paste your current permissions file? That error message in your log looks like you either have a spacing issue or a misplaced colon somewhere in the file.
     
  8. Offline

    farkros

    Like Lhammonds and JaguarJo have said, Yaml parser is your best friend, Any spacing error or letters misplaced mess it all up, like not being able to connect.

    Please post your permissions.
     
  9. Offline

    MCJoshua345


    I use Notepad++ to edit my server files.

    Here's my permissions file:
    http://pastebin.com/sNmYgrZj
    There you go! Thank you guys for your help! I'm very new to this stuff...

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 14, 2016
  10. Offline

    JaguarJo Retired Staff

    MCJoshua345 You need to move the schema-version line out of the groups section; it is breaking up your group formatting and that is why the Creator rank shows up as a spacing error. Try moving that line clear to the end of your file so that it isn't in either the groups or users sections.
     
    farkros and rbrick like this.
  11. Offline

    MCJoshua345

    Thanks! It works! I'm glad I had your teaching, because I'm thinking about making a server with different ranks!
     
  12. Offline

    farkros


    I use notepad++ as well, But it won't detect spacing errors, after editing it your permissions in notepad++, paste it into a yaml parser, fix the issues, then copy and paste it back into the file that's opened in notepadd++
     
  13. Offline

    MCJoshua345

    it's working. by the way, you know how on servers like Mineplex where you have the nametag? Like "HERO MCJoshua345"? how do you do that?
     
  14. Offline

    AGC-Intra


    The title before a playername in most cases is their 'Prefix'.
    Many plugin can adjust a prefix. Even your permissions file can hold a prefix for each rank/group.
    Multiple plugins trying to set a prefix could cause problems.
    If you have issues setting a prefix please post ALL the plugins you are using.

    For the prefix to actually appear above their head as a nametag you'll need a plugin such as NametagEdit.
     
  15. Offline

    MCJoshua345

    I have:
    Cook
    CoreProtect
    Essentials
    Lockette (Doesn't Work)
    HealthBar
    mcMMO
    PermissionsEX
    Stacker
     
  16. Offline

    MCJoshua345

  17. Offline

    MCJoshua345

    Can someone please help me? By the way, I added Buycraft
     
  18. Offline

    JaguarJo Retired Staff

    MCJoshua345 Could you post what your permissions file looks like now that you've edited it?
    The error mentions an invalid plugin.yml; did you edit any files other than permissions.yml? You might need to reinstall PEX...
     
  19. Offline

    MCJoshua345

    I found out that the file had got corrupted. PEX so I loaded PEX, and I got this log about a typing error. Probably when I added new ranks. Gonna see what a YAML Parser can do. Here is my log and current permissions file.
    Log: http://pastebin.com/T5PU3CcE
    Permissions.yml: http://pastebin.com/CDavixZc
    The YAML parser said something was wrong with Members, Member+, etc. Couldn't figure out the problem if my life depended on it because I know nothing about configuring YAML files... Thanks for all your guy's and girl's help.
     
  20. Offline

    JaguarJo Retired Staff

    MCJoshua345 Looks like you forgot to indent your Mod group name, the inheritance sections shouldn't have been indented that far since they aren't part of the options section, and you had a tab on line 399.
    Try this one: http://pastebin.com/gb1yN478 (Oh, and I changed your Creator group's inheritance to Mod, since there is no group GoodBoy for them to inherit from.)
     
    AGC-Intra likes this.
  21. Offline

    MCJoshua345

    Thanks! It worked! Although, my name is red... does that have something to do with prefixes?
     
  22. Offline

    JaguarJo Retired Staff

    MCJoshua345 Do you have OP on the server? If so, check near the beginning of your Essentials config for this part:
    Code:
    # A color code between 0-9 or a-f. Set to 'none' to disable.
    ops-name-color: '5'
    The number or letter you put there will decide what color to make your name in chat. It only affects users who have OP.
     
    AGC-Intra likes this.
  23. Offline

    MCJoshua345

    Yes, I am! Thanks so much for your help. Since no other players are op, I guess this partially fixes my prefixes problem! Although I still don't know why they don't show up...

    YES! =) I found out why the prefixes (and suffixes but I don't use those) weren't working! It's because there was a setting in the Essentials config that linked to plugins that edit Player Names (NTE,, PermissionsEX, etc.) that turned it off! Works fine (and awesome!) now! Thanks for all your help!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 14, 2016
  24. Offline

    AGC-Intra

    Would be best if you start our own thread with this problem listed.
     
  25. Offline

    deathrobe20000

    Will do thanks.
     
Thread Status:
Not open for further replies.

Share This Page