Permissions Ex Not Working

Discussion in 'Bukkit Help' started by 8Keep, Sep 9, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, I am trying to set up a 24/7 server with bukkit.
    I installed permissions ex and essentials and a few other plugins.

    The problem is that essentials is not recognizing permissions ex i think. But in the console it says:
    Essentials: Using PermissionsEx based permissions
    But like ten lines before that it says:
    Essentials: Using config based permissions. Enable superperms in config.
    I dont know what to do.

    I have a couple groups made in my permissions file, in the everyone group there are no permissions set, so i think that means they cant do anything, all the permissions are set to false.
    But if I make myself in the everyone group, then I can set the time with /time day. I do not want that. All i want the everyone group to be able to do is build and use /home and /sethome and some kits with /kit starterkit.

    I attached my permissions file. The essentials file is just a brand new installed one.
    The plugin modifyworld and chatmanager came with permissions ex too.

    Should i use a different permissions plugin? Can someone help me?

    I have tried permissionsbukkit now, and still whatever group you are in you can use essentials. How do i stop this?

    Attached Files:

    Last edited by a moderator: Jun 19, 2016
  2. Offline


    Please post your permissions file.
  3. Offline


    ok heres my whole plugins folder. I removed every other plugin and it still isnt working. With permissionsbukkit I am getting an error cannot load permissionsbukkit1.2.jar or something like that.

    I just found out that no plugins are working, every one gets a cannot load .jar error. I dont know what happened.

    Wait nevermind, I have gotten all the other plugins working. But every time I start the server, I get this error for permissionsbukkit:

    09.09 11:18:26 [Server] INFO    at
    09.09 11:18:26 [Server] INFO    at
    09.09 11:18:26 [Server] INFO    at net.minecraft.server.MinecraftServer.h(
    09.09 11:18:26 [Server] INFO    at net.minecraft.server.MinecraftServer.b(
    09.09 11:18:26 [Server] INFO    at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
    09.09 11:18:26 [Server] INFO    at org.bukkit.command.SimpleCommandMap.dispatch(
    09.09 11:18:26 [Server] INFO    at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(
    09.09 11:18:26 [Server] INFO    at org.bukkit.craftbukkit.CraftServer.reload(
    09.09 11:18:26 [Server] INFO    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    09.09 11:18:26 [Server] INFO    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    09.09 11:18:26 [Server] INFO    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    09.09 11:18:26 [Server] INFO    at
    09.09 11:18:26 [Server] INFO    at java.util.jar.JarFile.<init>(
    09.09 11:18:26 [Server] INFO    at java.util.jar.JarFile.<init>(
    09.09 11:18:26 [Server] INFO    at<init>(
    09.09 11:18:26 [Server] INFO    at<init>(
    09.09 11:18:26 [Server] INFO    at Method)
    09.09 11:18:26 [Server] INFO plugins/PermissionsBukkit-1.2.jar (Permission denied)
    09.09 11:18:26 [Server] SEVERE Could not load 'plugins/PermissionsBukkit-1.2.jar' in folder 'plugins':

    Attached Files:

    Last edited by a moderator: Jun 19, 2016
  4. Offline


    Open up plugins>>PermissionsBukkit>>config.yml and replace the section titled Owner with this:
                mobdisguise.* : true
                permissions.*: true
            inheritance: Admin
  5. Why not delete PermissionsBukkit.jar and PEX.jar and SuperPermsBridge.jar and Permissions.jar and GroupManager.jar and try bPermissions?

    Helpful videos, and guaranteed to work, or your money back ;)
  6. Offline


  7. Offline


  8. Offline


    major necro, bro
  9. Offline


  10. Offline


    Hi, I'am having the same problem. Please help me! :) I'm using PermissionsEx.
    This is my permissions.yml file :
    Please fix it for me :) ( Don't mind those Zaidejas and such, I'am from Lithuania :D)
  11. Offline


  12. Offline


    So i have a problem with Permissions Ex. When i try do /pex promote or any pex command, shows me the list of commands. my name is in the owner slot and i've tried /pex user name group set group but the same thing happens Help! my permission file is here
  13. Offline


    I am having the same issue as 8keep in the first post;

    When Essentials and PermissionsEX are installed together, permissions granted to the player default to those listed under player-commands in the Essenstials Config file and the Permissions.yml is completely ignored. I can alter groups and permissions willy-nilly with no effect.

    A version of my permissions where I remove the players ability to use the 'home' command can be found here;

    However, I can still use 'home.'

    If I remove the player-commands section of the Essentials config file (as directed when using an incompatible permissions system), regardless of the permissions granted by PermissionsEX, I cannot use any Essentials commands.

    Essentials lists PermissionsEX as a compatible system on the Wiki. Am I missing a line of code somewhere to enable PermissionsEX? Do I have to put in a reference? Not sure what is going on...
Thread Status:
Not open for further replies.

Share This Page