PermissionEX question.

Discussion in 'Bukkit Help' started by josip1, Dec 29, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    If they don't have a permission disabled my players can use there a way to disable all permissions for them? But allow them certain ones?

    So like

    - -disableAll
    - canDoThisPerm

    This way I don't have to type out EVERY permission they can't do.
  2. Offline


    it shouldnt work this way. if they dont have a node they shouldnt have it.
    double check the plugin in question to make sure its set to use permissions system in its config.

    - is the only other way that i know of besides not adding a node to begin with.

    op or '*' will have all nodes, is the only way to exclude from these.
    josip1 likes this.
  3. Offline


    It's like this for all plugins I am using! Even the default permissions for bukkit...if I don't apply the negative...they can use it.
  4. Offline


    somethings causing it to act like this then, it should be the opposit. backup your group yml, shut the server down, uninstall pex, then disable all other plugins (not delete them) do this by adding .old to the end of the name, example essentials.jar rename to essentials.jar.old, then reinstall pex from a fresh download and test it. i know its extra steps but thats how i tackle perms issues to eliminate all potantial issues 1st. then when u get it functions properly renable all your plugins.
  5. Offline


    Yep still going on =/ disabled all plugins etc...a default user can still do it. =/

    absolutely 0 permissions and still can do it.
  6. Offline


    post your perms file please.
  7. Offline


  8. Offline

    Nathan C

    That is not how Permissions works.

    Everyone has no permissions to use any commands, unless you add the nodes into the permissions config.
  9. Offline


    try the following (guest and admin only)
            default: true
                rank: '1000'
            prefix: '&f[&7Guest&f] '
            - showcase.finite
            - multihome.defaulthome.go
            - multihome.defaulthome.set
            - multihome.namedhome.go
            - multihome.namedhome.set
            - multihome.namedhome.delete
            - multihome.namedhome.list
            - multihome.namedhome.invitetimed
            - multihome.namedhome.list
            - multihome.homeondeath
            - lockette.user.create.*
            - doors.*
            - residence.create
            - dynshop.sell.sign
            - spawny.spawn
            - dynshop.price
            - expminer.use
                rank: '3'
            prefix: '&f[&4Admin&f] '
            - '*'
            - admin
  10. Offline


    Well it seems i've somehow changed how permissions works lol.

    @Leavaris...didn't work... :(

    Silly me, I forgot that the accounts were ops previously so that messed with it! Now it works! lol
    Big thanks to justin the cynical for making me realize that!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  11. Offline


    josip1 likes this.
  12. Offline


    Yeah noticed that after I posted the solve. Thanks as well :) I thought it was meaning like the op permission lol.
    Leavaris likes this.
Thread Status:
Not open for further replies.

Share This Page