Not quite a plugin, but all the same: BiomeTerrainMod!

Discussion in 'Bukkit Tools' started by R-T-B, Jan 19, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    My BiomeTerrainMod update is now Bukkit ready. It acts just like the old one, see the included readme for more info.

    This is an early preview build, but should work with Bukkit across builds unless they massively change how it is designed. I'd like feedback from the Bukkit community on how well it works.

    Thanks, see this site to obtain it (and help out! Email me if you want to become a contributor!):

    Also this thread for news and updates:
  2. Offline


    Genious, thank you for this great mod!
  3. Offline


    Not a problem, I assume it's working well? :)
  4. Offline


    Hmm, in the readme stands:
    I'm on linux [​IMG].

    So, what do you mean with adapting?
  5. Offline


    Yes!!!!!!!!! thanks, you rock!
  6. Offline



    I'm going to include a linux shell script in final bukkit release, as a lot is actaully broken I discovered at the moment (only basic settings are obeyed)

    All the same, you'd make a, mark/chmod it executable, and fill it with text like this:

    java -Xmx1024M -Xms1024M -cp BiomeBukkit.jar:craftbukkit.jar org.bukkit.craftbukkit.Main

    Note the colon instead of semicolon. ;)

    That should run it fine, just run it in console.
  7. Offline


    Thanks! Been waiting for this [​IMG] 4 you
  8. Offline


    Damn, would love to see this, but definitely impossible to make it works :/

    I'm on Windows 7 64-bit, and here is my start.cmd file :
    @echo off
    java -Xmx1024M -Xms1024M -cp BiomeBukkit.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
    But when I launch this file, a regular Bukkit server starts, generates a world which is sadly classic, no custom biome trees, no giants floating cliffs, and yet I imported some settings from here Share your BiomeTerrain Mod.

    Any idea ?
    GingernutRanger likes this.
  9. Offline


    Windows 7 32-bit, and I have the same problem as "ToitagL". I also used settings straight from that sharing thread.
  10. Offline


    Windows 7 64bit, same problem as them. Set min/max temp to 0, min/max moisture to 0, and snow and ice threshhold 10.5 to try and see a difference... I spawn in a world of lush green and trees for a spawn point. And I made the biome sizes small, and this biome is normal sized.
  11. Offline


    Same for me. I would occasionally stumble upon some interesting landscapes but nothing as dramatic as the screenshots that were in the thread.
  12. Offline


    well biomebukkit version 0.7 with windows 7x64 not working here. downloaded V0.6 and tried it without bukkit and that worked well, my craftbukkitis at version #107.
    by not working i mean that it just generates the normal world, not loading the ini file at all...
  13. Offline


    Same here. Doing everything the readme says (and you have said in the thread on and no .ini in the world folder, so I only get standard worlds... :(
  14. Offline


    Thanks for the bukkit port, makes the game much more interesting.

    However, same issue as the two above.
    Seems like editing 'BiomeTerrainModSettings.ini' don't have any effect at all.
    Running @ Hardy Heron 8.04.4 LTS with bukkit snapshot 0.0.1 (guess that's the only one avaiable)
  15. Offline


    I am going to play around with the other versions of this mod to see if Bukkit's causing all the sadness.
  16. Offline


    Awesome thanks for this. I've been playing with it and want to deploy on my server but unless I'm missing something it seems like its missing the new lapis ore. Any chance of an update for this?
  17. Offline


    Who is bucyruss, and what happened to him?
    Good mod by the way, thanks.
  18. Offline


    Did you actually get this working with bukkit?
  19. Offline


    A wrapper on top of a wrapper...interesting. Going to try this now. I wanted to try it before.
  20. Offline


    well i cannot get it to work, maybe someone found a way but im quite frustrated :/ thought bukkit loaded the minecraft_server.jar after it had loaded itself... but no. minecraft_server.jar can be modified to run biomes but as soon as i try it with bukkit it just dont work
  21. Offline


    Hello all,

    a new bukkit build is up that actually works. I know, crazy right?

    Sorry about the bad build, I tested it only briefly and truth be told, it worked but only obeyed say 10% of the settings, making it pretty useless. The new one loads all it's proper "plugins" making it work 100%. You should get msg's in the console similar to the following if it's working:

    Loaded: BiomeTerrain_BiomeMod
    Loaded: BiomeTerrain_UndergroundLakeMod
    Loaded: BiomeTerrain_TreeMod
    Loaded: BiomeTerrain_TerrainMod
    Loaded: BiomeTerrain_ReplaceBlockMod
    Loaded: BiomeTerrain_DepositMod
    Loaded: BiomeTerrain_CaveMod

  22. Offline


    Thanks for this, The newest 0.7 release works fine with my bukkit server :D
  23. Offline


    Good to hear I finally got something Bukkit related right. ;)
  24. Offline


    I wanter to try biome but:
    Exception in thread "main" java.lang.NoClassDefFoundError: org/bukkit/craftbukkit/Main
    Caused by: java.lang.ClassNotFoundException: org.bukkit.craftbukkit.Main
            at Method)
            at java.lang.ClassLoader.loadClass(
            at sun.misc.Launcher$AppClassLoader.loadClass(
            at java.lang.ClassLoader.loadClass(
            at java.lang.ClassLoader.loadClassInternal(
    . Program will exit.ain class: org.bukkit.craftbukkit.Main
    edit: debian 64b last craftbukkit ^^ (118)
  25. Offline


    Hey RTB, I'' test it out when I get a chance

    @GyD, make sure your bat file matches your craftbukkit.jar, I know the one RTB doesn't include the extra lines and words from SNAPSHOT etc, so
    Something like..
    @echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xmx1024M -Xms1024M -cp BiomeBukkit.jar;craftbukkit-0.0.1-SNAPSHOT.jar org.bukkit.craftbukkit.Main
  26. Offline


    @Novar234 : craftbukkit matches I think early beta of craftbukkit had this problem related to the 64b
  27. Offline


    It matches and still does that? We're looking at Debian right? Make sure you've installed the latest JRE from sun, that icedtea based on seems to cause issues left and right in my experience.

    Open Synaptic package manager if you have a gui, and look for "Java" Try to find 1.6 sun based version.

    Linux can be tricky... I use Solaris personally. Not really easier, just a matter of what one is used to.
  28. Offline


    yay, with solaris i grown up into unix business! but ages ago, on sun ultra sparc 5/20 machines :D
    thanks for porting biometerrainmod to bukkit!

    for debian and ubuntu w/o gui (vps/dedicated servers):
    apt-get update
    apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
    sudo apt-get update
    sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
  29. Offline


    perfectly work!!
  30. Offline


    With the altedit files that I added to Minecraft_server.jar, everything works well now ;)
Thread Status:
Not open for further replies.

Share This Page