Plugin Help None of my PEX permissions affect anything withing my server

Discussion in 'Plugin Help/Development/Requests' started by RageAx, Apr 9, 2017.

Thread Status:
Not open for further replies.
  1. Offline

    RageAx

  2. Offline

    timtower Moderator Moderator

  3. Offline

    RageAx

  4. Offline

    timtower Moderator Moderator

    @RageAx Change the config, it contains "permissions.jar", change that to "permissions.yml"
     
  5. Offline

    RageAx

    ok i just changed that, but that was set to .jar because pex didn't respond when it was set to .yml
     
  6. Offline

    timtower Moderator Moderator

    @RageAx Then you probably have a fault in your permissions.yml
    Please post your <server directory>/logs/latest.log using http://pastebin.com
     
  7. Offline

    RageAx

  8. Offline

    timtower Moderator Moderator

    @RageAx Pex is working fine according to that log.
    Was that log generated after you changed the config back to contain permissions.yml?
     
  9. Offline

    RageAx

    Just realised a mistake i made that log was the one before i reset the server, this is the one i get on startup[ and it prevents me from doing anything with /pex
    https://pastebin.com/zEyCWg5M
    Sorry about that :/
     
  10. Offline

    timtower Moderator Moderator

    @RageAx Line 120 of your permissions.yml, it is missing a dash.
     
  11. Offline

    RageAx

    I added the dash in, saved it and restarted the server but pex still doesn't do anything, from in game to the console, this is the log i got if that's any help
    https://pastebin.com/mFvmcYJt
     
  12. Offline

    timtower Moderator Moderator

    @RageAx Around line 124, vipplus, missing a space between the word and the dash
     
  13. Offline

    RageAx

    Ok, i've just gone through the permissions.yml and corrected what i see;
    pex still doesn't respond and this is my log https://pastebin.com/MrB4Xj2H
     
  14. Offline

    timtower Moderator Moderator

    @RageAx Line 166
    197 needs to be removed
     
  15. Offline

    RageAx

    Line 166 and 197 need to be removed?
     
  16. Offline

    timtower Moderator Moderator

    @RageAx No, 166 has an error, only remove 197
     
  17. Offline

    RageAx

    ok i removed line 197 and nothing has changed :/
     
  18. Offline

    timtower Moderator Moderator

    @RageAx Did you also fix line 166?
     
  19. Offline

    RageAx

    what's the error?
     
  20. Offline

    timtower Moderator Moderator

    @RageAx It is in a permissions block and missing a dash.
     
  21. Offline

    RageAx

    ok i got it but still nothing
    I've just gone over it and got all the errors i can see
     
  22. Offline

    timtower Moderator Moderator

  23. Offline

    RageAx

  24. Offline

    timtower Moderator Moderator

    @RageAx Around 170, spacing is not correct
     
  25. Offline

    RageAx

  26. Offline

    timtower Moderator Moderator

    @RageAx Remove line 198
    Line 173 to 176 are missing 2 spaces in front of them.
     
  27. Offline

    RageAx

    ok so i fixed the lines but no change within the server, the pex just doesnt appear when you do /pex
    if it's relevant - log https://pastebin.com/dBNePNdW
     
  28. Offline

    timtower Moderator Moderator

    @RageAx According to that log you didn't fix line 172 to 176
     
  29. Offline

    RageAx

  30. Offline

    timtower Moderator Moderator

    @RageAx Post your permissions.yml please.
    That still contains the same error.
     
Thread Status:
Not open for further replies.

Share This Page