(New User) Odd Error message when trying to start a server

Discussion in 'Bukkit Help' started by KaynTragus, Mar 10, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    KaynTragus

    First, the Important info:
    OS: Windows 7 64bit Ultimate
    Java build 1.6.0_24-b07
    Using Hamachi
    Command used:
    @ECHO OFF
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="64" "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xincgc -Xmx1G -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"
    IF /I "%PROCESSOR_ARCHITECTURE:~-2%"=="86" java -Xincgc -Xmx1G -jar "%~dp0craftbukkit-0.0.1-snapshot.jar"

    PAUSE

    Now, as to my problem:
    When I try to run my RUN.bat file, I am presented with a java window that displays the following:
    java.lang.ExceptionInInitializerError
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Unknown Source)
    at jline.ConsoleReader.class$(ConsoleReader.java:39)
    at jline.ConsoleReader.<clinit>(ConsoleReader.java:38)
    at net.minecraft.server.MinecraftServer.<init>(MinecraftServer.java:65)
    at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:396)
    at org.bukkit.craftbukkit.Main.main(Main.java:83)
    Caused by: java.util.MissingResourceException: Can't find bundle for base name j
    line.CandidateListCompletionHandler, locale en_GB
    at java.util.ResourceBundle.throwMissingResourceException(Unknown Source
    )
    at java.util.ResourceBundle.getBundleImpl(Unknown Source)
    at java.util.ResourceBundle.getBundle(Unknown Source)
    at jline.CandidateListCompletionHandler.<clinit>(CandidateListCompletion
    Handler.java:31)
    ... 7 more
    Caused by: java.lang.ClassCastException: jline.CandidateListCompletionHandler ca
    nnot be cast to ResourceBundle
    at java.util.ResourceBundle$Control.newBundle(Unknown Source)
    at java.util.ResourceBundle.loadBundle(Unknown Source)
    at java.util.ResourceBundle.findBundle(Unknown Source)
    at java.util.ResourceBundle.findBundle(Unknown Source)
    at java.util.ResourceBundle.findBundle(Unknown Source)
    ... 10 more
    Press any key to continue . . .

    And I am at a complete loss as to how to even begin fixing this... any help would be appreciated, thanks.

    If any more information is needed, I'll gladly provide it
     
  2. Offline

    woodzy

    u know i think u need to redo ur java
     
  3. Offline

    KaynTragus

    I have uninstalled and re-downloaded Java and am still recieving the same message, I am downloading java from http://www.java.com/en/download/inc/windows_new_xpi.jsp and am wondering if this is the wrong version to use, or if there's something I need to do after installing it to make bukkit work?
    [MERGETIME="1299858772"][/MERGETIME]
    Having managed to find an old version of Craftbukkit (specifically, build 256) It works perfectly, however of course a newer build would be preferable, any idea why this old version would work while the newer builds do not?
     
  4. Offline

    saturnine_nl

    if you have a 64bit machine and 64 bit OS be sure to download the 64bit version of java
    the server start script checks if you run 64bit , and wants to start the 64bit java client
     
  5. Offline

    KaynTragus

    I am running the 64bit version of Java, and also have tried running it with the 32 bit version in the past, just to be sure, both give me the same error message.
     
  6. Offline

    TnT Retired Staff

    Do you get that same message with no plugins at all? Have you tried build 527?
     
  7. Offline

    KaynTragus

    I have not yet tried to install any plugins, so I am running it with none, and I recieve the same error message when using build 527.
     
  8. Offline

    TheDaddyPeanut

    I also get it just reinstalled windows 7, i have 64-bit version of java. File is called: chromeinstall-6u24

    So just downlaoded it on the java website, any fixes for this?
     
  9. Offline

    TnT Retired Staff

    I've love to know if it happens without any plugins installed. (Just rename your plugins folder to something like plugins.bak and restart your server). If the error doesn't go away, I'd also suggest then (with no plugins) generating a new world to see if that works.

    Can you post your full server.log file as well please (at least the latest start to stop from your server)?
     
  10. Offline

    KaynTragus

    My server never actually starts, therefore I have no plugins folder, world folder, nor anything but the "craftbukkit-0.0.1-SNAPSHOT.jar" file and the "RUN.bat" file, it never gets to the point of generating any other files but crashes instantly, unless I use an old version.
     
  11. Offline

    TnT Retired Staff

    Put only two files in an empty directory - the run.bat and the craftbukkit-0.0.1-SNAPSHOT.jar.

    Change the run.bat to say simply this:
    Code:
    @echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xms1G -Xmx1G -jar craftbukkit-0.0.1-SNAPSHOT.jar nogui
    pause
    
    Can you start the server?
     
  12. Offline

    KaynTragus

    Using that RUN.bat I recieve the error:

    'C:\Program' is not recognized as an internal or external command,
    operable program or batch file.
    Press any key to continue . . .
    [MERGETIME="1299864321"][/MERGETIME]
    I edited the bat file to read:
    @echo off
    "%ProgramFiles(x86)%\Java\jre6\bin\java.exe" -Xms1024M -Xmx1024M -jar craftbukkit-0.0.1-SNAPSHOT.jar
    pause

    And now it seems to work fine, thankyou very much for the help everyone's provided, I'd never have managed it on my own
     
  13. Offline

    TnT Retired Staff

    I forgot quotes the first time I posted it - fixed it within a minute or two, but you must have grabbed the non-quoted version. Try again with the code I have above.
    [MERGETIME="1299864430"][/MERGETIME]
    If you've got it working this far - try taking your old world and replacing the new one it would have just generated - if it works, then try to add in plugins.
     
Thread Status:
Not open for further replies.

Share This Page