Plugin Help Need help with PEX

Discussion in 'Plugin Help/Development/Requests' started by Inertia77, Jun 20, 2018.

  1. Offline

    Inertia77

    These are the Plugins on my server: GriefPrevention, PEX, WorldEdit, WorldGuard, NoCheatPlus, , SetSpawn, OpenInv, EssentialX, and lastly Clearlag.

    when I do /plugins, Pex comes up in red. I have copied this premade pex permissions file and wanted to use it as my own

    Code:
    groups:
      Member:
        options:
          default: true
          prefix: '&a[Member]&f '
        permissions:
        - modifyworld.*
        - essentials.msg
        - essentials.sethome
      Moderator:
        options:
          prefix: '&3[Moderator]&f '
        permissions:
        - essentials.mute
        - essentials.kick
        - essentials.fly
        - essentials.tp
        inheritance:
        - Member
      Admin:
        options:
          prefix: '&c[Admin]&f '
        permissions:
        - essentials.ban.*
        inheritance:
        - Moderator
      Owner: Flyer_
        options:
          prefix: '&4[Owner]&f '
        permissions:
        - '*'
    schema-version: 1p/code]
    
    So i have it set up so i have that in the yml and im able to still use pex while in game, but when i try to put my name in the owner slot it goes back to having an internal error (or when i try to use pex in game to set myself to the group owner, I get a new tab called "users". Not sure if that's correct or not.
    
    lemme know whats wrong/if i need more info to share!
    
    So everything seems to be working in the permissions file, as thats posted and pex is wokring, yet in the game i dont have the prefix of owner
    also when trying to add .essentials.home to the member group it gives me an internal error :(
     
    Last edited: Jun 20, 2018
  2. Offline

    xbpuk

    Hi there, @Inertia77

    I'm not sure what you meant by your request so I'll try to assist either way.

    - 1. Your configuration file doesn't follow YML standards. I've gone ahead and fixed it for you. (Below)

    Code:
    groups:
      Member:
        options:
          default: true
          prefix: '&a[Member]&f '
        permissions:
        - modifyworld.*
        - essentials.msg
        - essentials.sethome
      Moderator:
        options:
          prefix: '&3[Moderator]&f '
        permissions:
        - essentials.mute
        - essentials.kick
        - essentials.fly
        - essentials.tp
        inheritance:
        - Member
      Admin:
        options:
          prefix: '&c[Admin]&f '
        permissions:
        - essentials.ban.*
        inheritance:
        - Moderator
      Owner:
        options:
          prefix: '&4[Owner]&f '
        permissions:
        - '*'
    schema-version: 1
    
    - 2. You must use the command "/pex user [username] group set [group name]" before you will see a prefix in-in-game chat.

    - 3. Too before you see a prefix in-the-in-game chat. You must install EssentialsChat. Which can be found here: https://www.spigotmc.org/resources/essentialsx.9089/

    Best of luck,

    - ES Team.
     

Share This Page