[MISC] IceDrop v1.9 - Break ice blocks and get a drop! [953]

Discussion in 'Inactive/Unsupported Plugins' started by robin0van0der0v, Feb 21, 2011.

  1. Offline


    IceDrop - Break ice blocks and get a drop!
    Version: v1.8

    • Get a drop if you break ice.
    • Get (no) water if you break ice.
    Download IceDrop!
    Source is inside the jar file.

    Give the player you want this permissions for placing ice:
    Give the player you want this permissions for destroying ice:
    Give the player you want this permissions for getting a drop if he break ice:
    Known bugs:
    None. :D

    This plugin creates a properties file on Plugins/IceDrop/config.yml. ;)

    Standard properties:
            normal: false
            skylands: false
            nether: false
            normal: true
            skylands: true
            nether: true
            normal: true
            skylands: true
            nether: true
    Version 1.0
    • Release.
    Version 1.1
    • Added Permissions.
    Version 1.2
    • Removed old constructor.
    Version 1.3
    • No Permissions? Then everyone can get ice.
    Version 1.4
    • Changed namespace.
    • Cleaned up code.
    Version 1.5
    • Fixed infinity ice.
    Version 1.6
    • Added properties file.
    Version 1.7
    • Fixed block breaking.
    Version 1.8
    • Properties file is now saved in YAML format.
    Version 1.9
    • You can now setup drops by their environment.
    • Fixed water.
    Cheeqow and NoFear13 like this.
  2. Offline


    Be pretty cool if it had permissions support! And sweet avatar!
  3. Offline


    Added permissions! :)
  4. Please remove your old constructor:

    Now your Plugin works anymore:
    2011-02-25 23:37:43 [SEVERE] Could not load plugins\IceDrop.jar in plugins: null
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:80)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:129)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:94)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoSuchMethodException: com.bukkit.robin0van0der0v.IceDrop.IceDrop.<init>()
    at java.lang.Class.getConstructor0(Unknown Source)
    at java.lang.Class.getConstructor(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:75)
    ... 8 more

    Thank you
  5. Offline


    Fixed. :)
  6. Offline


  7. Offline


  8. Still working OK (for me anyway) on bukkit build #552 - Nice plugin - simple, and does the job ! At least provides for in-game use of ice, rather than hacking it in.

    .......... many thanks ........
  9. A quick question - Do you do a version that doesn't require permissions please ? ..... Currently your plug-in is the only one that required me to load a Permissions plug-in before it would work, and unlike many, I would rather the plug-in either have its own built-in permissions, or be able to use it without permissions - is that possible please ?
  10. Offline


    I'm also thinking about this, but would like permissions to be optional.
  11. Offline


    Fixed, if you now don't have permissions then everyone can get ice! :)
  12. Offline


    Excellent! Gonna try this now. :)

    Nice, interesting side affect, placing an ice black and breaking it, produces water!! :)
  13. Only just seen your reply - thanks for updating - works great - and the fact that breaking ice produces water - not a problem - you still get an ice block as well - makes you have to be more careful about where you place ice in the first place :D!

    .... great update - many thanks ........ !!
  14. Offline


    It only produces water if it touch a other block. ;)
  15. Well, it doesn't matter to me really about the water production ........ still an excellent plugin ..... by the way - ever thought of doing a 'Glass-Drop' ??? ....... this would complete the no-drop blocks, since you have already covered Bedrock (which I also use - with great care I may add ..........). :eek:
    It could become your 14th plugin !!
  16. Offline


    Im getting this error.... can someone help me?
    It mentions permissions in here, but I dont have that mod....

  17. Offline


    http://forums.bukkit.org/threads/9797/ :D

    Fixed i think. :p
    Can you test it? :)
  18. Offline


    When i attempt to place an ice block on my server, it simply disappears, and never places.
  19. Offline


    Yes, it's the same thing for me. here's what I notice about it.... I'm not sure if it's a function that was intended or not, but when you break the ice water spawns in the same spot as if the plugin wasn't there. There IS a drop, but no matter how many you pick up... only one of them shows in your inventory. The others just disappear. Lastly, placing the block triggers the motion, *waves hands* but does not place anything.
  20. Offline


    That is the exact experience we are having on the server, think it could be with the 1.3 update? or maybe something else? (I am not sure when this was released in relation to the 1.3 update)
  21. Offline


    I think the area is protected. ;)
    Here it works good on 556. :p
  22. Offline


    Same as by GlassDrop.

    It isn't working with ice blocks!
    Sometimes I get a drop, but I can't place the block (he get's away, but isn't placed...)
    Sometimes I don't even get a drop when I destroy a block!

    Hope you can fix this...

    [I'm an admin on my server!]
  23. Offline


    Well, I am the operator/admin on my server, and the only protected area is the spawn and I get the same problem in areas several chunks away from the spawn.
  24. Offline


    Fixed, it was a problem with the dropped block (it was an infinity block).
  25. Offline


    Great, it's working now!
    Thanks for your quick fix!!!

  26. Offline


    Good job, it works great now, plus a quick response time, you have earned much respect today.
  27. Just tried on bukkit #602 - got a drop & could place a drop - still seems to be working fine !
  28. Offline


    I have a abusing thing with that plugin: when a player in nether breaks an iceblock, it will generate water AND drop a new iceblock. that's little bit "infinite water for free", especially in lavanether, not so "survival" ;)
    can you please fix this?
    i know, i can set the permissions for nether world different and remove permission "icedrop", but probably you can make this default in plugin?
  29. Offline


    Fixed. :)
    Kartus likes this.
  30. Offline



    Great plugin!

    But with your standard config it's not possible to place ANY block in the nether.
    I've set the nether things to true and it's working again.

    Hope you can fix this!


Share This Page