Minecraft server connecting problem

Discussion in 'Bukkit Help' started by engise, Jan 18, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    engise

    Hello, this is my first post at this forum. Sadly I didn't want it to start with a problem but alas I can't control it ... never mind. Here is my problem.

    I want to make a server so I installed bukkit and opened the Minecraft server ports (because I'm on a router) and everything is great except that I cant connect to my own server :/

    I'm not sure if anyone can connect to it. I cant test it right now, because my friend is a asleep and I cant tell him to try to connect, so I tried to join my server, but when I tried it gave me a whole bunch of errors like "Connection Lost; Failed to login: User not premium", "Connection Lost; Internal client error: java.net.ConnectException: Connection timed out: connect" and etc. So I get all of these errors and I just cant connect. I'm using the IP of the server (for me it's 192.168.88.2)

    So when it didnt want to connect me like 10000 times I went to the console to see if I get an output of my login attempts and yay ...

    Code:
    2011-01-19 02:51:10 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-19 02:51:10 [INFO] Loading properties
    2011-01-19 02:51:10 [INFO] Starting Minecraft server on 192.168.88.2:25565
    2011-01-19 02:51:10 [INFO] Preparing level "world"
    2011-01-19 02:51:10 [INFO] Preparing start region
    Preparing spawn area: 16%
    Preparing spawn area: 44%
    Preparing spawn area: 65%
    Preparing spawn area: 81%
    Preparing spawn area: 89%
    Preparing spawn area: 97%
    2011-01-19 02:51:16 [INFO] Done! For help, type "help" or "?"
    2011-01-19 02:51:53 [INFO] /192.168.88.2:50329 lost connection
    2011-01-19 02:54:06 [INFO] /192.168.88.2:50907 lost connection
    2011-01-19 02:54:49 [INFO] /192.168.88.2:50993 lost connection
    2011-01-19 02:57:43 [INFO] /192.168.88.2:51640 lost connection
    2011-01-19 03:05:29 [INFO] /192.168.88.2:53368 lost connection
    2011-01-19 03:06:16 [INFO] /192.168.88.2:53491 lost connection
    So, what's the problem ?
     
  2. Offline

    TnT Retired Staff

    Minecraft authorization servers are having problems.
     
  3. Offline

    engise

    So it's not from me ? And if not when the problems are fixed I can get on my server without any problem ?
     
  4. Offline

    TnT Retired Staff

    Not just you. Yes, probably.
     
  5. Offline

    Lycake

    You can try setting the server into offline mode in the .properties until minecraft.net servers are fixed. You should be able to join the server even if mc.net is down.

    Cake
     
  6. Offline

    engise

    Nope, even offline mode doesn't work :/

    Code:
    2011-01-19 03:17:08 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-19 03:17:08 [INFO] Loading properties
    2011-01-19 03:17:08 [INFO] Starting Minecraft server on 192.168.88.2:25565
    2011-01-19 03:17:08 [INFO] Preparing level "world"
    2011-01-19 03:17:08 [INFO] Preparing start region
    Preparing spawn area: 16%
    Preparing spawn area: 48%
    Preparing spawn area: 65%
    Preparing spawn area: 81%
    Preparing spawn area: 93%
    2011-01-19 03:17:14 [INFO] Done! For help, type "help" or "?"
    2011-01-19 03:17:31 [INFO] /192.168.88.2:55905 lost connection
     
  7. Offline

    Lycake

    Your server is not in offline mode. You would get a huge warning I think. Be sure to have
    Code:
    online-mode=false
    in your
    Code:
    server.properties
     
  8. Offline

    engise

    These are and were my settings when I posted the code from the console window :


    Code:
    #Minecraft server properties
    #Sun Jan 16 19:34:41 EST 2011
    #http://www.minecraftwiki.net/wiki/Server.properties
    level-name=world
    hellworld=false
    spawn-monsters=true
    online-mode=false
    spawn-animals=true
    max-players=8
    server-ip=192.168.88.2
    pvp=true
    verify-names=true
    online-mode=true
    server-port=25565
    motd=Bukkit build 50.
    
     
  9. Offline

    Lycake

    You have 2 times online-mode:
    Code:
    online-mode=false <----- THERE
    spawn-animals=true
    max-players=8
    server-ip=192.168.88.2
    pvp=true
    verify-names=true
    online-mode=true <----- AND THERE
    delete the second one.

    Cake
     
  10. Offline

    engise

    Oh my god it actually worked !!!

    You know I love you forever right ? Umm so if the minecraft.net site stops glitching out then my server will work online ?
     
  11. Offline

    Lycake

    Like TnT said:

    Cake
     
  12. Offline

    engise

    A very stupid question ... um how can I update my bukkit build ? Or where can I download the newest build ?
     
  13. Offline

    TnT Retired Staff

    How stupid do you think you're going to feel when you realize it's in an FAQ right above this post? (It always downloads the latest version of Bukkit).
     
    icedmoca likes this.
  14. Offline

    engise

    Alot sir, thank you. I actually had an older build of bukkit and I'm not use to searching for stuff ... well at least in the forums. :]
     
  15. Offline

    itune

    I AM HAVING THE SAME PROBLEM!!!!!
    I have the craftbukkit server and when I start it up then I can log in but I noticed people aren't logging in and when I looked at the thing that starts up the server it's saying the IP (someone trying to log in) lost connection
    example: 18:08:36 [INFO] /94.231.109.47:52587 lost connection
    PLEASE HELP!
     
  16. Offline

    Urahara72

    I am having the same issue as iTunes, though it worked fine just a few days ago. Help?
     
  17. Offline

    eclair-chan

    I have almost the same problem. I have created my server but it always says this:

    [INFO] Preparing start region for level 0
    [INFO] Preparing spawn area: 16%
    [INFO] Preparing spawn area: 36%
    [INFO] Preparing spawn area: 65%
    [INFO] Done (4775316191ns)! For help, type "help" or "?"
    [INFO] Disconnecting /5.219.194.198:2617: Took too long to log in
    [INFO] Disconnecting /5.219.194.198:2803: Took too long to log in

    I just don't know what's the problem.
    Thanks.
     
  18. Offline

    BlackenedAndi

    Mine doesn't even work. When I double clock on the RUN.bat file the cmd screen pops up and it displays this:

    C:\Users\(my user)\(folder location)\Bukkit Server>java -Xms1G -jar craftbukkit-1.1R1.jar
    Unable to access jarfile craftbukkit-1.1-R1.jar
    The system cannot find the path specified.
    Press any key to continue . . .
     
  19. Offline

    chrisparisi3

    java -Xmx1024M -Xms1024M -jar craftbukkit-1.1-R1.jar nogui.
    you also may want to make sure you have the craftbukkit 1.1 in your server folder
     
  20. Offline

    Sayshal

    May i recommend the beginners bukkit package. It installs this all for you and comes with a beginner-friendly interface, as well as an automatic plugin/bukkit updater (for like 90% + of your plugins)
     
  21. Offline

    FVJTeam

    HELLP My friend cant join my server but i can ANyone?
     
  22. Offline

    Tigr3tap

    Did you portforward your router?
    here you go
     
  23. Offline

    EzioMotU

    hi, i'm new to this site and i'm having the same problem loging in the server. i made my own server for my mates and i and go on. But when i log in, this sign 'user not premium' shows up. i tryed changing the online mode to false then when i come up, it still shows up. plz help me. i'm using free version not paid minecraft.
     
  24. Offline

    Satchu

    Hi i´m having the same problem that EzioMotu every time i try to loggin in my own server it says "user not premium" so i go on my server folder i open the server properties and i change the online-mode=true to online-mode=false and i save it then i run the server and when i try to enter on my server it still saying the same thing so i go check the server properties and the online-mode=false its again online-mode=true Why it change automaticly??? :s and sorry for my bad english
     
  25. Offline

    Caerigna

    Have Premium
    Portfowarded (25565 setup)
    Tried setting online to false

    when i try to use localhost cmd prompt says 127.0.0.1:50348 lost connection. (127.0.0.1 is NOT my IP address)
    when i try to use the IP address:25565 i get the java.net.ConnectException: Connection refused: no further information.

    just wanted to setup a server for friend and i to play together and have some pluggins, please help.
     
  26. Offline

    dylanhansch

    127.0.0.1 is the IP address for "localhost". Don't worry there.

    I am actually having the same issue, except mine is running in multicraft. I have minecraft servers running outside of multicraft, but the ones inside multicraft say they are online via the web admin panel, except when I try to join with my minecraft client it says the server is offline, and in the multicraft console, it says 192.168.1.100 lost connection. (192.168.1.100 is my LAN IP address).

    I would really appreciate if someone knows how to fix this issue!
     
Thread Status:
Not open for further replies.

Share This Page