Solved MidiSystem throws an IllegalAccessError

Discussion in 'Plugin Development' started by MisterErwin, May 4, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Hello together,

    if I try to use MidiSystem.getSequencer();, I receive an IllegalAccessError

    Is there a problem with my java, because I receive this error also if I'm trieing to make a "normal" java appliation.

    Thank you,



    Fixed it by myself:

    After I've uninstalled the java media framework, it works ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 1, 2016
  2. Offline


    Thankss a lot man. That was really helpful. You have nay idea on why this error occurs? I am guessing its something to do with the presence of similar(if not exactly same) sound classes in jmf.
  3. Offline


    Thanks.... But I found it also only b/c I tried to clean up my pc ;)
Thread Status:
Not open for further replies.

Share This Page