[MECH] RedstoneChips 0.97 - Integrated circuits plugin [1.5.1-R0.2]

Discussion in 'Archived: Plugin Releases' started by eisental, Jan 19, 2011.

  1. Offline


    RedstoneChips 0.97 / BasicCircuits 0.97 / SensorLibrary 0.34
    (Last update on April 30th, 2013, cb 1.5.1-R0.2)


    • Build chips with any number of input and output pins, from compact 2 block chips up to whatever you can imagine.
    • Choose from over 50 different chip types and several 3rd party chip libraries.
    • Most chip types can work with a wide or infinte range of i/o configurations. Sign arguments allow you to customize chip behavior.
    • Chips can communicate through redstone, or directly by touching each other. Some chip types can also communicate over wireless channels.
    • Chips can be built in almost any imaginable structure allowing very compact circuits.
    • Debug and maintain large projects using various tools and commands.

    [cake] Help me spend more time working on RedstoneChips. Please donate

    Circuit libraries made by other people:
    Changelog (open)

    RedstoneChips 0.97 (Apr 30th, 2013)
    • Fixed the saving bug on cb 1.5.1.
    • Added an option to disable update checking.
    BasicCircuits 0.96 (Apr 30th, 2013)
    • pixel: Added a maximum distance value preference to prevent lags and server crashes. The max can be changed using/rcprefs pixel.maxDistance x and defaults to 7.
    • sram: Fixed a problem with anonymous memory.
    SensorLibrary 0.34 (Dec 1st, 2012)
    • daytime: Fixed daytime offset bug.

    Full changelogs and source code @ github.com:
    RedstoneChips [gunpowder] BasicCircuits [gunpowder] SensorLibrary
    DoomLord, Shamebot, Vecht and 6 others like this.
  2. Offline


    Did you use different Chip materials?
    To do a 2x2 screen, the back of the chips need to be:

    Where A is one material, and B is the other.

    If you do not alternate materials like this, the first pixel will work fine, but all the others will be messed up.
  3. Offline


    So I'm new to this had a go at it, checked out the website and had a read. However, I dont know where I'm going wrong when trying to make a pixel. I write on the sign.


    But when i try to activate it nothing happens. :S What stupid mistake am I making?

    EDIT: Doesn't matter, I stupidly forgot about the interface block -.-
  4. Offline


    Can you add permissions to the pixel sign? I have people exploiting it to change wool to whatever color they please. It is too bad, because I love the functionality. Sadly, I run a server with a working economy, and colored wool is worth a fair amount based on the dye it uses. Thanks
  5. Offline


    It doesn't work for me in #818, for example if I make a simple clock chip, the output lever flips around, but doesn't affect the redstone I have linked to it.
  6. Offline


    Is your plugin really just compatible with CB798?

    Oh, and running it next to Minecart Mania on CB818 leady to a shitload of exception because you seem to mess up some signs. I do not know how but if you want details just contact me ;) Minecart Mania fails to cast some sign blocks correctly when your plugin is active.
  7. Offline


    @mze9412 As far as I can see #818 works.

    @ratty What do you mean by the redstone not being affected?

    Does anyone else see this problem?

    @Munkyman587 I'll add a permissions system eventually.
    Munkyman587 likes this.
  8. Offline


    Hang on, in the test I setup I see something I was doing wrong. Before I post again I'll make absolutely sure something is actually not working, and include steps on how to reproduce it.
  9. Offline



    So now in more Detail ;)

    CB818, MinecartMania Suite 1.2.7
    With the Redstone Chips Plugin enabled (http://forums.bukkit.org/threads/mech-redstonechips-0-9-integrated-circuits-plugin-798.1205/) I get the following errors when signs are too close to a redstone chip. TI removed the RedstoneChips plugin and MinecartMania behaves as it should, everything works.

    Maybe you change some things about signs which kills minecart mania? I have a track right next to an active redstone chip. If you want you can take a look on my server ;)

  10. Offline


    @mze9412 Well RC may update text on chip signs when it's starting up. The fact that it makes MinecartMania throw an exception doesn't seem to be its fault. It looks like a weird CraftBukkit bug. You should also post this on the MinecartMania thread. Do you get this whenever a vehicle is moving?
  11. Offline


  12. Offline


    I think the SRAM chip is limited to 32 bits, so you are exceeding it's max value by using 40 inputs.
  13. Offline


    If that's the problem then wait for BC0.91 which lets you have srams with unlimited word lengths. It's basically finished but I still need to update the documentation :/
  14. Offline


    It is in fact limited to the size of an INT, 2147483647 that is...
    I fixed it by using 20 outputs per sram, so I have 2 sram's per screenline, 10 screenlines making it a whopping 20 sram's :D
  15. Offline


    Ok I have a problem now. :(
    I was trying out some stuff with the mod, having fun, making a small 8 by 8 display, but I used a map editor to copy the chips which tell the pixels with colour (was basically a counter and transmitter) but ever since then it doesn't acknowledged when I destroy a bit of a chip. it just pretends it's there.

    I can even destroy a output block from something like a receiver and it will still send an output if a signal is broadcast on that channel. D: it fix it I have to use "/rcbreak" to manually break the chip.

    any idea's how I could stop this?
    Thanks :)

    EDIT: Also any chance you want to make stuff like the pixel default range, able to be changed, in the config. Would be a lot quicker for single block pixels, since they have a lot more pixels in obviously. :) Thanks and REALLY great pluggin thanks :) enjoying it a lot.
  16. Offline


    @lain_VM I don't quite understand... Does this happen with all your chips now? or just those that you have copied? If you mess around with blocks outside of the game the plugin should realize the chips are broken next time it's disabled (or on server shutdown) and remove the invalid chips. I could add the default pixel range to the preferences but I think the upcoming display chip would solve these problems. Anyways, glad you enjoy it :)

    @Mortana It's limited to a 32bit signed integer. An INT can be of many sizes but a normal Java integer is always 32bits. In any case, as I said before, BC0.91 would solve this problem as well.
  17. Offline


    None of my chips on the server recognise when they are broken, even if I delete the pluggin, re add it, make a chip and try and break the chip. You're more then welcome to come on my server and see if that will be easier to understand. The console is kicking out any exceptions so...
  18. Offline


    Did you delete the plugins/RedstoneChips folder or just the jar file? Are you using any "special" tools such as the superpickaxe to break chips?
  19. Offline


    @Eisental, I know, anyhow, I made a workaround using smaller srams for now, till the new version is released.
    I do however have some strange "bug", could be due to lag, but it's strange.

    What I did, was as I said, made a display of 10x10, 100 pixelchips
    Each row uses 2 sram chips, one for the first 5 pixels of that row, and one for the last 5 pixels of that row.
    Each sram, outputs its memory, based at the input of a receiver, wich gets it's input from a counter (wich at this time only counts from 0 to 1, to keep it easy).
    Then, each output from sram, is send to a transmitter, wich get's it's clocksignal using another receiver, wich get's his signal, from another transmitter, wich gets his input from a regular clock chip.
    Frame 0 should be all white, so I won't show a picture of that
    Frame 1 should be this:
    (I know, I stored the pixellines upside down :p)

    Anyhow, this appears to be frame 0:

    And this appears to be frame 1:

    When I turn the clockgenerator off, and I manually give an input to all my transmitters, I get the frame as it should be...
  20. Offline


    Ahhhh, that seems to register now that I break it without creative mode on, (includes 1 hit break). Thanks :')

    Can I ask about these new display chips, and how they will work, will it mean that I have to replace ALL my pixel chips? D: Cause I have a 32x48 screen under construction, 1 block = 1 pixel. :p
  21. Offline


    It's possible you are seeing an issue with the counter resetting. In some cases the reset is not complete before the outputs get sampled again (actually, it's a bit more complicated than that), and you end up with frames that may be missing, partial, or mixed together.

    I have a couple of posts about this earlier in the thread.

  22. Offline


    i dont have sram problems like that, and i have 100 bit srams (thanks to early release) what i do have lately is that some chips (small or big, no difference) forget an output, so when i do debug info, its missing some outputs, or i cannot activate, etc etc, corrupt areas, but the good news is, they come and go (but you need to reactivate when bad region is gone) no console errors :(
    BTW: thanks for the playerid chip. however, i run into some miner problem that my srams dont update when the same player moves over it. (playerid chip/transmitter, clock on player output/sram adres input. read/write connected on the clock of the receiver, so basicly, when a player is on the idscanner of the first station, it will send the player id to the sram, and store the entered destination. when the same player now take the minecarts system again, it doesnt store the new data.
    its the readonly chip that is the problem
  23. Offline


    Does this work on 818
  24. Offline


    @omgmac I haven't tested it enough but it seems to work fine on 818.

    @Iain_VM You would need to rebuild the screen if you want to use the new chip but it will take you much less time and require only 1 sign. You could stick to the pixels of course if you want.
  25. Offline


    Is anyone having problems using sram in read/write mode in 818. I've been trying to store data from a terminal but I noticed that whenever I switch to read mode all the inputs go low and stay there. I tried both inputs just incase I was accidentally using the disable pin but neither work.
  26. Offline


    use debug and make sure you send the store command, i had problems using clock output from receivers etc because they seem to pulse to short or its the best i can think off
  27. Offline


    Just one quick question, I try to use the iptransmitter circuit to send a signal to a friends server, I was trying to set up my end and kept getting strange errors. Something about something happening internally, any help would be greatly appreciated.
  28. Offline


    You should have an error log in the server console when that happens. Paste it and I'll be able to help.
  29. Offline


    15:27:10 [SEVERE] Could not pass event PLAYER_INTERACT to RedstoneChips
    java.lang.ClassCastException: java.lang.Integer cannot be cast to java.lang.String
    at org.tal.basiccircuits.iptransmitter.init(iptransmitter.java:48)
    at org.tal.redstonechips.circuit.Circuit.initCircuit(Circuit.java:131)
    at org.tal.redstonechips.CircuitManager.activateCircuit(CircuitManager.java:187)
    at org.tal.redstonechips.CircuitManager.checkForCircuit(CircuitManager.java:183)
    at org.tal.redstonechips.RedstoneChips$4.onPlayerInteract(RedstoneChips.java:203)
    at org.bukkit.plugin.java.JavaPluginLoader$10.execute(JavaPluginLoader.java:306)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:166)
    at net.minecraft.server.ItemInWorldManager.dig(ItemInWorldManager.java:63)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:453)
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    This is what I got
  30. Offline


    this is my minecart router, it can bring any player from any station to any station using the command /rctype "number" to select the station. "number = station number"

    the display will first show you the ride number (how much is the system used)
    then it will show you what station it will send you to
  31. Offline


    btw, just one more strange but somewhat insignificant issue, I have made a clock on my server, and all of a sudden 112 circuits shut themselves off, not I big problem really just strange

Share This Page