[MECH] RedstoneChips 0.97 - Integrated circuits plugin [1.5.1-R0.2]

Discussion in 'Archived: Plugin Releases' started by eisental, Jan 19, 2011.

  1. Offline


    RedstoneChips 0.97 / BasicCircuits 0.97 / SensorLibrary 0.34
    (Last update on April 30th, 2013, cb 1.5.1-R0.2)


    • Build chips with any number of input and output pins, from compact 2 block chips up to whatever you can imagine.
    • Choose from over 50 different chip types and several 3rd party chip libraries.
    • Most chip types can work with a wide or infinte range of i/o configurations. Sign arguments allow you to customize chip behavior.
    • Chips can communicate through redstone, or directly by touching each other. Some chip types can also communicate over wireless channels.
    • Chips can be built in almost any imaginable structure allowing very compact circuits.
    • Debug and maintain large projects using various tools and commands.

    [cake] Help me spend more time working on RedstoneChips. Please donate

    Circuit libraries made by other people:
    Changelog (open)

    RedstoneChips 0.97 (Apr 30th, 2013)
    • Fixed the saving bug on cb 1.5.1.
    • Added an option to disable update checking.
    BasicCircuits 0.96 (Apr 30th, 2013)
    • pixel: Added a maximum distance value preference to prevent lags and server crashes. The max can be changed using/rcprefs pixel.maxDistance x and defaults to 7.
    • sram: Fixed a problem with anonymous memory.
    SensorLibrary 0.34 (Dec 1st, 2012)
    • daytime: Fixed daytime offset bug.

    Full changelogs and source code @ github.com:
    RedstoneChips [gunpowder] BasicCircuits [gunpowder] SensorLibrary
    DoomLord, Shamebot, Vecht and 6 others like this.
  2. Offline


    It's not really more signs. It's the same amount of signs with less chips...
    But what's the problem to copy signs? They copy the same as other block, don't they?
  3. Offline


    I think it's the editing them after the fact that is the difficult part.
  4. Offline


    can u plz help? :'( it no work
    can u help me plz? :'( it no work
    20:29:47 [SEVERE] Could not pass event REDSTONE_CHANGE to RedstoneChips
    at java.util.AbstractList$Itr.checkForComodification(Unknown Source)
    at java.util.AbstractList$Itr.next(Unknown Source)
    at org.tal.redstonechips.CircuitManager.redstoneChange(CircuitManager.ja
    at org.tal.redstonechips.RedstoneChips$2.onBlockRedstoneChange(RedstoneC
    at org.bukkit.plugin.java.JavaPluginLoader$32.execute(JavaPluginLoader.j
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    at net.minecraft.server.BlockButton.interact(BlockButton.java:141)
    at net.minecraft.server.BlockButton.b(BlockButton.java:122)
    at net.minecraft.server.ItemInWorldManager.dig(ItemInWorldManager.java:7
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:438)
    at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    at net.minecraft.server.NetworkManager.a(NetworkManager.java:196)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:372)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:287)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:394)

    well it did work for a while with the speedcircuits but now it eventually stopped working.
    im going to try again and it might be because i dont have the sensor libraries which i shall get right now.
    plz help.
  5. Offline


    @ploopo Does it happen when deactivating a circuit with speedcircuits?
  6. Offline


    @ploopo Please explain which chips are you using when this happens.
    @Shamebot It seems to happen when a button is triggering a redstone change event. Not when a circuit is deactivated.
  7. Offline


    I just looked on the redstoneChange method, then remembered he mentioned speedcircuits and wondered if deactivating a circuit using a circuit of speedcircuit's would alter the inputList.
  8. Offline


    But isn't a flipflop a pretty large circuit?

    Didn't think/know about the counter.
    Will have to try this

    Well again, the idea was to make use (if you used extra signs on the input/outputs) of signs to alter outputs of clocks (and other circuits) aka: modifiers. in the interest of compact (space saving) circuits.

    But then again, I'm not a coder, so sometimes my suggestions sound far easier than they are to actually implement...

    *back to blowing up circuits*
  9. Offline


    Yes. makes sense. deactivate or reset. If that's the case, I'm not sure how to solve it.
  10. Offline


    Needspeed10 would need to use a syncedDelayedTask.
  11. Offline


    @ArashiDragon The flipflop can have any number of input/output pairs so 1 input and 1 output would be the smallest one. I'll think about i/o signs. I like the idea but in any case I don't want the clock to have more than 1 frequency.

    Right, nice. Actually I'm working on merging speedcircuits with BasicCircuits so I can change that myself.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  12. Offline


    well i made the thing on the video for the speed circuits I did get the libraries and i edited the thing from the vid and it worked once. i'm using a pulsar and chestset (from speedcircuits) im trying to spawn stuff into the chest with chestset i got rid of an OR sign from the vid and when i press the button from the pulsar it does not spawn items in the chest and i get the warning
    srry sometimes i just keep saying things without order. I hope you can still understand.
  13. Offline


    So you didn't use speedcircuits' resetter at all?
  14. Offline


    ??? what does resetting it make it work???
  15. Offline


    No, but if it would be caused by the resetter circuit, we'd know what happens, but you didn't mentioned one, so the problem lies elsewhere.
  16. Offline


    hmm... [gunpowder]
  17. Offline


    I have a question about /rcarg

    is this the correct syntax:
    Current sign:
    1st line: pixel
    2nd line: white red
    3rd line: 'blank'
    4th line: ht-seg:0

    tried /rcarg 4 h-seg:0

    response: unknown color name: h-seg:0
    pixel was not activated.
    Counld not reactivate circuit with new sign arguments

    Sign now reads:
    1st line: pixel
    2nd line: white red
    3rd line: ht-seg:0
    4th line: 'blank'

    If I try replacing /rcarg 4 h-seg:0
    with /rcarg 3 h-seg:0 it works, BUT it moves it to line 3? Is this ok?

    I'm asking because on your website RedstoneChips Pixel circuit docs, it has:
    Sign text
        [color] ... [color]
        [dist{<distance>}] (optional)
        [broadcast-channel] (optional. must be the last argument)

    Thanks in advance.
  18. I get this error in my server log:

    2011-05-18 21:06:49 [SEVERE] Exception in thread "AWT-EventQueue-0"
    2011-05-18 21:06:49 [SEVERE] java.lang.NullPointerException
    2011-05-18 21:06:49 [SEVERE] at me.silverstar.timefold.TimeFoldActionListener.actionPerformed(TimeFoldActionListener.java:36)
    2011-05-18 21:06:49 [SEVERE] at javax.swing.Timer.fireActionPerformed(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at javax.swing.Timer$DoPostEvent.run(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.event.InvocationEvent.dispatch(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventQueue.access$000(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventQueue$1.run(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventQueue$1.run(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.security.AccessController.doPrivileged(Native Method)
    2011-05-18 21:06:49 [SEVERE] at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventQueue.dispatchEvent(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    2011-05-18 21:06:49 [SEVERE] at java.awt.EventDispatchThread.run(Unknown Source)

    It also says it loaded 0 chips, and the circuits file in the folder is empty. Am I missing something here? Sorry if this is a noob question :<
  19. Offline


    @LegendarySandwich There's no mention of RedstoneChips in this error. What makes you think it's connected? It's an error with another plugin called perhaps TimeFold. Are there any other lines in this error that you didn't paste?
    EDIT: Btw, I personally wouldn't use a bukkit plugin that runs a java Timer unless it has a very good reason...

    @ArashiDragon It's not about lines. It's about arguments. Your 1st argument is 'white', 2nd is 'red', 3rd is 'ht-seg:0'. Lines don't matter. Arguments are split according to spaces. You added an aditional (4th) argument with 'ht-seg:0' so it got confused.

    @ploopo I would have to test chestset but it would take me a while. You better try again once there's a similar chip as part of the main circuit libraries.
  20. Offline


    @eisental Ok, got that, so basically it'll always move the 4th line to the 3rd unless there's something already in the 4th line.

    I'll test this more, cause I still think I'm getting an error.

    But I could be wrong. So off to testing... (well later today, grandma needs to go shopping today, I get to play chauffeur)

    @eisental Are circuits ment to be able to share input/output blocks? or is this just a happy circumstance I stumbled across?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  21. Offline


    They can even share parts of their structure, you can add some blocks to a circuit, attach a second sign and activate it.
  22. Offline


    *gets an evil gleam in her eye* Oh.. this is gonna be fun. God I'm loving Redstone Chips more and more.
  23. Offline


    Nope, not quite...

    You have 3 arguments on your sign (the chip name is NOT an argument):
    "white" "red" "h-seg:0"

    They could be on the sign as:
    white red




    red h-seg:0


    red h-seg:0

    In all those cases "h-seg:0" is argument 3 (not 4).

    Using /rcarg, the formatting of the sign may not be maintained though, so the order of the items will not change, but how they are formatted on the sign may change.

    In the case of the command; tried /rcarg 4 h-seg:0
    Your arguments became:


    Note that when you have multiple chips sharing the same space and some subset of shared inputs and outputs, you can end up with some VERY unpredictable behavior. Also, IIRC the "break" code only expects a single chip to be broken by destroying a single block, so if for example you share an input block between two chips and then destroy that input block, only one chip will be deactivated. (Eisental please correct me if I'm wrong.)

  24. Offline


    This is fixed now, v0.4 ist just released, please update.
    Sorry for any issues.
  25. Offline


    Sharing blocks can cause some weird behavior. I think all redstone events should work correctly but any command that needs to identify a chip by its location will give unexpected results when dealing with shared blocks. This is definitely not intended and I might fix it in the future (it will be very easy to fix :p).

    @SilverstarX Cool. Thanks for letting us know...
  26. Ah, sorry. That error was just under some RedstoneChips messages in the server log so I thought they were coming from it (the fact that it said 0 chips loaded didn't help). I think I've got it all figured out now, thanks.

    Uh, what? It's still at version 0.9.
  27. Offline


    Yeah, I "accidently" found it, gladly.

    I mean my plugin, TimeFold, which caused the error.
  28. OOOOH, TimeFold. I didn't even know you were the one who made that, lol. Cool, I'll download the updated version.
    SilverstarX likes this.
  29. Offline


    depens on the use, if the name is the same ok but if channel should be something else, its sign edit time
  30. Offline


    I think making RC aware that a block can belong to multiple chips would be a really good addition. It would pave the way for the I/O block I had talked about before, which is inherently a member of multiple chips. (BTW, I still think the Repeater as an I/O block would work great)

  31. Offline


    @Mordenkainen I guess you're right but just allowing chips to share any block as it is now can create a lot of confusion and weird circuit bugs. I'll try the repeater idea although I don't like, as I said last time, that it already has another redstone function. If anybody has any idea of a way to set a direction without using signs, do let me know.

Share This Page