Inactive [MECH] MultiInv V2.4.1 - Per World Inventories [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Pluckerpluck, Feb 17, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Psycho Robot

    Just edit the config file and put one of your world names on one line, and the other on a separate line under it
     
  2. Offline

    TheGildur

    hey there,

    I'm using b860 and wanted to ask if there is some sort if incompatibility? I have 3 worlds, 2 of them shall share, the 3th world is supposed to have an own inventory, seperated from the other two. For now all worlds are NOT sharing, which means I have different iventories in all world. But if I add this line in the sharing-file:

    Code:
    #minorWorld = majorWorld
    sphere = Castle
    then it says in the console that the share-config is loaded without any errors, but Inventories are not being shared though, nor the hearths. Any ideas?
     
  3. Offline

    Flobi

    This is unnecessary. If you put the plugin in, it will by default separate
    all worlds into their own inventories.
    You say you only have two worlds, but have you taken into account the 1.6 addition of inherent nether world? The primary world has a nether which is linked to by each and every (provided it's not overridden by a plugin) nether portal. It's called: "{primaryworldname}_nether".
     
  4. Offline

    keyname

    I run craftbukkit 860 and have the following setup:

    jagtmarken = dennyeverden
    terranova = dennyeverden
    HELVEDE = dennyeverden
    smiletsverden2 = smiletsverden

    It seems like all the minor worlds share inventory, but the major world (dennyeverden) is not sharing....
     
  5. Offline

    Flobi

    I would ask you to make sure that is the actual name of your major world. A slight spelling error could easily cause what you describe. It's also potentially case sensitive (though I haven't tested this), so if your world name is Dennyeverden, it would have a separate inventory from dennyeverden (possibly).
     
  6. Offline

    chriskevini

    Hi I got this when i teleported with Multiverse

    18:30:38 [SEVERE] Could not pass event PLAYER_TELEPORT to MultiInv
    java.lang.NullPointerException
    at uk.co.tggl.Pluckerpluck.MultiInv.MultiInvPlayerListener.onPlayerTeleport(MultiInvPlayerListener.java:55)
    at org.bukkit.plugin.java.JavaPluginLoader$8.execute(JavaPluginLoader.java:292)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    at org.bukkit.craftbukkit.entity.CraftPlayer.teleport(CraftPlayer.java:208)
    at com.gmail.nossr50.mcPlayerListener.onPlayerCommandPreprocess(mcPlayerListener.java:861)
    at org.bukkit.plugin.java.JavaPluginLoader$5.execute(JavaPluginLoader.java:271)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:58)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:310)
    at net.minecraft.server.NetServerHandler.handleCommand(NetServerHandler.java:706)
    at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:678)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:671)
    at net.minecraft.server.Packet3Chat.a(Packet3Chat.java:32)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:226)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:399)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:309)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)

    thanks
     
  7. Offline

    Poeschl

  8. Offline

    Mentioum

    also getting this... everything seems to work though.
     
  9. Offline

    godsyn

    Can you also change the topic to reflect the latest version (2.1.0), please. Makes checking for updates a bit more of a pain.
     
  10. Offline

    Smelltastic

    Does MultiInv track iConomy funds separately for each world along with inventories? If not, I'd like to request that as a feature.
     
  11. Offline

    Bakies

    Where is the shares.txt located? do i need to create it? where do i create it?
     
  12. Offline

    keyname

    Oh yes, sorry about that - a simple nobrain typo in the worldname. :oops:

    Newer versions use shares.properties as i recall (not at my server at the moment), not shares.txt anymore.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 9, 2016
  13. Offline

    fatmarley

    I have the same issue, on restart it works, but then at some point in the day it stops sharing.


    EDIT: I found out that you can only link to ONE world for the Multiinv to work successfully. But this is only based on testing done on my server, so it is possible that i am wrong.
     
  14. Offline

    Bakies

    Still where is it?
     
  15. Offline

    jellybellys

    plugins/multiinv
     
  16. Offline

    Bakies

    do i make it? it wasnt created when I ran the server with the plugin the config was though. I am so confused i feel stupid.
     
  17. Offline

    chriskevini

  18. Offline

    nukeade

    One of my players reports the following bug with MultiInv 2.1.0 on Bukkit 860:


    1) put stuff in your inventory in creative world
    2) warp back to the survival world (i used /warp dragon)
    3) use /kill (or die by other means--apparently TNT works also)
    4) when you respawn in the survival world, you'll have your creative inventory
     
  19. Offline

    Drdetroit

    The Same thing is happening on my server. Running Bukkit 860. when i die i re spawn with my inventory from creative world. witch really sucks! Anyway around this??
     
  20. Offline

    piousminion

    Any tips on not getting my logs flooded with:
    "[WARNING] [MultiInv] Failed to teleport player correctly" ?
     
  21. Offline

    angus22397

    looking forward for you to fix this....
     
  22. Offline

    vein_mx

    Please also update the version in the title of the thread =]
     
  23. Offline

    Flobi

    The author hasn't been here in over a month. It's only luck that it's still working really.
     
  24. Offline

    vein_mx

    Oh alright, sorry about that! But I dont think its "luck" lol. Just nothing needed to be changed.
     
  25. Offline

    AS1LV3RN1NJA

    Also having this problem with a few players, now known on my server as "The Survival Glitch"; they think it may be to do with me teleporting them to me from a different world.
     
  26. Offline

    efstajas

    Would really like an updated version. This is an essential on my server but with all this bugs getting worse with every CB- Update... :(
    Doesn't work with CB860. Do not download and try, it will cause all your servers plugins to not work anymore. The console gets spammed with "COULD NOT PASS ... TO ..."- Errors when I have this plugin loaded.
    Please, update it! I REALLY need it. :(

    No, normally not. If you manage your servers files with FTP, try refreshing.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 9, 2016
  27. Offline

    Flobi

    Don't know if this helps, but I am using 2.1.1 and it isn't doing this on my world. 2.1.1 isn't even listed on the OP, it's in a thread a few pages back:

     
  28. Offline

    Pluckerpluck

    A MONTH! Are you sure? I'm sure I was on here in June fixing some problems... plus the bukkit api keeps dying on me. So it is sort of luck it works (if it does for you)

    I'm terribly terribly sorry about all this but my life has been a bit hectic recently. My PC has a tendency to continually die (with the last error Windows telling me it's not a valid/genuine installation)... then I got a failed service pack update... which almost resulted in me losing all my work as I only have 1 PC and needed another to get all my data. I couldn't even just try and re-install windows as the installer blue-screened from the CD. I was forced to make a GParted cd and format the drive after copying all my files off which took WAY too long.

    Other than that I've also had exams (A-Levels) for school and have been under tonnes of pressure.

    I'd also point out that "Latest Jar" and "Old version" are not the same even if the thread title is wrong... I'll change that.

    And I'm going to work on this tomorrow (GMT) so it's 11pm here. I'm going to ensure I have a working version before I stop and I'm also going to fix any converter issues. I sort of had a problem with the files in that they were still world specific even though they shouldn't have been. So this means MultiInv 2.2 will be incompatible with MultiInv 2.1 but I'm going to ensure the converter works first and can convert either old inventories (if you still use them) or 2.1 inventories. The main reason from the old to new inventories change was to ensure my inventories were stored in plain text so others could more easily access them if need be.

    Once again I am terrible sorry and I'm going to try and fix everything.

    P.S. I actually had trouble getting to sleep last night thinking about how I'd abandoned you all....

    Edit: I'd also like to add that I think the git repo is TERRIBLY out of date. It takes time (and mostly effort) to set up and use git and it definitely hasn't been a priority on my PC atm. Does anyone realize how many updates a new Windows PC has to install!

    Edit 2: Finally, the converter is also getting a non-gui mode for those without a GUI. And if anyone knows how to get the inventories out of notch's player data files please do tell.

    *sigh* they've changed the way respawning works then.... I'll try fix this.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 9, 2016
    Mentioum, AS1LV3RN1NJA and efstajas like this.
  29. Offline

    efstajas

    Thank you really much. You don't have to worry that much about us (about me at last, don't know how the others think about that...), sure it's not good if an important plugin suddenly stop working, but hey, Minecraft is just a game. I honestly feel sorry for you feeling sorry for us. I know how you feel. :'(
    Anyway, I'm really looking forward to an updated version, so I can enable my Creative World again. :)
     
    AS1LV3RN1NJA likes this.
  30. Offline

    Phinary

    Well... For some reason, when I shutdown my server.. I got spammed with multiverse messages then eventually the server shut down. When we logged back on, everyones inventory of the players that were logged on when i shut down, got their inventories deleted. :(
     
Thread Status:
Not open for further replies.

Share This Page