Inactive [MECH] MagnetBlock v0.4.7 - Movable Structures controlled by Redstone [1060]

Discussion in 'Inactive/Unsupported Plugins' started by narrowtux, Mar 2, 2011.

  1. Offline

    Loose Nut

    I have a small request,
    allow the magnet to get power from any direction.
    much like the input (transmitter) from your redremote plugin

    or magnet get power from diamond block attached

    would help with magnets in the air.
     
  2. Offline

    narrowtux

    You can seperate the movement by creating a pit where a single block of the structure can go through. This will keep the structure in place.
    [MERGETIME="1299759004"][/MERGETIME]
    I updated RedRemote to v0.2, this emits BlockRedstoneEvents to DiamondBlocks that haven't got a switch.
    This works great with MagnetBlock if you place the receiving Diamondblock directly aside the Magnet. Update for MagnetBlock to receive Power from Up/Down also arrives in a few seconds.
     
  3. Offline

    icomeinpieces

    all i'm getting is AIR when i add blocks and nothing when i add the magnet block.
    is there something that I might not be doing right?
     
  4. Offline

    narrowtux

    Haven't tried it with recent versions of craftbukkit, which version do you have got? Mine is 497
     
  5. Offline

    raz235

    can you please take down the debug message because its flooding my server console other than that your plugin is great!
    i think that you need to update to the latest recommended build because some things dont work as they should like the structure stuck at the middle while it still got place to go until the magnet
     
  6. Offline

    fohl

    Hey,
    this is an awesome plugin! I just want to tell you about a funny bug I discovered. Maybe you already know about that, but if i add a redstone torch to a structure and move it aorund the torch is popping out for each movement. But the torch-block moves right. The same happens to normal torches.
     
  7. Offline

    icomeinpieces

    i'm running 527
    here is where i got mine from: http://ci.bukkit.org/job/dev-CraftBukkit/
     
  8. Offline

    narrowtux

    Indeed, I know this already ;)
    I'm still working to get item-blocks like redstone or flowers working that they can be added to a structure. In this change, I'll also improve the movesystem that this doesn't happen any more.
     
  9. Offline

    ssechaud

    Testing v0.1.4 with CB build 531 and 532, I am getting this message when using something that was working in CB build 493:

    19:39:23 [INFO] Magnet not found at Location{world=CraftWorld{name=world}x=-192.
    0y=68.0z=100.0pitch=0.0yaw=0.0}
    19:39:31 [INFO] Magnet not found at Location{world=CraftWorld{name=world}x=-178.
    0y=68.0z=100.0pitch=0.0yaw=0.0}
     
  10. Offline

    narrowtux

    Maybe you removed some of the magnets. These are just info messages that you have lost a magnet. rebuild it and everything will be ok.
     
  11. Offline

    TechGuard

    I like the idea, but the moving of the magnet is looking pretty buggy. Maybe add an option to change the timer sleep?
     
  12. Offline

    icomeinpieces

    anyone know if this plugin is working with CB 527?
    I keep getting "AIR added to structure" messages when doing anything.
     
  13. Offline

    raz235

    Im using CB 531 and its pretty buggy..
    the structure gets stuck in the middle of his track to the magnet if i saw correctly even in the video it happend to u do u have any idea how to fix it?
     
  14. Offline

    narrowtux

    I don't think that it stuck there, your impression is caused by the bad framerate when I do video recordings of games.
     
  15. Offline

    raz235

    so you think this bug is caused by the CB version?
    sorry for my english :(
     
  16. Offline

    narrowtux

    I didn't test it with the new version, but I will do it. Is there any possibility to downgrade to 497? this version runs very good...
    I recently read on craftbukkits twitter-account that there is a bug with blocks this may have something to do with it (I dont really know what the bug is exactly :D)
     
  17. Offline

    icomeinpieces

    maybe i missed something is the wool needed as demonstrated in your video?
    is the ditch in the ground that was used for the structure needed in some way?
    perhaps I'm just configuring it wrong, I'm trying to make a gate similar to yours :)
     
  18. Offline

    raz235

    first of all thank you for all of your help..
    well i dont think i will downgrade because i just updated my plugins and if i install CB 497 most of them wont work..
    mabey when i have the time i will open a new server with CB 497 and this plugin to check it out bug free(i hope[​IMG])
     
  19. Offline

    SunShe

    when your "teleferry like" move in your video, curious to see if that eat bandwith like crazy for send each times all new blocks at other players. but the idea are so cool. it's almost like controllerblock.
     
  20. Offline

    Vanoi

    Yes you can do that... if your magnet is directly below the structure, but if you put it on the sides it will want to move to the side instead and collide with any blocks on the side and stop moving. Thus it won't move up and down when you have blocks on the side to keep it in place and your magnet is on the side.
     
  21. Offline

    Loose Nut

    for structures that keep dissapearing
    you can go into \plugins\MagnetBlock\xxx.structure
    and edit the blocks.csv file and replace AIR with what ever it used to be (if you have access to the server)
    then do /reloadall (if you have essentials)

    might be good to make a backup of your blocks.csv file for each structure.
    might be able to share structures this way too.

    anyone want to share a structure, so i can try that ?
    a simple copy and paste would be enough
    something like this
     
  22. Offline

    drampelt

    I get spammed with this in console after a new first time install:
    Magnet not found at Location{world=CraftWorld{name=world}x=-1162.0y=58.0z=-1431.0pitch=0.0yaw=0.0}
    Some of the exact numbers change a bit but really annoying and laggy
     
  23. Offline

    icomeinpieces

    any news on this plugin working with CB 527?
     
  24. Offline

    narrowtux

    Loke Loose Nut said:
    Will definitely try to test a new release of bukkit.
     
  25. Offline

    icomeinpieces

    good luck hopefully if you do find the same problems with the new CB version and your plugin as I did that it's not a difficult code change for the new version.
     
  26. Offline

    ssechaud

    Any ideas why something built in 493 works, and then doesn't in 531? Not wanting to put it on the server and tell people to rebuild their stuff without knowing why.
     
  27. Offline

    icomeinpieces

    is there a way to rotate structures with the magnets not with the bone. A friend wants to make gun turrets for a project and would love it if they could rotate.
    [MERGETIME="1299912919"][/MERGETIME]
    files for created structures remain after a structure has been deleted ingame can these be reused to auto recreate structures? also does there have to be a iron block in the structure in order to be attracted by a magnet?
     
  28. Offline

    narrowtux

    The Auto-rotate feature is already planned.
    You don't really have to build an iron block in the structure, when you don't do it, the very first block is taken as origin point. but if you want the control over the origin point, an iron block is very helpful.
     
  29. Offline

    3istee

    Code:
    11:03:42 [SCHWERWIEGEND] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'mbfs
    ' in plugin MagnetBlock v0.1.4
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:33)
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:80
    )
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:1
    83)
            at net.minecraft.server.NetServerHandler.c(NetServerHandler.java:619)
            at net.minecraft.server.NetServerHandler.chat(NetServerHandler.java:582)
    
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:576)
            at net.minecraft.server.Packet3Chat.a(SourceFile:24)
            at net.minecraft.server.NetworkManager.a(SourceFile:230)
            at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NullPointerException
            at com.narrowtux.MagnetBlock.MagnetBlock.save(MagnetBlock.java:285)
            at com.narrowtux.MagnetBlock.MagnetBlock.onCommand(MagnetBlock.java:134)
    
            at org.bukkit.command.PluginCommand.execute(PluginCommand.java:31)
            ... 12 more
    This appears everytime I want to finish a structure. The "Block added!" message isn't coming also.

    PS: I have running 497
    Newest recommned version (532 or so) doesn't work, too.

    Edit: Fixed by change the version number in the info.cvs (or so) from 0.1 to 0.14. Works for me now :D
     
  30. Offline

    icomeinpieces

    so if i add a iron block to a structure after it is built, will it be considered the origin point instead of whatever block was the first one placed?
     

Share This Page