Inactive [MECH] bLift 1.2 - Simple elevators [1.2.5]

Discussion in 'Inactive/Unsupported Plugins' started by Brad811, Jun 15, 2011.

  1. Offline


    bLift - Simple elevators!
    Download: bLift BukkitDev
    If you like the work I've done, or would like to see more features and improvements, please consider donating!
    Version: v1.2

    If you are having issues with this plugin,

    FIRST: Read the thread to make sure your question has not been answered.
    SECOND: If you can't find an answer, file a ticket:
    If you would like to post your question instead for some reason, in your post please include:
    1. The version of this plugin you are using (the output of /version bLift, not "the latest one")
    2. The version of bukkit you are using (not "the latest one")
    3. Any error messages associated with the issue
    Otherwise I will most likely be unable to help you!

    Some simple elevator action. It's only called bLift because bElevator sounds weird.
    If y'all like it, I'll add more features like multiple floors and being able to put torches in your elevators!

    Simple 2-floor elevator:

    Multi-floor elevator:
    _____BOTTOM FLOOR________MIDDLE FLOORS_________TOP FLOOR______

    You can get fancy with it:

    Video: (NOTE: gold blocks are no longer required)

    • simple up-down elevators
    To use a simple 2 floor elevator, press the button to move between the floors.
    To make a 2 floor elevator up only, remove the button in the top floor.
    To make a 2 floor elevator down only, remove the button in the bottom floor.

    To use a multi-floor elevator, first initiate the signs by right clicking any one of them (this only needs to be done once).
    The top number is the current floor. The bottom number is the destination. You may fill in the other two lines with anything if you like.
    Right click the sign until the bottom number says the floor number you want to go to.
    Then press the button to go to that floor.

    [air] = air
    [iron] = iron block
    [glass] = glass
    [brownmushroom] = button
    [wood] = sign

    Simple 2 floor elevator format:
    [air] \
    [air] (any height)
    [air] /

    Multifloor elevator format:
    [air] \
    [air] (any height)
    [air] /
    [air] \
    [air] (any height)
    [air] /


    • Now goes up to level 256!
    • Floors can now be smaller (one floor's ceiling can be another floor's bottom)
    • Added command: /blift [floors OR ends] [material] (uses permission "blift")
    • Hopefully fixed a couple of glass disappearing problems
    • Added multi-floor elevators
    • Fixed glass disappearing
    • Removed gold block requirement
    • Initial release!
    tobmaster3000, croxis, Omen and 5 others like this.
  2. Any way to disable message "ding" and have a config file to control speed of the lift? (set up speed and down speed Independence) Seems to go down faster then up
  3. Offline


    i tried to make a multi-floor elevator and was using the same piece of glass for the top of one floor and the bottom of another and it wouldnt allow it to work. :\
    do you think you could fix it to where you can use the same piece of glass for the top of a floor as the bottom of another? other than making a multi-floor the 2-floor worked great. thanks
  4. Offline


    I can see several things that can be improved.

    1. Signs need to be clearer, ie:
    - Floors -
    Current: 1
    Destination: 3
    2. Ability to use other material then glass as floor/roof for floors
    3. Larger elevator, i get claustrofobic in the small space. Atleast be able to make the size 2x2.
  5. Offline


    It wont work for me, I don't get any error messages and i do exactly as the pictures show.
  6. Offline


    Theese seem to pop up fairly frequently in log

    Code (Text):
    2. 2011-08-26 17:46:26 [SEVERE] Could not pass event REDSTONE_CHANGE to bLift
    3.         at com.bradsproject.BradleyJewell.bLift.MultiElevator.isInMultiElevator(
    4.         at com.bradsproject.BradleyJewell.bLift.MultiElevator.prepareMultiElevator(
    5.         at com.bradsproject.BradleyJewell.bLift.MultiElevator.<init>(
    6.         at com.bradsproject.BradleyJewell.bLift.Elevator.<init>(
    7.         at com.bradsproject.BradleyJewell.bLift.bLiftRedstoneListener.onBlockRedstoneChange(
    Also, if the elevator could bypass server kicking for floating for too long while riding the elevator, that would be great.
  7. Offline


    will this be updated for 1060? It works but is alittle glitchy.
  8. Offline


    Right now the maximum amount of floors in a multi-floor elevator is 4, and I'm making a flat with 10 floors :)
    Could you make it possible to make elevators without a maximum amount of floors (or a high maximum, like 25 floors or so)? Thanks!
  9. Offline


    Where are you getting that 4 is the max number of floors? Right now the only limit is map height.
  10. Offline


    I'm having a bug on this combining it with NoCheat, it detects I'm flying.. :(
  11. Offline


    In that flat I'm building, it worked fine with 4 floors but when I added a 5th one it wouldn't work :S
    Btw, I use 1 glass block between two floors, so there is a floor underneath and above each glass block. Maybe that is the problem?
  12. Offline


    We've been having some weird glitches with blift since bukkit 1060. It will freak out on people sometimes and make them stay in a constant up and down loop until they re-log. They go up about 8-10 blocks, then back down, rinse repeat.
  13. Offline


    Awesome job! I love the signs to show the floors and how you can change the floor you want to go to!
  14. Offline


    what are the permissions nodes?
  15. Offline


    Great plugin. It works on Build 1060. The only thing I have to suggest is that the bottom and top glass can be shared. Most buildings have a one thick divider between floors. All the other stuff is great. I like the simple sign idea. I took a screenshot to show you what I mean. The multi-floor elevator on the very right does not work.
    Sorken likes this.
  16. Hi,

    I'm getting this error using CB1060

    Code (Text):
    2. [SEVERE] Could not pass event REDSTONE_CHANGE to bLift
    3. java.lang.NullPointerException
    4.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.isInMultiElevator(
    5.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.prepareMultiElevator(
    6.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.<init>(
    7.     at com.bradsproject.BradleyJewell.bLift.Elevator.<init>(
    8.     at com.bradsproject.BradleyJewell.bLift.bLiftRedstoneListener.onBlockRedstoneChange(
    9.     at$35.execute(
    10.     at org.bukkit.plugin.RegisteredListener.callEvent(
    11.     at org.bukkit.plugin.SimplePluginManager.callEvent(
    12.     at net.minecraft.server.BlockButton.interact(
    13.     at net.minecraft.server.BlockButton.b(
    14.     at net.minecraft.server.ItemInWorldManager.dig(
    15.     at net.minecraft.server.NetServerHandler.a(
    16.     at org.getspout.spout.SpoutNetServerHandler.a(
    17.     at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    18.     at net.minecraft.server.NetworkManager.b(
    19.     at net.minecraft.server.NetServerHandler.a(
    20.     at org.getspout.spout.SpoutNetServerHandler.a(
    21.     at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    22.     at net.minecraft.server.MinecraftServer.h(
    23.     at
    24.     at
    25. 2011-09-04 13:02:13 [SEVERE] Could not pass event REDSTONE_CHANGE to bLift
    26. java.lang.NullPointerException
    27.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.isInMultiElevator(
    28.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.prepareMultiElevator(
    29.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.<init>(
    30.     at com.bradsproject.BradleyJewell.bLift.Elevator.<init>(
    31.     at com.bradsproject.BradleyJewell.bLift.bLiftRedstoneListener.onBlockRedstoneChange(
    32.     at$35.execute(
    33.     at org.bukkit.plugin.RegisteredListener.callEvent(
    34.     at org.bukkit.plugin.SimplePluginManager.callEvent(
    35.     at net.minecraft.server.BlockButton.interact(
    36.     at net.minecraft.server.BlockButton.b(
    37.     at net.minecraft.server.ItemInWorldManager.dig(
    38.     at net.minecraft.server.NetServerHandler.a(
    39.     at org.getspout.spout.SpoutNetServerHandler.a(
    40.     at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    41.     at net.minecraft.server.NetworkManager.b(
    42.     at net.minecraft.server.NetServerHandler.a(
    43.     at org.getspout.spout.SpoutNetServerHandler.a(
    44.     at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    45.     at net.minecraft.server.MinecraftServer.h(
    46.     at
    47.     at
    48. 2011-09-04 13:02:15 [SEVERE] Could not pass event REDSTONE_CHANGE to bLift
    49. java.lang.NullPointerException
    50.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.isInMultiElevator(
    51.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.prepareMultiElevator(
    52.     at com.bradsproject.BradleyJewell.bLift.MultiElevator.<init>(
    53.     at com.bradsproject.BradleyJewell.bLift.Elevator.<init>(
    54.     at com.bradsproject.BradleyJewell.bLift.bLiftRedstoneListener.onBlockRedstoneChange(
    55.     at$35.execute(
    56.     at org.bukkit.plugin.RegisteredListener.callEvent(
    57.     at org.bukkit.plugin.SimplePluginManager.callEvent(
    58.     at net.minecraft.server.BlockButton.interact(
    59.     at net.minecraft.server.BlockButton.b(
    60.     at net.minecraft.server.ItemInWorldManager.dig(
    61.     at net.minecraft.server.NetServerHandler.a(
    62.     at org.getspout.spout.SpoutNetServerHandler.a(
    63.     at net.minecraft.server.Packet14BlockDig.a(SourceFile:42)
    64.     at net.minecraft.server.NetworkManager.b(
    65.     at net.minecraft.server.NetServerHandler.a(
    66.     at org.getspout.spout.SpoutNetServerHandler.a(
    67.     at net.minecraft.server.NetworkListenThread.a(SourceFile:105)
    68.     at net.minecraft.server.MinecraftServer.h(
    69.     at
    70.     at
  17. Offline


  18. Offline


    I have been using Blift sens realese it have been working great all the time but now people get kicked for flying how come?
  19. Offline


    Ive noticed all kinds of weird glitches including what you mentioned since CB 1060, unfortunately I have not seen one post from the dev about fixes or for that matter an update.
  20. Offline


    Agreed, that would be useful.
  21. Offline


    Can't get it to work . Nothing happens, i put the sign in and if i rightclick it nothing happens. i get the "bLift version 1.1 is enabled! " in server manager. so the plugin must be on. but it act's like its not.anyone any idea how to get it working ?

    Bukkit Build: CB1060
    bLift Version: 1.1.1
    Error message: None
  22. Offline


    @Brad811 Any plans on developing this plugin further?
  23. Offline


    Hello people!
    I'm french and do not know speak English.
    I use google translator ... sorry:)
    Thank you very much for your plugin, it is too good!
    I am a french video tutorial if you want you can add it:)

    thank you again.
    good job man!
  24. Offline


    Plugin still reports itself as being 1.1 insetad of 1.1.1
  25. Offline


    I tried to right click the multi-level elevator sign, level one went as 1 but no others showed up not even the destination on sign 1. Please respond.

    Oh never mind I fixed it. Note: It does NOT work with LWC

    Good job! If you get this working propperly, it's awesome! Now this is a good developer!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
    Huene likes this.
  26. Offline


    AWESOME Plugin! :D

    Just confirming to people wondering, it does work (fully, to my knowledge) on 1185 :)
  27. Offline


    Multi-level elevators do not work in 1185, are there still plans to update this? it's a few RB's old
  28. Multi-level elevators works fine for me on B1214.
  29. Offline


    Thank you very much I'll upgrade and try again
  30. Offline


    I'm running 1.1 and multi-floor elevators run fine in 1185 for me.
  31. Offline


    Meh thank you all, it seems I missed the part about floors and ceilings not being able to be on the same block, multi-floor is working just fine excepting that problem

Share This Page