Maven - not downloading needed libraries.

Discussion in 'Plugin Development' started by zajacmp3, Apr 3, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    zajacmp3

    Hello,

    First of all I will try to make it easy to read for you.

    Things I need help with or just questions I need answer to:
    1) Am I having bad luck and my first encounter with Maven is on some outdated project?
    2) Why Maven can't get any of the needed libraries?

    Describing how my problems happened:
    1. Integrated Maven and other stuff with my eclipse with github
    2. source: https://github.com/OneBusAway/onebusaway/wiki/Importing-source-code-into-Eclipse
    3. imported project into my eclipse workspace
    4. can't compile the project cause it can't get a hold on any of the external jars.
    I managed to find some of them manually and make it work, but I can't find them all.
    And it should not do it automatic?

    Screenshots with errors:
    http://i.imgur.com/S9WrNZv.png

    http://i.imgur.com/I5QbcwG.png

    Thanks for help everyone!
     
  2. Offline

    TheE

    Could you post the contents of your pom.xml? It appears as if you try to access every referenced project via http://thedemgel.com:8080/jenkins/ with does not exist (or is offline as of writing). Try switching to other repositories, at least for bukkit and Vault you may want to use the official ones.
     
  3. Offline

    zajacmp3

    Thanks for answering!

    Here is the pom.xml contents:
    link to pastebin:
    http://pastebin.com/jdx2eg50
    code:
    Code:
    <!-- Blacksmith build file -->
    
    <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
             xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
        <modelVersion>4.0.0</modelVersion>
    
        <groupId>net.apunch</groupId>
        <artifactId>blacksmith</artifactId>
        <version>1.0-SNAPSHOT</version>
        <name>Blacksmith</name>
        <description>Blacksmith Character for the CitizensAPI</description>
    
        <!-- Properties -->
        <properties>
            <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
            <bukkit.version>1.3.2-R1.0</bukkit.version>
            <citizensapi.version>2.0.3-SNAPSHOT</citizensapi.version>
            <vault.version>1.2.18-SNAPSHOT</vault.version>
            <build.number>Unknown</build.number>
        </properties>
    
        <!-- Repositories -->
        <repositories>
            <repository>
                <id>bukkit-repo</id>
                <url>http://repo.bukkit.org/content/groups/public/</url>
            </repository>
            <repository>
                <id>citizens-repo</id>
                <url>http://repo.citizensnpcs.com/</url>
            </repository>
            <repository>
                <id>vault-repo</id>
                <url>http://ci.herocraftonline.com/plugin/repository/everything/</url>
            </repository>
            <repository>
                <id>thedemgel-repo</id>
                <url>http://thedemgel.com:8080/jenkins/plugin/repository/everything/</url>
            </repository>
        </repositories>
    
        <!-- Dependencies -->
        <dependencies>
            <dependency>
                <groupId>org.bukkit</groupId>
                <artifactId>bukkit</artifactId>
                <version>${bukkit.version}</version>
                <scope>provided</scope>
            </dependency>
            <dependency>
                <groupId>net.citizensnpcs</groupId>
                <artifactId>citizensapi</artifactId>
                <version>${citizensapi.version}</version>
                <scope>provided</scope>
            </dependency>
            <dependency>
                <groupId>net.milkbowl.vault</groupId>
                <artifactId>Vault</artifactId>
                <version>${vault.version}</version>
                <scope>provided</scope>
            </dependency>
            <dependency>
                <groupId>regalowl.hyperconomy</groupId>
                <artifactId>HyperConomy</artifactId>
                <version>0.933</version>
                <scope>system</scope>
                <systemPath>${basedir}/lib/HyperConomy.jar</systemPath>
            </dependency>
            <dependency>
                <groupId>me.tehbeard</groupId>
                <artifactId>CitiTrader</artifactId>
                <version>RC-5</version>
                <scope>provided</scope>
                <exclusions>
                    <exclusion>
                        <artifactId>Towny</artifactId>
                        <groupId>com.palmergames</groupId>
                    </exclusion>
                </exclusions>
            </dependency>
        </dependencies>
    
        <!-- Build information -->
        <build>
            <plugins>
                <plugin>
                    <groupId>org.apache.maven.plugins</groupId>
                    <artifactId>maven-compiler-plugin</artifactId>
                    <version>2.5.1</version>
                    <configuration>
                        <source>1.6</source>
                        <target>1.6</target>
                    </configuration>
                </plugin>
            </plugins>
        </build>
    
    </project>
    So probably all the errors I get is cause the project dependencies are outdated not working or something right?
    It is now my fault and I can continue studying Maven. Yep? :)
     
  4. Offline

    Lolmewn Retired Staff

    Does the pom.xml have a red something? I'm sure that can't be good.
     
  5. Offline

    zajacmp3

Thread Status:
Not open for further replies.

Share This Page