[Mac Only] AutoBukkitServer [Easy]

Discussion in 'Bukkit Tools' started by hawkfalcon, May 19, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Odilon13_

    • How do you start your server in the thing?

    Whenever I try start_server.command, the server just turns off!
    WTF

    HELP ME! Please

    http://dev.bukkit.org/bukkit-plugins/helpeveryonenow[plugin] EDIT by Moderator: merged posts, please use the edit button instead of double posting./
     
    Last edited by a moderator: Oct 29, 2015
  2. Offline

    hawkfalcon

    I need more details than that to help you, Odilon13_
     
  3. Offline

    DanilaFe

    Hi!
    I've stumbled over this, and, although I already have a Bukkit server, decided to try this out. I can see you wrote the server in AppleScript, which is the main reason it's Mac only (also the chmod a+ x I'm guessing). Maybe it could be a good idea to re-write this application in java to make it universal? It would help tons more people, and java works on EVERY platform.

    But otherwise, this is really great! This would really help somebody new to Craftbukkit set up their own server.
     
    hawkfalcon likes this.
  4. Offline

    hawkfalcon

    Yeah, I could. Maybe one of these days ;)
     
  5. Offline

    haykam821

    I can't setup... it always returns "Cannot divide something by something" and crashes, even after a reinstall.
     
  6. Offline

    hawkfalcon

    How much ram are you using.
     
  7. Offline

    fahlman


    I'm receiving the same error. "Can't divide 3612.0 by zero." The error pops up after the script successfully creates the CraftBukkit folder, downloads craftbukkit.jar and creates the start_server.command file. This happen whether I try Beta, Dev or Recommended. I've tried 1, 2 and 3GB RAM.
     
  8. Offline

    Pietyrx

    I have a problem with my plugins. I tried to download commandbook, and i dragged the folder into my plugins folder. This is what happened in start_server.command when I started the server:
    12:59:20 [INFO] Starting minecraft server version 1.6.4
    12:59:20 [INFO] Loading properties
    12:59:20 [INFO] Default game type: SURVIVAL
    12:59:20 [INFO] Generating keypair
    12:59:20 [INFO] Starting Minecraft server on *:25565
    12:59:20 [INFO] This server is running CraftBukkit version git-Bukkit-1.6.4-R2.0-b2918jnks (MC: 1.6.4) (Implementing API version 1.6.4-R2.0)
    12:59:20 [SEVERE] Could not load 'plugins/CommandBook.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandPermissionsException
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:184)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:305)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:230)
    at org.bukkit.craftbukkit.v1_6_R3.CraftServer.loadPlugins(CraftServer.java:241)
    at org.bukkit.craftbukkit.v1_6_R3.CraftServer.<init>(CraftServer.java:219)
    at net.minecraft.server.v1_6_R3.PlayerList.<init>(PlayerList.java:56)
    at net.minecraft.server.v1_6_R3.DedicatedPlayerList.<init>(SourceFile:11)
    at net.minecraft.server.v1_6_R3.DedicatedServer.init(DedicatedServer.java:107)
    at net.minecraft.server.v1_6_R3.MinecraftServer.run(MinecraftServer.java:393)
    at net.minecraft.server.v1_6_R3.ThreadServerApplication.run(SourceFile:583)
    Caused by: java.lang.NoClassDefFoundError: com/sk89q/minecraft/util/commands/CommandPermissionsException
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:249)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:173)
    ... 9 more
    Caused by: java.lang.ClassNotFoundException: com.sk89q.minecraft.util.commands.CommandPermissionsException
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at org.bukkit.plugin.java.PluginClassLoader.findClass0(PluginClassLoader.java:80)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:53)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    ... 12 more
    12:59:20 [INFO] Preparing level "PotterCraft"
    12:59:20 [INFO] Preparing start region for level 0 (Seed: -3694487667036094220)
    12:59:21 [INFO] Preparing start region for level 1 (Seed: -3694487667036094220)
    12:59:21 [INFO] Server permissions file permissions.yml is empty, ignoring it
    12:59:21 [INFO] Done (1.137s)! For help, type "help" or "?"



    Do you know what's wrong? Thanks in advance!
     
  9. Offline

    fahlman

    According to that error CommandBook isn't loading correctly. Make sure you have the latest version of CommandBook that is compatible with the version of CraftBukkit you're using. I just checked. The latest release, CommandBook 2.3, is compatible with CraftBukkit 1.6.2. I assume you're using CraftBukkit 1.7.9-R0.2 so you'll need to try a development build of CommandBook. The development builds can be found here: http://builds.enginehub.org/job/commandbook/. Click the red "Latest Unstable" button.
     
  10. Offline

    Pietyrx

    Thanks! That helped a lot :D

    Is there a way to open and change the server.properties file? When I try to open it it says,"There is no application set to open the document "server.properties"." Thanks in advance!

    Okay also, I need help with the port forwarding, this is what the start_server.command looks like: (And no, there isn't another server already running from my router).
    16:40:38 [INFO] Starting minecraft server version 1.6.4
    16:40:38 [INFO] Loading properties
    16:40:39 [INFO] Default game type: SURVIVAL
    16:40:39 [INFO] Generating keypair
    16:40:39 [INFO] Starting Minecraft server on *:25565
    16:40:39 [WARNING] **** FAILED TO BIND TO PORT!
    16:40:39 [WARNING] The exception was: java.net.BindException: Address already in use
    16:40:39 [WARNING] Perhaps a server is already running on that port?

    >

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Oct 29, 2015
  11. Offline

    Crazy_Man73

    yeah, samthing happens to me and I'm using 2
     
  12. Offline

    hawkfalcon

    I can't reproduce this. Odd.
    Restart your computer.
     
  13. Offline

    Coolguy8245

    Well i got the bukkit server ready But I'm not able to join the server? In order for people to join do we have to be in the same connection?? Also are they any other versions then just 1.6.4? Just wondering
     
  14. Offline

    IamCanwedoit

    Hey!
    Thank you so much for making this awesome tool!
    I only have one problem(picture of it attached.)
    Do you perhaps have any ideas on how to fix this issue?

    Thank you so much! I might finally be able to make a minecraft server!!!
    You are a great help! :)
    Thanks again!
    TheCanwedoit
     

    Attached Files:

  15. Offline

    Nathan2118

    Is this server good for 1.7.10?
    and also am I allowed to make a donation store for my server?
     
  16. Offline

    JayJaycool

    I downloaded it once and got a server then accidentally deleted it cause i thought my port wasn't working and i deleted it right before i got my port fixed so i redownloaded it and its not coming with all the files that i need in it all it comes with is start craftbukit.jar ops.jar and serverprops and when i run craftbukkit it says not allowed but I've done it before and when i do the start all its says it starts and then says process complete and doesn't let me do anything what do i do
     
  17. Offline

    LPerMitStyle

    I have a problem:
    Last login: Fri Sep 12 17:49:41 on ttys000
    peggy-reimers-MacBook-Pro:~ peggyreimer$ /Users/peggyreimer/Desktop/my\ server/CraftBukkit/start_server.command ; exit;
    Invalid or corrupt jarfile craftbukkit.jar
    logout

    [Prozess beendet]

    that ist written in my terminal
    the [Prozess beendet] is there beacouse i am german, and the computer settings language is german
     
  18. Offline

    -_Husky_-

    You need to port forward your network.

    Can you post the picture on http://imgur.com/ ? It's not attached.

    It's fine for 1.7.10, however the jar download for the server will not work.

    Delete the server.log, Start the server, Post the log here.

    The downloads to everything Bukkit are down at the moment due to a DMCA request. That's why you've got that error.

    Hope I helped. :)
     
  19. Offline

    Gamer111

    I have the same problem hawkfalcon. Yes, i let the process finish and nothing more happened. I re-downloaded the server and everything but nothings working.:(
     
  20. Offline

    hawkfalcon

    NOTE: THIS WILL _NOT_ WORK DUE TO THE DMCA TAKEDOWN.
     
    -_Husky_- likes this.
  21. Offline

    DrScream

    rename craftbukkit.jar to bukkit.jar and it will work even with the eula
     
  22. Offline

    Geo70870

    I did this and it didn't work please help
     
  23. Offline

    -_Husky_-

    Please read this:


     
  24. Offline

    DrScream

    I dont know whats wrong maybe the DMCA takedown but it worked fine for me.
     
  25. Offline

    bazz

    I already have my own bukkit server and decided to try this out, but..
    /Users/myuser/Downloads/directory doesnt/untitled\ folder\ 2/CraftBukkit/start_server.command ; exit;
    Invalid or corrupt jarfile craftbukkit.jar
    logout

    [Process completed]
     
  26. Offline

    yewhoneydew

    hello hawkfalcon i love bukkit servers but on my mac i follow your instructions clearly and have watched every single youtube video on how to make it work but when i start it up it says this

    command ; exit;
    Invalid or corrupt jarfile craftbukkit.jar
    logout

    [Process completed]




    pls help me by replying and getting me a bukkit server pls i will then keep on using them and thank you for reading this
     
  27. Offline

    yeah12134

    HAWkfalcon help me
    i have a problem it says

    Last login: Sat Nov 1 20:08:40 on ttys000
    /Users/igormudriy/Desktop/CraftBukkit/start_server.command ; exit;
    igors-mac-mini:~ igormudriy$ /Users/igormudriy/Desktop/CraftBukkit/start_server.command ; exit;
    Invalid or corrupt jarfile craftbukkit.jar
    logout

    [Process completed]

    It says that for my terminal
    everytime i load it i have tried all the options like buid and dev

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Oct 29, 2015
  28. Offline

    xXwolfieXx

    When I try to connect to my server it says Can't Connect To Server
     
  29. Offline

    Blkscorpion2



    Guys you are not reading the thread. Please read the above quote!
     
    hawkfalcon likes this.
  30. Offline

    Adzkii

    it's funny how people are still commenting saying it's not working when hawkfalcon said it won't work while the DMCA is still on.
     
    hawkfalcon likes this.
Thread Status:
Not open for further replies.

Share This Page