Level requirements for items! c:

Discussion in 'Archived: Plugin Requests' started by C4sad3i, Jul 7, 2014.

  1. Offline

    C4sad3i

    Hallo, basicly what i want. Is if you type *REQ; LVL 100* (to example.) ANYWHERE AT THE WEAPON PLEASE . You would have to be In that level (THE NORMAL MOJANG LEVELS!!! )

    Here's a screenshot of what it would look like. To example. (I'm using RPGITEM that why it looks like that )

    [​IMG]

    Name for the plugin. LEVEL REQUIREMENTS
    When do I like it by? ASAP C: I do have some time. But It would be nice to get it within a couple of days c:

    I've been looking for such a plugin now in a while. And haven't found one ideal to my needs. c: Since I use RPGITEM. It would just mess things up :c

    Tell me if there is anything I missed. And I will instantly edit this post to make you understand better!! c:
     
  2. Offline

    MCMastery

    C4sad3i Sorry, but I misunderstand what you want. Do you want a plugin that adds special armor and tools with special enchantments, that require the player to have a certain amount of xp for them to obtain it?
     
  3. Offline

    welsar55

    MCMastery He wants it so they have to be like level 456 to use a item.
     
  4. Offline

    C4sad3i

    MCMastery I'm using RPGITEM thats why it looks like that. I want that if it says so in the description of it. You have to be that level to use it c:
     
  5. Offline

    MCMastery

    C4sad3i So there is a list of items and their required level in the config.yml?
     
  6. Offline

    C4sad3i

    MCMastery That works too, but i was thinking something like it listens to the description of the weapon. As you can just randomly set it to an weapon. Wich will make it much more expandable! (If you now understand what i mean) Just tell me if I could possibly explain better and I'll try c:
     
  7. Offline

    C4sad3i

  8. Offline

    izarooni

    How would you change the level requirement if you don't use a config? the levels would have to be save somewhere so the server can get them later, no?
     
  9. Offline

    C4sad3i

    izarooni It will be stuck on the weapon. It will just read the message and see what level is req. If this won't work it will work with an config yeah c:
    EDIT; I don't want to add a description. I wan't it to read a already existing one!
     
  10. Offline

    htmlman1

    I can definitely do this, hold on. Though let me ask you something - how in the world is someone going to get 24791 levels?

    Here's what I came up with, which fulfills your request. If you want it, I can send you the file.


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 9, 2016
  11. Offline

    xXSilverswordXx

    htmlman1 wow great!
    please make it work for armour as well :3
    If possible add a "your level is too low message" (definable in config)
     
  12. Offline

    htmlman1

    Oh, ok. For armour, when the user attempts to put it on, it'll snap back to its original spot and they will get a "your level is too low."

    Currently, the message they get is "You do not have enough experience to use this item," but I can change it to something like "You need x more levels to use this item." Or whatever. I suppose I could add a config file.
     
  13. Offline

    xXSilverswordXx

    Yeah, that would be great
     
  14. Offline

    htmlman1

    Alright, I've added both of these, along with a short little config:
    Code:
    # Whether or not to play sounds when item usage is denied
    # Possible values: true | false
     
    PlayNastySound: true
     
    # The message you display when the user can't use the item
    # Use %p% as a placeholder for the player's username, and %n% as the amount of levels they lack.
     
    ItemDenialMessage: You need %n% more levels to use this item, %p%!
    Armor usage and stuff is fixed. Right now the usage of tools, weapons, and armor is restricted. If I had to, I could extend this restriction to food and potions, and even block placing.

    I'd publish another video, but I'm too lazy right now. C4sad3i , pm me if you want the link (along with anyone else who wants it.)

    EDIT: Just in case you want to know, the current file size of this plugin is 7KB.
     
  15. Online

    timtower Moderator Moderator

  16. Offline

    htmlman1

  17. Online

    timtower Moderator Moderator

    htmlman1 Pretty much all plugins on this forum aren't approved. Most developers don't bother to make a dev.bukkit page either
     
  18. Offline

    htmlman1

    Ah, ok.
     
  19. Offline

    xXSilverswordXx

    thanks :D i cant test it till 3:30 though :/ (7am 4 me :3)
     
  20. Offline

    C4sad3i

    htmlman1 RPG servers, the max level of players in mc is that level thats why c: EDIT; Is there any commands. And does it listen to the already existing line? c;
     
  21. Offline

    htmlman1

    There are no commands right now. Basically what it does is every time a user tries to use a item, the plugin scans the item's lore for "*REQ; LVL 456*" or whatever, and then if that is there, it checks if the player has that amount of exp. If the player does, then the plugin won't keep them from using it. If there isn't, the plugin won't let the player use it.

    If you want any changes, I'd be happy to make them.
     
  22. Offline

    C4sad3i

    htmlman1 That sounds absolutly perfect. I'll check it when I'm back to work. (I'm actually working with my server right now as a summer project so I like to call it my summer jobb c:) Made 65$ the first 10 days it was up ^^ Really proud over it. But yeah thanks alot!!! I'll check it out as fast as possible ^^
    EDIT; and also. the levels of my players keep disapering. Do you know why?? (Haven't installed the plugin yet. Nothing with that todo, just asking)
     
  23. Offline

    htmlman1

    No problem! :) Also, about the experience - is the disappearance completely random, or does it always happen after some specific event? If it's random, it's probably whatever plugin manages your players' experience.

    But in short, no, I can't really pinpoint the reason for this without more knowledge about your server (what plugins you use, etc.)
     
  24. Offline

    C4sad3i

    htmlman1 Could i send you a list in pm a bit later? c:
     
  25. Offline

    htmlman1

    Sure, no problem.
     
  26. Offline

    C4sad3i

    htmlman1 Okey, thanks. Trying to find the host website. I'm not at home so yeah.. But I'll pm you the plugins when I've found them.
     
  27. Offline

    htmlman1

    Alright. (Not trying to patronize you or anything, but in case you didn't know, to get a quick list of the plugins you have, just type /plugins)

    Er, no. But anyway - can't you just run the command from the console? (Console = god)

    Also...

    The magical deity Google has whispered in my ear that the command is "/pex user C4sad3i bukkit.command.plugins".

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 9, 2016
  28. Offline

    ChocolateChoo

    htmlman1 This plugin seems really well done, Id just want to know what do we need to put in the lore to add the level restriction AND (if there are any) what the the permission nodes? PEX specifically.
     
  29. Offline

    Macaron

    htmlman1
    I'm the one that posted in your profile. I don't mean to rush you... but are you still gonna modify the plugin for me? I need to know your answer so I can decide if I need to find someone else.
     
  30. Offline

    htmlman1

    You'll probably need to find someone else. Sorry :/
    There are no perms nodes. For the level restrictions, put this in the lore:

    *REQ; LVL 15*

    Of course you can replace 15 with whatever you like.
     

Share This Page