Introducing Recommended Builds

Discussion in 'Community News and Announcements' started by EvilSeph, Feb 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    With the recent move to http://dl.bukkit.org, we're happy to announce a change to our building system that people have been wanting for a while now: recommended builds. The way the new system will work is that every week or so we'll be picking a CraftBukkit build and marking it as recommended so that plugin developers have an idea of what build they should be up to date with.

    Recommended versions will be what we consider a "stable" revision of CraftBukkit. This means that we expect plugin developers to support the latest Recommended version at the very least. Plugin developers then also have the option of developing and releasing for the latest builds to help us test and mold the API, but we cannot guarantee any form of stability with development builds.

    Since we only just recently deployed the Recommended builds system, things will not work as we planned: it is highly likely plugin developers will not be caught up for a few days but we hope this change will provide our community with a more stable "release" cycle to work with.

    The latest recommended build can always be found here:
    http://dl.bukkit.org/downloads/craftbukkit/list/rb/

    With this link always pointing to the latest Recommended build download:
    http://cbukk.it/craftbukkit.jar

    And here's an RSS feed for the Recommended Builds system that you can subscribe to for notifications:
    http://ci.bukkit.org/other/latest_recommended.rss

    At the moment we have chosen to keep development builds available to the general public, but this may be changing in the future.
     
  2. Offline

    woodzy

    LOL, i hope the logblock and jail get pdated first XD
     
    Last edited by a moderator: Dec 14, 2016
  3. Offline

    invis45

    is it updated to 1.4 yet
     
  4. Offline

    danirunes

    wait, i still don't get it, the bukkit version 0.0.1 which u posted is the newest? cuz if it is i cant load it with the old bat file
     
  5. Offline

    VRYUKI

    Hmm...nope. won't load with the batch file, nor does it run when i try to replace it in my server. Even if I remove all plugins.
     
  6. Offline

    EvilSeph Retired Staff

    New Recommended Build: #612

    Plugins that work with 602 should work just fine. This new Recommended Build just provides Minecraft 1.4 update compatibility.
     
    Dan1234 likes this.
  7. Offline

    Live-Dimension

    I just downloaded it, it says the build is #609.

    Edit: Got the wrong number for the version, whoops!

    Craftbukkit version git-Bukkit-0.0.0-609-g39996e1-b612jnks (mc: 1.4)

    b612jnks is the version number, and not 0.0.0-609?

    Well, it still says minecraft 1.4, and it works.
     
  8. Offline

    Shilofax

    Just downloaded #612 and i am getting "Internal Server Error" Anyone else having this problem?
     
  9. Offline

    woodzy

    i run ubunto10_4 server and i have no issues at all =:)
    and were 1.4
     
  10. Offline

    Bjourk

    What's the best place to find update notes on the latest recommended build?
     
  11. Offline

    AnrDaemon

  12. Offline

    Jack Daun

    Sorry if this has already been asked but i am running 609 and it accepts 1.4 clients, will wolves spawn?
     
  13. Offline

    garglebutt

    yes
     
  14. Offline

    Lord Chaos

    I don't understand. I am downloading whats supposed to be version 612, but when the server starts up, its still 609. :(
     
  15. Offline

    cobra1162

    why do i level-seed= ?


    Thanks
     
  16. Offline

    Grum Bukkit Team Member

    New Recommended Build: #617

    Mostly fixes issues with plugins not loading when being old and not having an author defined in the plugin.yml.
     
    cjc343 and Manji like this.
  17. Offline

    cobra1162

    thanks
     
  18. Offline

    Lord Chaos

    This makes no sense. Now that it says #617 it downloads #612 instead...and when it was #612 I got #609.
     
  19. Offline

    Littlejth

    Look at the last number of the build tag, not the number in the middle. Also, does this mean that anything updated for 602 will work with 617?
     
  20. Offline

    NFFPokemon

    seems that noone is able to connect to my server after the update to 612.. idk if this is a problem on my end?
     
  21. Offline

    fudjy

    i just tryed to log onto my server
    i recieved the following message:

    Failed to connect: Internal Server Eror


    anyone care to explain? i have just updated to 612 btw
     
  22. Offline

    Donny

    I have yet to see it in any members though
     
  23. Offline

    Troopah

    Can someone help me? I'm on a mac and whenever I try to start my server on the recommened builds #612 and #617 their are no errors in the terminal, but when I try to connect to my server it just is stuck at the "connecting to server..." screen on minecraft.
     
  24. Offline

    thappy001


    Happened to me as well.
    Try removing all plugins from the server... ( the fastest and safest way is to rename your plugins folder to something like 'xplugins' or similar) and see if you can connect then.
     
  25. Offline

    EvilSeph Retired Staff

    Update to 617, we fixed a bug that would cause that error.
     
  26. Offline

    fudjy

    ok, thanks, ill download it now

    ok, thanks, downloaded and placed in server, works fine, thanks very much, will 1.4 features be in it?? like wolves etc?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 9, 2016
  27. Offline

    ArmEagle

    They should as far as I know.
     
  28. Offline

    Bufahad360

    I really needed this! Kept trying to see if the old build works every few hours, but now i dont have to! however i cant find any wolves in 1.4 update, and trust me i spent lots of time looking for one... Any advise??
     
  29. Offline

    TheBeefiest

    The wolves are in wooded areas, i saw two the first day i was playing.
     
  30. Offline

    HBlakeH

    When is there going to be a new build that works with all of my plugins? when I use the newest build it has only the original Mincraft server commands, which suck.
     
  31. Offline

    SpaceManiac

    @HBlakeH As soon as all of your plugins work with the new build. :)
     
Thread Status:
Not open for further replies.

Share This Page