Internal Error w/ Build 818 RECOMMENDED!??!?

Discussion in 'Bukkit Help' started by MikeA, May 31, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    When I update my server to the 818 recommended build, everyone that tries to join gets Internal Server Error and it says in console that the listener is already listening? This makes no sense...!

    What's the problem?
  2. Offline


    Check your processes for Java.exe, make sure that when the server was previously closed it didn't hang in the background?
  3. Offline


    It says something with syncing the inventories. I've tested the build in another directory on another port and it worked fine but it won't work with my regular world for some reason.

    Shouldn't there be a support team for bukkit? This is pretty lame.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  4. Offline


    if you delete you'r ".dat" file under "world/players" it can help. btw. take backup of you'r dat file first. because u will loose all the items u had on you when u delete it.. try that and see if that helps with ur world
  5. Offline


    this happens to everyone that tries to connect, not just me.
  6. Offline


    try with urself atleast.. if it helps..
  7. Offline


    No shit, I've tried over 30 times. It worked fine when I tested it on a test server but when I moved everything to my original directory and added the updated plugins it said Internal Error and noone could join.
  8. Offline


    Happening to me too.

    02:05:57 [INFO] Disconnecting Parker_yadigg [/]: Internal ser
    ver error
    02:05:57 [WARNING] Failed to handle packet: java.lang.IllegalArgumentException:
    Listener already listening
    java.lang.IllegalArgumentException: Listener already listening
            at net.minecraft.server.Container.a(SourceFile:32)
            at net.minecraft.server.EntityPlayer.syncInventory(
            at net.minecraft.server.NetLoginHandler.b(
            at net.minecraft.server.NetLoginHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:91)
            at net.minecraft.server.MinecraftServer.h(
    02:05:57 [INFO] Parker_yadigg lost connection: disconnect.endOfStream
  9. Offline


    Finally! You know how I feel :(.. You would think they would have people who know how to fix their wrapper.

    Or at least tell us what's wrong.
  10. Offline


    I AM A GENIUS! I hope this is your problem as well, it was the "openinv" plugin. Get that out of there!!!
    MiHo likes this.
  11. Offline


    Ohh shit you have to be kidding me.. ARE YOU KIDDING ME!?!?!?!? LMAO I wasted so many hours fucked up.
  12. Offline


    Was that it?
  13. Offline


    I'm updating now, I will tell you in a minute.

    Yes! It worked! Thank you for posting here LOL, you honestly saved me soo much time and anger :D!

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  14. Offline


    Thank you for your post :D
    I wanted to post my problem here, and than I found this thread, which solved my problem.

  15. Offline

    Daniel Few

    I'm still getting this error and i have OpenInv set to OpenInv.jar.s in plugins so it wont load:?
    Just trying now with ALL plugins disabled,
    any other ideas?
  16. Offline


  17. Offline


    OpenInv was updated so go ahead and download the new version and that should help. I had the exact same problem (I'd love for you guys to test if the new OpenInv version works as I can't get to my main computer for testing).

    *Edit: @jamietech me when you find a conclusion of the new version working please.
  18. Offline


    I just tested the 818 build for it and it works great :D
Thread Status:
Not open for further replies.

Share This Page