[INACTIVE][WGEN/MECH] StyxSpace v1.1 [TheOne] - Go to space! BananaSpace coming soon. [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Styx Reborn, Jun 13, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Styx Reborn

    StyxSpace - Version 1.1 [TheOne]
    What is StyxSpace, what can it be used for?
    StyxSpace is a plugin that allows generation of worlds that are "space", empty. Say you want to make a space station and some planets, you can do so with StyxSpace. We offer you space to build in, you make space really look like space. Freebuild servers (like Styx Reborn!) can use StyxSpace to give their players a world they can freely wander around and build amazing space
    related builds. Survival servers can use StyxSpace to give players a new world to explore.

    StyxSpace is very lightweight. It only offers a single command for everything. You can use other plugins like Inception to offer players a brand new way to
    go to space. For extra realism we have added spacehelmets & spacesuits to the plugin - without a
    helmet/suit you won't be able to survive in space for long! StyxSpace has a great amount of
    configuration to make your space worlds feel exactly how you want them. You might be wondering what the space StyxSpace creates looks like.. Below are some screenshots with planets, asteroids and all that good stuff StyxSpace has to offer!
    Screenshots of StyxSpace (open)

    As you can see from the last screenshot, StyxSpace now has Pail (a Bukkit GUI) support. From there you can change StyxSpace settings and save them. This feature is still a work in progress but should be finished soon!

    StyxSpace also has Spout-support. If you have Spout installed, and your players use Spoutcraft, you can now remove clouds from spaceworlds! This is toggleable in the configuration file though, so don't worry.
    Download StyxSpace v1.1 [TheOne]
    Download dev builds or older versions
    Before asking questions, please read the wiki here!
    (includes installation instructions!)

    Full permission node and command list (open)

    2. commands:
    3. space:
    4. description: Go to space, back to earth etc.
    5. usage: |
    6. /<command> <enter> [spaceworld] - Go to a space world
    7. /<command> <back> - Go back where you were
    8. /<command> <help>

    Permission groups
    • styxspace.* - Access to all StyxSpace commands
    • styxspace.teleport.* - Access to all teleportation commands (/space enter, /space back etc)
    • styxspace.portal.* - Access to portal creation, usage and removal
    Single permissions
    • styxspace.portal.use
    • styxspace.portal.create
    • styxspace.portal.remove
    • styxspace.teleport.enter
    • styxspace.teleport.exit

    How to report bugs!
    Please use this form when reporting bugs:
    [b]StyxSpace Version:[/b]
    [b]CraftBukkit Version:[/b]
    [b]Description of bug:[/b]
    [b]How to reproduce:[/b]
    [b]Errors in log about StyxSpace? If yes, paste it here:[/b]

    Version 1.1 [TheOne] The biggest update ever.:
    -Added support for multiple space worlds
    -Added glowstone generation, configurable spawning chance
    -Added "asteroid" generation, configurable spawning chance
    -Added nethermode, makes space have nether environment (it's a lot of fun!)
    -Added a tiny little Spout feature, no clouds. Requires Spout & Spoutcraft (client mod)
    -Added Pail (Bukkit GUI) support.
    -Added permission nodes to plugin.yml
    -Added SpaceWorldHandler and SpaceConfigHandler (API)

    -Changed config.yml a lot. Please make a new config when updating from older versions to 1.1.
    -Planet generation configuration is in its own file now, global
    -Helmet block id, armortype, and givehelmet/suit are now global
    -Changed some commands because of multiple space world support
    -Changed some permission nodes, added permission groups (SuperPerms)
    -Changed the API around a bit for multiple space worlds (API)
    -Cleaned the code up a cheeseload

    -Removed some old code that is no longer used
    -Removed /space reload as it didn't work like it should
    -Removed teleporting others to space as it was a hacky command
    -Removed a command no one has yet found, added sometime in 0.4
    -Removed SpaceHandler (API)
    -Removed some old methods because of code changes (API)

    Version 1.0 [Graduation]:
    -Added /space help & reload (permission nodes under download link)
    -Possibly patched some problems with area detection
    -Started new plugin, 'StyxFlight'
    -Expanded & modified the API, more info
    -Prepared coming API changes (SpacePlayer)
    -Made plugin "open source", more info


    Older versions of StyxSpace (open)

    Version 0.9_5 [Netherrack]:
    -Readded spawn block generation on teleport to space removed in 0.5
    Version 0.9_4 [Netherrack]:
    -Fixed errors if a player dies while suffocating in space
    Version 0.9_3 [Netherrack]:
    -Changed the way helmets are handled
    Version 0.9_2 [Netherrack]:
    -Implemented Bukkit's permission system
    -Added hasPermission(String permission, Player player) to API (SpacePlayer)
    Version 0.9_1 [Netherrack]:
    -Fixed only ops or players with permission being able to break a sign
    Version 0.9 [Netherrack]:
    -Added portals, more information here
    -Added spacesuits (just as configurable as helmets)
    -Added /space playername to teleport other players to space, permission node:

    -Implemented a few missing API methods
    -Fixed errors when changing world while suffocating
    -Fixed some problems with message order (permissions)
    -Removed unused configuration for messages
    -Changed colors of other messages to red/green

    Version 0.8_1 [Adventor]:
    -Fixed helmet given regardless of configuration settings
    Version 0.8 [Adventor]:
    NOTE: Please delete your configuration file for a new one to be generated!
    -Rewrote most of the code for optimization
    -Organized configuration file
    -Pumpkinhelmet replaced with blockid
    -Fixed endless loop of errors when a player quits while in 'drowning' mode
    -Implemented most of the API, more information here

    Version 0.7_4-9:
    -Implemented API (for usage)
    -Fixed /space back working regardless of the permission node
    Version 0.7_3-9:
    -Added API, for more information, click here
    Version 0.7_2 (URGENT):
    -Fixed fix of errors with /space
    Version 0.7:
    -Added new config setting, helmetrequired: true/false: defaults to false
    -Givehelmet now defaults to false
    -Gave the death a drowning effect
    -Cleaned up code

    Version 0.6:
    -Made messages configurable
    -Fixed dying after dying for having no helmet

    Version 0.5:
    -Added planet generation, extremely configurable, defaults to on
    -Added /space back, permission node: styxspace.teleport.exit
    -Cleaned up the code
    -No more forced spawnblock, generated only once
    -No bugfixes, sorry

    Version 0.4_2:
    -Fixed errors with breathable areas
    Version 0.4_1:
    -Fixed internal server errors when leaving space
    Version 0.4:
    -Brought back settings for hostile and neutral mobs
    -Breathable areas, don't use glass helmets anymore!
    -Fixed material duplication bug
    -Fixed configuration file resetting to default on reload
    -Removed BukkitContrib requirement
    -Made helmet checks more efficient
    -Prepared for 0.4_1 later this week
    -New permission node for /space: styxspace.teleport.enter, preparing for new commands

    Version 0.3_2:
    -Fixed BukkitContrib loading after StyxSpace
    -Fixed grammar errors
    Version 0.3_1:
    -Made chunk generator lightweight
    Version 0.3:
    -Pumpkins as spacehelmets
    -Configurable autogive of spacehelmets
    -Fixed players running out of "air" to breathe when clicking a spot in their inventory (without
    actually removing the helmet)
    -Attempted fix of BukkitContrib problems
    -Any teleport to space will be recognized and will show welcome messages etc.

    Version 0.2
    -Configurable weather (true/false)
    -Configurable mobs (true/false)
    -Configurable night only (true/false)
    -Configurable world name
    -Configurable space helmets (true/false)
    -Space helmets, if you take it off your head you will die
    -Fixed void kicking for flying

    Version 0.1_3:
    -Only pigs spawn in space
    -No rain/thunder/snow in space
    Version 0.1_2:
    -/space now defaults to OP if Permissions is not installed
    Version 0.1_1:
    -Spawngriefprotection will replace the following: sign, ladder, water, lava with stone
    -Disabled /space when the player is in space (configurable in v0.2)
    Version 0.1:
    -Initial release of StyxSpace
  2. Offline


    Whenever I am trying to use the plugin on my server, I get:

    Could not load 'plugins/StyxSpace.jar' in folder 'plugins':
    at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
    at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
    at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
    at java.lang.reflect.Constructor.newInstance(Constructor.java:532)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:172)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:194)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:117)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:109)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:232)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:219)
    at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:146)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:283)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:422)
    Caused by: java.lang.NoClassDefFoundError: org/bukkitcontrib/event/inventory/InventoryListener
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    at me.iffa.StyxSpace.StyxSpace.<init>(StyxSpace.java:90)
    ... 13 more
    Caused by: java.lang.ClassNotFoundException: org.bukkitcontrib.event.inventory.InventoryListener
    at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:266)

    Please help.
  3. Offline

    Styx Reborn

    You need BukkitContrib (a plugin) from here
  4. Offline


    I have that, and it still doesn't work.
    I don't known if It just loads later or not.
  5. Offline

    Styx Reborn

    BukkitContrib should load before StyxSpace. You can always try restarting a few times and see if it works.
  6. Offline


    Ok, I try that.
    Edit: yeah that is not working. Still get the same error and BukkitContrib is always loading after, and i don't know how to force it to load first. In fact, your plugin seams to be the first of my plugins that is loading.
  7. Offline


    centered text in main post? really?

    and you know you can do this
    • blah
    • blah
    • blah
    instead of
    - blah
    - blah

  8. Offline

    Styx Reborn

    I hate the whatever editor is and no way I'm using BBcode to do all that...
    I <3 centered
  9. Offline


    After many restarts and reloads of both the server and the plugins, your plugin will not work, and BukkitContrib still loads after without StyxSpace recognizing it.
  10. Offline

    Styx Reborn

    It should not be doing that. When I tested it StyxSpace loaded after BukkitContrib. I'll see what I can do for 0.3 or 0.2_1 :/
  11. Offline


    Ok Thank you
  12. Offline


    Why do i get this error?

    Attached Files:

  13. Offline


    LightKing, I have the same problem. I think in fact that this plugin does not use the new BukkitContrib, and thus does not load properly.
  14. Offline

    Styx Reborn

    You need CraftBukkit build 860 to use this plugin. Error comes from chunk generator class missing (meaning that you're running 818 or some old build)
  15. Offline


    perfect to use with inception plugin, thanks! :)
  16. Offline

    Styx Reborn

    Currently updating to 0.3 - any teleport (from Inception.. anything) will be "recognized" by StyxSpace. Tried fixing the BukkitContrib problem for some people and something else I keep forgetting. Oh.. pumpkin helmets! (and you can turn autogive on/off)
  17. Offline


    Are players able to fly? If not could you add something like that?
  18. Offline

    Styx Reborn

    Ah... gravity in space - another thing I'll consider adding. Updated main post like.. a lot.
    LtdSupply likes this.
  19. Offline


    I was thinking about this too. I wasn't sure if you could even do this, but I think it'd be awesome to see weightlessness while in space. I'm building an Aurora Class Battle Cruiser in space and I'd love to see no gravity/oxygen in open areas in space, and enclosed areas having some gravity and are breathable. As I said, I'm not even sure how that'd be possible as I'm no modder. [redflower]
  20. Offline


    I am using version 0.3 and I'm still having the inventory/running out of air problem

    Version 0.3:
    -Pumpkins as spacehelmets
    -Configurable autogive of spacehelmets
    -Fixed players running out of "air" to breathe when clicking a spot in their inventory (without actually removing the helmet)
    -Attempted fix of BukkitContrib problems
    -Any teleport to space will be recognized and will show welcome messages etc.

    There is no console error
  21. Offline


    Again, the plugin does not work for me, and I get the same error that I got before. Even with the update, BukkitContrib 0.0.5 is not recognized by the plugin, and the plugin tries to load first. I tried other BukkitContrib dependent plugins and they worked, but not this plugin. I really want this plugin to work, but it just wouldn't work for my server.
  22. Offline

    Styx Reborn

    I tested it multiple times - it does work... do you actually have a helmet at the time?

    It works for me and seems to work for everyone else.. try deleting plugins and only leaving StyxSpace + BukkitContrib. If it works, then keep adding plugins until you find the one that does this.
  23. Offline


    Ok thank you

    Edit: I tried using only BukkitContrib and StyxSpace, and my server will not work. I put the latest recommended build, lastest plugin, and a new map, without any change. i still get the same error. But I think the problem lies in BukkitContrib.
  24. Offline


    hey can you make it so if your in a area with no holes you can remove your helmet?
  25. Offline


    I'm not sure what I did but it works now lol anyways, this plugin is amazing! Keep up the good work :D
  26. Offline

    Styx Reborn

    That would be very hard to code... In fact I don't think it's possible at all. Sorry :(
  27. Offline


    Thanks, after getting craftbukkit v.860, it loads and works properly now.\

    Oh and, wats the permission node ^-^? i found it before, but now i cant find it
  28. Offline


    I've found that now that I've started building in the area I can breathe without the helmet. Quite odd, but probably useful for the moment ;P At least until my ship is done, then I'll tackle the issue.
  29. Offline

    Styx Reborn

    Oh.. forgot that in the new post (I believe) - styxspace.use
  30. Offline


    Absolutely not working for me :(
  31. Offline


    Thanks for the shout-out! Favor returned :)
Thread Status:
Not open for further replies.

Share This Page