[INACTIVE][TP] SimpleWarp v2.3 - Simple Warping for the masses [1000] [UNSUPPORTED]

Discussion in 'Inactive/Unsupported Plugins' started by rymate1234, Jul 19, 2011.

  1. Offline


    SimpleWarp v2.3 - Simple Warping for the masses:

    Version: v2.3
    This is my first plugin, so be nice :)
    SimpleWarp is a simple plugin for handling warps. It has 3 commands:
    • /warp <warpname> - Warps to the specified warp (Permissions node warp.go)
    • /setwarp <warpname> - Creates a warp at your location (Permissions node warp.set)
    • /listwarps - List the first 8 warps in your warps.txt file. (Permissions node warp.list)
    The iConomy support is easily set up in the config file generated in the SimpleWarp folder, there you can set the price of warping :)

    • Warping to a warp
    • Creating new warps
    • Permissions
    • Warp listing
    • Economy Support
    Download it now!!! (Mediafire turns it into a .zip)
    Source Code!
    Experimental Release (Plus information)

    ToDo List (In order of importance):
    Red is not done, Orange is in progress, green is done (and coming in the next version!)

    • Configuration File
    • iConomy support
    • MySQL/SQLite warp storage
    • Warp Lists (/listwarps shows a list of warps) DONE! It can show up to 8 warps :p
    • Multiple warp list pages
    Version 2.3:
    • Added defaulting to OP functionality for people without permissions
    Read More.... (open)

    Version 2.2:
    • Fixed permissions node for /warp not working
    • Added feature for /warp that only warps you if there is enough headroom (Thanks to garbagemule for that :D)
    Version 2.1:
    • Fixed a major bug with /warp
    Version 2:
    • Adds a Config file!
    • Permissions 3.x support!
    • Economy support!
    • Warp listing!
    Version 1

    • Initial Release
    chapter_5 likes this.
  2. Offline


    wow, this is so simple, slightly less features than the warp plugin i use, but it has permissions, does it also default to op if a permissions plugin is not found? and one more thing, FIRST REPLY! but seriously, great job, for your first plugin, this works amazingly smooth. And i believe dropbox also has a way to record how many people download it, but i couldn't tell you how off the top of my head.
    rymate1234 likes this.
  3. Offline


    Thanks for the feedback :D

    So, any suggestions on how I could improve this plugin?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  4. Offline


    Great plugin, works smooth, everything i always wanted for my home mc server :p only suggestion would be to work on the list warps feature because it can be hard to remember exactly what warps are available. Good work so far though!
  5. Offline


    warp remove
    warp list
    would still missing
  6. Offline


    maybe a way to privatize a warp, or list players who can use the warp, i havn't ever seen a warp plugin that could do that, so that would be a nice feature, for semi private warps.
  7. Offline

    Oscar Varno

  8. Offline


    hey @rymate1234 congrats on the plugin dev title
  9. Offline


    does it work on 953?
  10. Offline


    I don't know about that, its not tested :p

    Go try and see, it should work :D
  11. Offline


    Hey guys I'm really new to dealing with how Minecraft is coded, myself and a few of my friends have a server I host, and everytime I've tried to add a plug-in I get an error.

    Any help anyone can offer is greatly appreciated I'd like to be able to add plugins, and I figured I'd start with this one because of how useful it is.
  12. Offline


    What version of bukkit you using? (type version into the console)
  13. Offline


  14. Offline



    No idea what may be causing that error. What other plugins do you have?
  15. Offline


    Just the PermissionsBukkit1.1
    rymate1234 likes this.
  16. Offline


    Try downloading now
  17. Offline


    rymate1234 could you help me when i try and set your plugin up with permsisons i get the same error as jj12345

    and this is my permissions groups file

            default: true
                prefix: '&7'
                suffix: '&f'
                build: false
            default: false
                prefix: '&1'
                suffix: '&f'
                build: true
                - citizen
                - 'warpplugin.warp'
                - 'econplugin.basic.*'
            default: false
                prefix: '&5'
                suffix: '&f'
                build: true
                - Builder
                - 'modplugin.ban'
                - 'modplugin.kick'
                - 'modplugin.unban'
                - 'set.warp'
            default: false
                prefix: '&4'
                suffix: '&f'
                build: true
                - '*'
  18. Offline


    Firstly, the plugin is not compatible with Permissions 3.x, it is only compatible with the Bukkit Permissions API.

    Secondly, the error that you and @JJ12345 had is due to MediaFire thinking my plugin was a .zip file. Assuming you downloaded it from MediaFire, I strongly recommend you re-download from the new link. :)
  19. Offline


    I wished this was the case, I am having the same error even with your "New Version" In the download..
  20. Offline


    You might want to take a look at this plugin, which shares the same name. It looks like what you are doing is the same thing. Unfortunately, the author of that plugin stopped updating it. It does still work with the latest CraftBukkit, however, and I currently run it on my server.

    If you add the features (all 4 commands) of the original SimpleWarp, I'm sure you'll find yourself a steady following. I'll personally appreciate it very much. I was planning to update the original SimpleWarp, but just haven't had the time.

    The plugin.yml file of your plugin needs to be updated. It refers to homes instead of warp points.

    Do you plan to release the source to this plugin?

  21. Offline


    Actually, its the same version, just that it downloads as a jar file :p

    Also, your error actually doesn't mention any of my plugin source files, so I really do not know what the problem is, it works perfectly on my laptop and my server.

    Also, you said this:
    Does that mean it happens with every plugin you have tried? If so it isn't a problem with my plugin, and you should ask in Bukkit Help

    Yeah, my plugin was originally going to be a home plugin, but I decided to do a warp plugin. I only planned it for usage on my server. I may add Home functionality in the future though :D
    And all them other features :D

    And I am not releasing the source of the plugin until I clean it up a bit, its a complete mess xD

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  22. Offline


    Thanks man, I've already started a thread on it.
  23. Offline


    Can you please create a permission node to see who can use what warp and when?
  24. Offline


    is there a permissions node for warping? not /warpset. just the /warp command.
  25. Offline


    am i too stupid to use this plugin?
    i am admin on my server.
    i type "/setwarp wood"
    and only get the response "/setwarp <warpname>"
    what did i do wrong? i wanted to create a warp with the name "wood"
  26. Offline


    Are you an Op? (i.e. op <yournamehere> in console)
    This plug in is not compatible with permissions 3.x

    Also, I am working on version 2 of this plugin, which will include:
    • /listwarps !
    • iConomy Support!
    • Customisable messages!
    After that, who knows? Maybe I'll add MySQL support
  27. Offline


    what version of Permissions do you need?
    i tried to use /setwarp Hub and it said an internal error had occured, so I'm guessing my permissions is not the right version?
  28. Offline


  29. Offline


    yea it didn't work :(
  30. Offline


    Ddin't think it would.

    Try upgrading to Build 1000 (Latest Recommended Build)

Share This Page